Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10

Find everything you need for the Galaxy S5 and discuss it in our S5 forum!
Have you seen that OnePlus One's awesome camera?? The forum is over here!

test: Reply
 
LinkBack Thread Tools
Old July 5th, 2011, 07:49 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jul 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Call Log not working correctly

Hello all,

I just recently upgraded my X10 to 2.1-update 1. I am on baseband version 2.1.65, kernel version 2.6.29, and Build Number 2.1.A.0.492.

My problem is with the call log. It seems like every third or fourth call is not adding to it. It's like it just randomly decides to add calls to the log when it feels like it. I have made several calls in the last day-plus and only one of them is in the log. It will show missed calls but incoming and outgoing are at random. Is there a setting that I am missing that I can change?

metalflyer is offline  
Reply With Quote
sponsored links
Old July 5th, 2011, 10:28 PM   #2 (permalink)
Member
 
Jake-SonyXperia's Avatar
 
Join Date: Jun 2011
Posts: 205
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 22 Times in 21 Posts
Default

In this situation I suggest a Factory Data Reset as it seems the application is not communicating with the handsets OS correctly.

Menu > Settings > Privacy > Factory Data Reset ( Note: this will remove all data from the handsets memory but will not touch a SIM card or Memory Stick.)

Let me know how you get on.
Jake-SonyXperia is offline  
Reply With Quote
Old July 19th, 2011, 03:06 AM   #3 (permalink)
New Member
 
Join Date: Jul 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

As I am also facing the same problem and also done the Factory Data Reset, Still the problem exists. Any other solution please?
maran_sm is offline  
Reply With Quote
Old July 19th, 2011, 09:24 AM   #4 (permalink)
Senior Member
 
beau420's Avatar
 
Join Date: Nov 2010
Location: Ottawa
Posts: 1,105
 
Device(s): x10a 2.3.3 (with x10i ROM from T.E.A.M. ROM V4.0)
Carrier: Not Provided

Thanks: 29
Thanked 177 Times in 166 Posts
Default

Quote:
Originally Posted by maran_sm View Post
As I am also facing the same problem and also done the Factory Data Reset, Still the problem exists. Any other solution please?
Hopefully not this -

Main: Entries missing from Call Log and...

I would go beyond a stupid reset.

First off. My Call Log is fine and has been fine since day one around 10 months ago.

I would go to the next step. Download SEUS from Sony and install it

Xperia? X10 - Update Service - Downloads - Mobile phones - Support - Sony Ericsson

Then do a full repair on the phone (which will reinstall the OS completely by redownloading and reinstalling it)

You aren't using any sort of Task Manager or App Killer are you?
beau420 is offline  
Reply With Quote
Reply

Sony Ericsson Xperia X10
Current Rating:
Rate this Phone:

The Xperia X10 announced November 2009 was Sony Ericssons first flagship phone running the Android OS and at the time of announcement - the first Android handset to come with a 1 GHz Snapdragon Processor setting a path and standard for other 'h... Read More



Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 02:03 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.