Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old July 22nd, 2011, 10:00 AM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jul 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Xperia X10 Color Problem after update

Hey i recently updated my phone in the last 24 hours and the colouring in the screen has gone negative like when you take a photo in the light it'll show up black and peoples faces would be blue and even the photos i took before are showing up that colour.

Is there any app to get my colour back to normal or go in to settings or has my screen just broke coincidentally after an update to Android 2.1?

Goughy99 is offline  
Reply With Quote
sponsored links
Old July 22nd, 2011, 10:16 AM   #2 (permalink)
Senior Member
 
beau420's Avatar
 
Join Date: Nov 2010
Location: Ottawa
Posts: 1,105
 
Device(s): x10a 2.3.3 (with x10i ROM from T.E.A.M. ROM V4.0)
Carrier: Not Provided

Thanks: 29
Thanked 177 Times in 166 Posts
Default

Quote:
Originally Posted by Goughy99 View Post
Hey i recently updated my phone in the last 24 hours and the colouring in the screen has gone negative like when you take a photo in the light it'll show up black and peoples faces would be blue and even the photos i took before are showing up that colour.

Is there any app to get my colour back to normal or go in to settings or has my screen just broke coincidentally after an update to Android 2.1?
My guess is a setting in the default camera app.

To confirm, download another camera app.

Download Camera 360 or RetroCamera.

Try those out.

If the problem persists in Camera 360 or RetroCamera, then I would probably download SEUS from Sony and do a full repair/reflash.....just remember to back everything up if you have to go that route.
beau420 is offline  
Reply With Quote
Old July 22nd, 2011, 10:21 AM   #3 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jul 2011
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by beau420 View Post
My guess is a setting in the default camera app.

To confirm, download another camera app.

Download Camera 360 or RetroCamera.

Try those out.

If the problem persists in Camera 360 or RetroCamera, then I would probably download SEUS from Sony and do a full repair/reflash.....just remember to back everything up if you have to go that route.
I don't think it's the camera app as it's also on the front page where my background is also showing negative instead of black it's showing up white, I also have tried a full repair but it's just ended up the same. I don't know how to get the colour back to normal :\
Goughy99 is offline  
Last edited by Goughy99; July 22nd, 2011 at 10:26 AM.
Reply With Quote
Old July 22nd, 2011, 11:04 AM   #4 (permalink)
Senior Member
 
beau420's Avatar
 
Join Date: Nov 2010
Location: Ottawa
Posts: 1,105
 
Device(s): x10a 2.3.3 (with x10i ROM from T.E.A.M. ROM V4.0)
Carrier: Not Provided

Thanks: 29
Thanked 177 Times in 166 Posts
Default

Quote:
Originally Posted by Goughy99 View Post
I don't think it's the camera app as it's also on the front page where my background is also showing negative instead of black it's showing up white, I also have tried a full repair but it's just ended up the same. I don't know how to get the colour back to normal :\
If you tried a Factory Reset or tried to repair using PC Companion, it is not the same as downloading and installing SEUS from Sony and doing a full repair using it.

How did you do a full repair?
beau420 is offline  
Reply With Quote
Old July 23rd, 2011, 02:00 PM   #5 (permalink)
Member
 
Join Date: Nov 2010
Location: ...HOME...:P
Posts: 270
 
Device(s): Sony Ericsson Xperia X10i
Carrier: Not Provided

Thanks: 17
Thanked 25 Times in 24 Posts
Send a message via MSN to Z3US Send a message via Yahoo to Z3US mayank1222@gmail.com
Default

if nothing goes right go left..lol

btw, just follow what beau420 said.If i still got problem go to SE store and ask for a replacement.
__________________
GOOD POSTS: THANKS

Bad Posts
: REPORT
Z3US is offline  
Reply With Quote
Reply

Sony Ericsson Xperia X10
Current Rating:
Rate this Phone:

The Xperia X10 announced November 2009 was Sony Ericssons first flagship phone running the Android OS and at the time of announcement - the first Android handset to come with a 1 GHz Snapdragon Processor setting a path and standard for other 'h... Read More



Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 05:25 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.