Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

test: Reply
 
LinkBack Thread Tools
Old August 31st, 2011, 05:57 AM   #1 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Aug 2011
Posts: 25
 
Device(s): Sony Xperia Z (UK Sim Free)
Carrier: Virgin Mobile

Thanks: 3
Thanked 0 Times in 0 Posts
Question Xperia X10 will not connect to PC via USB (unrecognised device)

I have had my X10 for just 2 months and ever since I have had it the phone will not connect to my PC using the usb cable, I have downloaded the latest Sony software such as the Update program and also PC Companion.

When I connect the phone to my PC running windows 7 it shows as installing the drivers but then says error and tells me "unrecognised device" I have this error showing up in device manager.

However when I try this on my freinds PC which is also running windows 7 and it connects fine without any problems I have since tried it on my wifes Laptop running Windows XP Home and it says the same "unrecognised device" this is the same with the other PC we have.

I even took the phone to a computer shop where they tried it on 3 of their machines and they could not get it to work again "unrecognised device" being the error.

It has become a real pain and I have now had to download an app called "My Phone Explorer" onto my phone and also install this onto my PC to enable me to transfer large files from my phone but via my wireless router/network.

I feel that it should just work as I have never had issues with phones like this before they have just been plug n play.

I have been onto Sony and they say they will look at the phone but will charge me if it works which knowing my luck it will, as it works on my friends pc without a problem so if it works ok on theirs then there cant be anything wrong with the phone.

Sony just tell me that the drivers are all built into the software program that you download and say my friend must have something different on their machine to make the phone work. Its so frustrating as it only seems to like 1 PC out of several.

If anyone can help with this or has a solution it would be greatly appreciated as I feel if I ever sold my phone then the new keeper would be unhappy as part of having phones like this with lots of memory you would expect them to connect to a PC without all these issues.

I have heard Sony are going to be bringing out new software soon which may cure this issue, does anyone know when to expect this new software.

Finally I have unmounted the SD card in my phone but still get the "unrecognised device" error when connection via USB.

Thanks everyone in advance

justinbarrow is offline  
Reply With Quote
sponsored links
Old August 31st, 2011, 06:05 AM   #2 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Aug 2011
Posts: 25
 
Device(s): Sony Xperia Z (UK Sim Free)
Carrier: Virgin Mobile

Thanks: 3
Thanked 0 Times in 0 Posts
Default

Forgot to mention, Thanks to my friends PC I have managed to get Android Gingerbread 2.3.3 onto the phone so it is using the latest software and the phone has never been rooted.

Thanks again.
justinbarrow is offline  
Reply With Quote
Old August 31st, 2011, 07:18 AM   #3 (permalink)
Senior Member
 
beau420's Avatar
 
Join Date: Nov 2010
Location: Ottawa
Posts: 1,105
 
Device(s): x10a 2.3.3 (with x10i ROM from T.E.A.M. ROM V4.0)
Carrier: Not Provided

Thanks: 29
Thanked 177 Times in 166 Posts
Default

Quote:
Originally Posted by justinbarrow View Post
Forgot to mention, Thanks to my friends PC I have managed to get Android Gingerbread 2.3.3 onto the phone so it is using the latest software and the phone has never been rooted.

Thanks again.
So, your phone doesn't work on your windows 7 computer or xp computer or multiple computers in a store, but it works on your buddies computer?

Are you always using the same USB cable?

Always try plugging it in to different USB ports....make sure you aren't using a HUB or anything. If you are only trying to use the USB ports on the front of a computer, try the back.

I would suggest using a different USB cable.

Does the phone still charge?
beau420 is offline  
Reply With Quote
The Following User Says Thank You to beau420 For This Useful Post:
justinbarrow (August 31st, 2011)
Old August 31st, 2011, 09:15 AM   #4 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Aug 2011
Posts: 25
 
Device(s): Sony Xperia Z (UK Sim Free)
Carrier: Virgin Mobile

Thanks: 3
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by beau420 View Post
So, your phone doesn't work on your windows 7 computer or xp computer or multiple computers in a store, but it works on your buddies computer?

Are you always using the same USB cable?

Always try plugging it in to different USB ports....make sure you aren't using a HUB or anything. If you are only trying to use the USB ports on the front of a computer, try the back.

I would suggest using a different USB cable.

Does the phone still charge?
I am using the same USB cable each time, would this make a difference? I have tried the USB ports on the back of my pc and these are the same still get the unrecognised error.

When connected to a PC the top LED is orange in colour and the battery appears not to be charging.

I will try with another cable and get back to you - thanks.
justinbarrow is offline  
Last edited by justinbarrow; August 31st, 2011 at 09:28 AM.
Reply With Quote
Old August 31st, 2011, 04:35 PM   #5 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Aug 2011
Posts: 25
 
Device(s): Sony Xperia Z (UK Sim Free)
Carrier: Virgin Mobile

Thanks: 3
Thanked 0 Times in 0 Posts
Thumbs up

Quote:
Originally Posted by beau420 View Post
So, your phone doesn't work on your windows 7 computer or xp computer or multiple computers in a store, but it works on your buddies computer?

Are you always using the same USB cable?

I would suggest using a different USB cable.

Does the phone still charge?
Thank you! it was a faulty USB cable i bought a new one and straight away it connects to all computers I was told some of the data pins may have been faulty but the charging pins were fine this explains why it charged from the mains but would not work via USB.

The lead was brand new with the phone 2 months ago and I have always had this issue since day 1, it must of been a faulty lead from the factory as I have always been very careful plugging it in and out of the phone after hearing of lots of issues with this phones charging port.

Thanks again, just goes to show what a difference these forums and a new cable can make. I am also glad I didnt send it back to sony as I may have been charged as they would of just wanted me to send the handset back without any cables and used their own and found nothing wrong.

Heres an interactive pint on me lol, Thanks again.
justinbarrow is offline  
Reply With Quote
Old August 31st, 2011, 10:51 PM   #6 (permalink)
Senior Member
 
beau420's Avatar
 
Join Date: Nov 2010
Location: Ottawa
Posts: 1,105
 
Device(s): x10a 2.3.3 (with x10i ROM from T.E.A.M. ROM V4.0)
Carrier: Not Provided

Thanks: 29
Thanked 177 Times in 166 Posts
Default

Sweet...glad it worked out....nice it was just the cable, but at the same time, kind of sucks you had to get a new one.
beau420 is offline  
Reply With Quote
Old December 11th, 2011, 02:04 PM   #7 (permalink)
New Member
 
Join Date: Dec 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

hey , i am having the same problem never get into usb mode tried many different cables ports, only thing i didnt try is ORIGINAL xperia cable, is this true XPERIA x10 works with only xperia cable and not other cables....?are there different specifications for the cable?
secondly sme one told me there are usb plug and play driver inside your phone that lets you manage usb is this true, i am new to android doesnt reply know much....
kindly help i have tried all the procedures given on different sites , even different computers and different cables, pc companion, SEUS etc etc
i really driving me hell crazy
drsaad is offline  
Reply With Quote
Old May 27th, 2012, 09:10 PM   #8 (permalink)
New Member
 
Join Date: May 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

hello good morning!! i have the same problem.. help.. im trying to upgrade my xperia x10. my laptop is not recognizing the usb cord/cable im using. My Dad said that he was able to use it just fine before he shipped it (the cp and laptop) here to the philippines. ive tried different cords already.
sinta rosa is offline  
Reply With Quote
Reply

Sony Ericsson Xperia X10
Current Rating:
Rate this Phone:

The Xperia X10 announced November 2009 was Sony Ericssons first flagship phone running the Android OS and at the time of announcement - the first Android handset to come with a 1 GHz Snapdragon Processor setting a path and standard for other 'h... Read More



Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


LinkBacks (?)
LinkBack to this Thread: http://androidforums.com/sony-ericsson-xperia-x10/405960-xperia-x10-will-not-connect-pc-via-usb-unrecognised-device.html
Posted By For Type Date
Thread How can i connect pendrive to my xperia x10 | Android Forums | BoardReader This thread Refback May 24th, 2012 11:13 PM


All times are GMT -5. The time now is 03:51 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.