Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10

New Forums: Nexus Player | Nexus 9
test: Reply
 
LinkBack Thread Tools
Old February 27th, 2012, 02:53 PM   #1 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jan 2011
Location: OC, SoCal, US, Earth, Sol System, Milky Way, Universe C
Posts: 37
 
Device(s): X10
Carrier: Not Provided

Thanks: 9
Thanked 3 Times in 2 Posts
Default Stumped - 2 days in!

OK, I've gone through http://androidforums.com/x10-all-things-root/420821-problem-installing-xrecovery-2-3-a.html and Cant even install xRecovery

I am using the GB 2.9.1 Flashtool. I was able to get through the 2.3 install, downgrade, root, and upgrade. Once I do, flashtool does not see the phone. I've tried turning it on while connected, connecting to usb, then turning on, etc. If I tell it to flash, it will see the phone in flash mode, but I can't get xrecovery on, and the generic 2.3 is killing me.

I have repeated the downgrade, root, upgrade routine at least three times. I even reflashed the 2.3 generic again and rerooted and set the whole thing up again. What am I missing?

Advertisements
torquey is offline  
Reply With Quote
sponsored links
Old February 27th, 2012, 08:40 PM   #2 (permalink)
Senior Member
 
beau420's Avatar
 
Join Date: Nov 2010
Location: Ottawa
Posts: 1,105
 
Device(s): x10a 2.3.3 (with x10i ROM from T.E.A.M. ROM V4.0)
Carrier: Not Provided

Thanks: 29
Thanked 177 Times in 166 Posts
Default

Quote:
Originally Posted by torquey View Post
OK, I've gone through http://androidforums.com/x10-all-things-root/420821-problem-installing-xrecovery-2-3-a.html and Cant even install xRecovery

I am using the GB 2.9.1 Flashtool. I was able to get through the 2.3 install, downgrade, root, and upgrade. Once I do, flashtool does not see the phone. I've tried turning it on while connected, connecting to usb, then turning on, etc. If I tell it to flash, it will see the phone in flash mode, but I can't get xrecovery on, and the generic 2.3 is killing me.

I have repeated the downgrade, root, upgrade routine at least three times. I even reflashed the 2.3 generic again and rerooted and set the whole thing up again. What am I missing?

Downgrade....root....then push xRecovery...then upgrade....or you should be able to install xRecovery after too.

When you open the flashtool...it does show that your phone is rooted when you plug it in?

Does it say: Android version : 2.3.3 / kernel version : 2.6.29 and doesn't say "Android version : 2.3.3 / kernel version : uname: permission denied

Make sure you have USB Debugging still on and Unknown Sources checked after rooting.

Can you get the buttons at the top of the Flashtool screen light up? Or are the still greyed out?

At what step do you get to in the process? Are you able to click the button to push xRecovery? Does it install and you just can't open xRecovery?
beau420 is offline  
Reply With Quote
The Following User Says Thank You to beau420 For This Useful Post:
torquey (February 28th, 2012)
Old February 28th, 2012, 01:23 AM   #3 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jan 2011
Location: OC, SoCal, US, Earth, Sol System, Milky Way, Universe C
Posts: 37
 
Device(s): X10
Carrier: Not Provided

Thanks: 9
Thanked 3 Times in 2 Posts
Default

Quote:
Originally Posted by beau420 View Post
Downgrade....root....then push xRecovery...then upgrade....or you should be able to install xRecovery after too.

When you open the flashtool...it does show that your phone is rooted when you plug it in?

Does it say: Android version : 2.3.3 / kernel version : 2.6.29 and doesn't say "Android version : 2.3.3 / kernel version : uname: permission denied

Make sure you have USB Debugging still on and Unknown Sources checked after rooting.

Can you get the buttons at the top of the Flashtool screen light up? Or are the still greyed out?

At what step do you get to in the process? Are you able to click the button to push xRecovery? Does it install and you just can't open xRecovery?
Thanks. While downgraded, the xrecovery button is disabled. Check root permission is available, but doesn't work since the OS won't run so I can grant SU permission. Once I upgrade, flash tool doesn't see my phone at all unless I go into flash mode. It doesn't show any errors, it just doesn't acknowledge the phone is connected. SEUS sees it, and if I tell flash tool I'm going to flash, it sees the phone once I connect in flash mode.
I did check the development settings were still correct, too.

Thanks again.
torquey is offline  
Reply With Quote
Old February 28th, 2012, 12:03 PM   #4 (permalink)
Senior Member
 
beau420's Avatar
 
Join Date: Nov 2010
Location: Ottawa
Posts: 1,105
 
Device(s): x10a 2.3.3 (with x10i ROM from T.E.A.M. ROM V4.0)
Carrier: Not Provided

Thanks: 29
Thanked 177 Times in 166 Posts
Default

Quote:
Originally Posted by torquey View Post
Thanks. While downgraded, the xrecovery button is disabled. Check root permission is available, but doesn't work since the OS won't run so I can grant SU permission. Once I upgrade, flash tool doesn't see my phone at all unless I go into flash mode. It doesn't show any errors, it just doesn't acknowledge the phone is connected. SEUS sees it, and if I tell flash tool I'm going to flash, it sees the phone once I connect in flash mode.
I did check the development settings were still correct, too.

Thanks again.
You don't need to do anything on the phone when you click the root button.

So, after you downgrade...and remove phone battery. Hold back button and pop back in battery....then at some point, you will be able to click the Root button (or go under Advanced and force root)

Just look what it does within the flashtool. Copy and paste your steps from the flashtool to this thread.

Then once the flashtool shows that it attempted to launch a rooting script, remove the battery....prep the phone to be upgraded, chose to Flash....it will prompt to plug in phone....so hold the back button and pop back in the battery and it will flash a couple files to do with the kernel.

Turn off the phone when it's done (or pop the battery) and it should turn on and be rooted.
beau420 is offline  
Reply With Quote
Old March 1st, 2012, 03:28 AM   #5 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jan 2011
Location: OC, SoCal, US, Earth, Sol System, Milky Way, Universe C
Posts: 37
 
Device(s): X10
Carrier: Not Provided

Thanks: 9
Thanked 3 Times in 2 Posts
Default

Quote:
Originally Posted by beau420 View Post
You don't need to do anything on the phone when you click the root button.

So, after you downgrade...and remove phone battery. Hold back button and pop back in battery....then at some point, you will be able to click the Root button (or go under Advanced and force root)

Just look what it does within the flashtool. Copy and paste your steps from the flashtool to this thread.

Then once the flashtool shows that it attempted to launch a rooting script, remove the battery....prep the phone to be upgraded, chose to Flash....it will prompt to plug in phone....so hold the back button and pop back in the battery and it will flash a couple files to do with the kernel.

Turn off the phone when it's done (or pop the battery) and it should turn on and be rooted.
Yes, all that works fine , and once I reboot, I've got root. The problem is, once all that is complete, if I connect the phone to the computer, flashtool doesn't see it, so I can't install xrecovery so I can backup or get a ROM on the phone. It doesn't seem to matter if I boot the phone, then connect, or connect while it's off and let it boot - flashtool just doesn't see the phone. If I click flash, and select a file, it will prompt me to connect in flash mode, and if I do, it sees the phone - but not outside of the flash function.

Thanks again.
P.S. Damn, just found this sitting here waiting to be submitted.
torquey is offline  
Reply With Quote
Reply

Sony Ericsson Xperia X10
Current Rating:
Rate this Phone:

The Xperia X10 announced November 2009 was Sony Ericssons first flagship phone running the Android OS and at the time of announcement - the first Android handset to come with a 1 GHz Snapdragon Processor setting a path and standard for other 'h... Read More



Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 08:08 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.