Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10

test: Reply
 
LinkBack Thread Tools
Old March 25th, 2012, 03:53 PM   #1 (permalink)
Member
Thread Author (OP)
 
Join Date: Jul 2010
Location: somewhere between here and there
Gender: Male
Posts: 380
 
Device(s): pebble blue samsung galaxy s3
Carrier: EE

Thanks: 28
Thanked 22 Times in 21 Posts
Default phone not working

ok guys, my phone finally stopped working last night, it just cut out. ive tried seus even updating that. went through the updating on my phone but it still wont switch on. when i try to switch it on i get a red light flashing three times and no start up.any help welcome. im due an upgrade 15th june so its only about 11 or 12 weeks to go i think but i dont want to be stuck with a pre android phone till then, i dont know how ill cope lol

ric

Advertisements
arkangeluk is offline  
Reply With Quote
sponsored links
Old March 25th, 2012, 05:38 PM   #2 (permalink)
Senior Member
 
beau420's Avatar
 
Join Date: Nov 2010
Location: Ottawa
Posts: 1,105
 
Device(s): x10a 2.3.3 (with x10i ROM from T.E.A.M. ROM V4.0)
Carrier: Not Provided

Thanks: 29
Thanked 177 Times in 166 Posts
Default

Quote:
Originally Posted by arkangeluk View Post
ok guys, my phone finally stopped working last night, it just cut out. ive tried seus even updating that. went through the updating on my phone but it still wont switch on. when i try to switch it on i get a red light flashing three times and no start up.any help welcome. im due an upgrade 15th june so its only about 11 or 12 weeks to go i think but i dont want to be stuck with a pre android phone till then, i dont know how ill cope lol

ric
Visit a store that sells the phone and test using a replacement battery.
beau420 is offline  
Reply With Quote
Old March 25th, 2012, 06:21 PM   #3 (permalink)
Member
Thread Author (OP)
 
Join Date: Jul 2010
Location: somewhere between here and there
Gender: Male
Posts: 380
 
Device(s): pebble blue samsung galaxy s3
Carrier: EE

Thanks: 28
Thanked 22 Times in 21 Posts
Default

sorry should have said, battery works ok in her x10 and her battery is just the same in my phone

ric
arkangeluk is offline  
Reply With Quote
Old March 27th, 2012, 08:20 AM   #4 (permalink)
Senior Member
 
beau420's Avatar
 
Join Date: Nov 2010
Location: Ottawa
Posts: 1,105
 
Device(s): x10a 2.3.3 (with x10i ROM from T.E.A.M. ROM V4.0)
Carrier: Not Provided

Thanks: 29
Thanked 177 Times in 166 Posts
Default

Quote:
Originally Posted by arkangeluk View Post
sorry should have said, battery works ok in her x10 and her battery is just the same in my phone

ric
Hopefully you have done a backup recently.

If so, install SEUS from Sony and run that and repair the phone.
beau420 is offline  
Reply With Quote
Old March 27th, 2012, 05:22 PM   #5 (permalink)
Member
Thread Author (OP)
 
Join Date: Jul 2010
Location: somewhere between here and there
Gender: Male
Posts: 380
 
Device(s): pebble blue samsung galaxy s3
Carrier: EE

Thanks: 28
Thanked 22 Times in 21 Posts
Default

ive already tried sues but all it is doing is telling me phone is fine and letting me update the phone. no option to repair. after i update, when i try to switch it on i get a red light flashing three times

ric
arkangeluk is offline  
Reply With Quote
Old March 29th, 2012, 10:03 AM   #6 (permalink)
Senior Member
 
beau420's Avatar
 
Join Date: Nov 2010
Location: Ottawa
Posts: 1,105
 
Device(s): x10a 2.3.3 (with x10i ROM from T.E.A.M. ROM V4.0)
Carrier: Not Provided

Thanks: 29
Thanked 177 Times in 166 Posts
Default

Quote:
Originally Posted by arkangeluk View Post
ive already tried sues but all it is doing is telling me phone is fine and letting me update the phone. no option to repair. after i update, when i try to switch it on i get a red light flashing three times

ric
If you can't use SEUS to fix it. Find an old ROM for 2.1 or something and use the Flashtool to flash to an older version.

Then use SEUS to repair/update it.
beau420 is offline  
Reply With Quote
Old March 31st, 2012, 05:05 AM   #7 (permalink)
Member
Thread Author (OP)
 
Join Date: Jul 2010
Location: somewhere between here and there
Gender: Male
Posts: 380
 
Device(s): pebble blue samsung galaxy s3
Carrier: EE

Thanks: 28
Thanked 22 Times in 21 Posts
Default

ok i will give that a try if i can find a 2.1 rom

ric
arkangeluk is offline  
Reply With Quote
Old March 31st, 2012, 10:28 AM   #8 (permalink)
Member
Thread Author (OP)
 
Join Date: Jul 2010
Location: somewhere between here and there
Gender: Male
Posts: 380
 
Device(s): pebble blue samsung galaxy s3
Carrier: EE

Thanks: 28
Thanked 22 Times in 21 Posts
Default

ok phone seemed to come back on itself today but it keeps swiching on and off. i have flashtool and still have a zip of a 2.1 rom but cant remember how to do it lol. phone is running 2.3 just now

ric
arkangeluk is offline  
Reply With Quote
Old March 31st, 2012, 05:58 PM   #9 (permalink)
Member
Thread Author (OP)
 
Join Date: Jul 2010
Location: somewhere between here and there
Gender: Male
Posts: 380
 
Device(s): pebble blue samsung galaxy s3
Carrier: EE

Thanks: 28
Thanked 22 Times in 21 Posts
Default

ok update time. i reflashed a 2.1 then hooked up seus and updated to 2.3 and thought everything was going ok but the phone keeps shutting down now. hope someone can suggest any other way to help me fix. ive only been a week without an android phone and the withdrawal symptoms are kicking in lol

ric
arkangeluk is offline  
Reply With Quote
Old April 1st, 2012, 01:13 AM   #10 (permalink)
Senior Member
 
beau420's Avatar
 
Join Date: Nov 2010
Location: Ottawa
Posts: 1,105
 
Device(s): x10a 2.3.3 (with x10i ROM from T.E.A.M. ROM V4.0)
Carrier: Not Provided

Thanks: 29
Thanked 177 Times in 166 Posts
Default

Quote:
Originally Posted by arkangeluk View Post
ok update time. i reflashed a 2.1 then hooked up seus and updated to 2.3 and thought everything was going ok but the phone keeps shutting down now. hope someone can suggest any other way to help me fix. ive only been a week without an android phone and the withdrawal symptoms are kicking in lol

ric
After installing 2.3, do a factory reset again (even if it just went through the setup wizard.

It would be a good idea maybe to reset the battery recalibrator or something

https://play.google.com/store/apps/details?id=proffesionals.battery.callibration&feat ure=search_result

Something that might reset the battery stats, or try using your wife's battery again.

Or if your phone is rooted use this:

https://play.google.com/store/apps/details?id=com.nema.batterycalibration&feature=sea rch_result#?t=W251bGwsMSwxLDEsImNvbS5uZW1hLmJhdHRl cnljYWxpYnJhdGlvbiJd
beau420 is offline  
Reply With Quote
The Following User Says Thank You to beau420 For This Useful Post:
arkangeluk (April 2nd, 2012)
sponsored links
Old April 2nd, 2012, 07:30 AM   #11 (permalink)
New Member
 
Join Date: Mar 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default sd card proplem - xperia x10

Hi android


now im very upset -
A month ago-I have and i got problemof memory - ( no memory card - and not recognized and all of this word about the memory proplems ) i fixed this proplem manytime by repair or updat my xperia x10 - and
This methodsolvedthe problemfor days just days - and after i send some song or pic to my phone - after some days this song or pic Disappearagainfrom the galleryor frommemory -
Why domy stuffdisappear frommemoryand frommy phone ???
i formate my memory several times - NTFS / AND Tryes alsow FAT 32 And this is not fixed the proplem > and when i go to storeg in my phone i see : Erase SD card is hidden




i can not use my camera - why android why ???
Whythe camerastrappedmemory - i updated my phone manytime and i repaired my phone manytime i used sony pc comp - or pc update programs - and alsow this is not fixed my proplem .

the proplem is not in the phone - the proplem in android 2.3.3 .

Because-after downloadingthe new system froma updatedorrepaired- solve the problemfor daysor justhours -andbackagain >
and Idoa search onthe internetaboutthis problem-and foundthat a lot lot of Androidphoneshave aproblem and gotthe sameproblem .


Android - i can not use my camera - WhatI wantfrom the phoneif hedoes not have acamera??



What is the solutionnow
jojox10 is offline  
Reply With Quote
Old April 2nd, 2012, 09:24 AM   #12 (permalink)
Senior Member
 
beau420's Avatar
 
Join Date: Nov 2010
Location: Ottawa
Posts: 1,105
 
Device(s): x10a 2.3.3 (with x10i ROM from T.E.A.M. ROM V4.0)
Carrier: Not Provided

Thanks: 29
Thanked 177 Times in 166 Posts
Default

Quote:
Originally Posted by jojox10 View Post
Hi android


now im very upset -
A month ago-I have and i got problemof memory - ( no memory card - and not recognized and all of this word about the memory proplems ) i fixed this proplem manytime by repair or updat my xperia x10 - and
This methodsolvedthe problemfor days just days - and after i send some song or pic to my phone - after some days this song or pic Disappearagainfrom the galleryor frommemory -
Why domy stuffdisappear frommemoryand frommy phone ???
i formate my memory several times - NTFS / AND Tryes alsow FAT 32 And this is not fixed the proplem > and when i go to storeg in my phone i see : Erase SD card is hidden




i can not use my camera - why android why ???
Whythe camerastrappedmemory - i updated my phone manytime and i repaired my phone manytime i used sony pc comp - or pc update programs - and alsow this is not fixed my proplem .

the proplem is not in the phone - the proplem in android 2.3.3 .

Because-after downloadingthe new system froma updatedorrepaired- solve the problemfor daysor justhours -andbackagain >
and Idoa search onthe internetaboutthis problem-and foundthat a lot lot of Androidphoneshave aproblem and gotthe sameproblem .


Android - i can not use my camera - WhatI wantfrom the phoneif hedoes not have acamera??



What is the solutionnow

Not sure why you thought typing in a larger font and centering it would help get your question answered quicker....but,

You are suppose to format SD card from phone...on phone, unmount card, format sd card, then mount sd card. If you can't format the sd card (not erase) then make sure there isn't any switch on the card making it read-only.

Or download a different camera app like Camera360. In Camera360 you can specify where you want pictures to be saved.

Also, when you upgrade from 2.1 to 2.3, you are suppose to do a factory reset wiping out all old data from 2.1 before you start using 2.3. Try that if problems persist. (that will also cause a problem if you are having problems on with the SD card)
beau420 is offline  
Reply With Quote
Old April 2nd, 2012, 04:27 PM   #13 (permalink)
Member
Thread Author (OP)
 
Join Date: Jul 2010
Location: somewhere between here and there
Gender: Male
Posts: 380
 
Device(s): pebble blue samsung galaxy s3
Carrier: EE

Thanks: 28
Thanked 22 Times in 21 Posts
Default

ok update time again. phone seems to be working again although it did shut down today still showing 23% but not to bothered about that. i have recalibrated the battery so will just see how it goes from here. hope it lasts till june till i can upgrade to new phone

ric
arkangeluk is offline  
Reply With Quote
Reply

Sony Ericsson Xperia X10
Current Rating:
Rate this Phone:

The Xperia X10 announced November 2009 was Sony Ericssons first flagship phone running the Android OS and at the time of announcement - the first Android handset to come with a 1 GHz Snapdragon Processor setting a path and standard for other 'h... Read More



Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 10:42 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.