Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10

test: Reply
 
LinkBack Thread Tools
Old June 17th, 2012, 11:11 AM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jun 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Sad "Download paused" in Market + Wifi connects, but no internet

Hi all, thanks for taking the time to click on this thread.

1) So I've been experiencing very annoying problems with my x10. First, I can't download any apps off of Android Market using Wifi (everything is fine with 3G, but I only get 200MB a month so I don't want to use it to download). Every time I try to, it will just say "Starting download....Downloading...Download paused". I tried to clear the cache/data, signed into GTalk/Gmail, and NOTHING works. I even factory reset my phone, and the problem persists. It was such a bad move because now my phone is practically has no apps because I can't download any. After some more googling, I started to suspect that it was my router. I'm nowhere near an expert on this stuff, but people were saying something about port 5228 and how it must be open for Android Market to work. I used one of those "Open Port Detector" websites, and yes, that port was closed. So I tried to port forward it, but I could only manage to open the port on my internet's IP address and not my computer's (the one that starts with 192?).

2) I'm not sure if this next problem I'm going to describe happened simultaneously with the first. Basically, my phone connects with my home Wifi just fine, but I can't access the internet. When I try to load Facebook, it would say "No Content" and "An error had occurred while fetching data. [Socket is not connected.]". And when I try to load a page on the stock browser, the load bar will never progress after a certain point.

I'm starting to wonder if it's a problem with my phone because all other wireless devices in the house (sister's HTC Inspire, dad's laptop) can connect and access the internet just fine. My sister's Android doesn't have any problems with the Market/Google Play either.

The problem has been persisting for a good few weeks, so I'm dying to find a solution! I've been trying to troubleshoot it for days now.

Advertisements
vennjlf is offline  
Reply With Quote
sponsored links
Old June 19th, 2012, 10:44 PM   #2 (permalink)
Senior Member
 
Sam-SonyXperia's Avatar
 
Join Date: Jun 2011
Posts: 1,042
 
Device(s):
Carrier: Not Provided

Thanks: 23
Thanked 151 Times in 138 Posts
Default

The first thing I would do in this situation is update the firmware of the router itself. You will likely need to go the manufacturers website for information on how do this, however it is generally fairly straight forward. If you can do that and then come back here and let me know how it went that would be great.
Sam-SonyXperia is offline  
Reply With Quote
Old October 27th, 2012, 05:24 AM   #3 (permalink)
New Member
 
Join Date: Oct 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by vennjlf View Post
Hi all, thanks for taking the time to click on this thread.

1) So I've been experiencing very annoying problems with my x10. First, I can't download any apps off of Android Market using Wifi (everything is fine with 3G, but I only get 200MB a month so I don't want to use it to download). Every time I try to, it will just say "Starting download....Downloading...Download paused". I tried to clear the cache/data, signed into GTalk/Gmail, and NOTHING works. I even factory reset my phone, and the problem persists. It was such a bad move because now my phone is practically has no apps because I can't download any. After some more googling, I started to suspect that it was my router. I'm nowhere near an expert on this stuff, but people were saying something about port 5228 and how it must be open for Android Market to work. I used one of those "Open Port Detector" websites, and yes, that port was closed. So I tried to port forward it, but I could only manage to open the port on my internet's IP address and not my computer's (the one that starts with 192?).

2) I'm not sure if this next problem I'm going to describe happened simultaneously with the first. Basically, my phone connects with my home Wifi just fine, but I can't access the internet. When I try to load Facebook, it would say "No Content" and "An error had occurred while fetching data. [Socket is not connected.]". And when I try to load a page on the stock browser, the load bar will never progress after a certain point.

I'm starting to wonder if it's a problem with my phone because all other wireless devices in the house (sister's HTC Inspire, dad's laptop) can connect and access the internet just fine. My sister's Android doesn't have any problems with the Market/Google Play either.

The problem has been persisting for a good few weeks, so I'm dying to find a solution! I've been trying to troubleshoot it for days now.
I Have almost the same problem. When i want to download or update an application from android market it will just say ''Downloading.......... . . .'' and nothings happens .
slutter is offline  
Reply With Quote
Old October 31st, 2012, 08:08 PM   #4 (permalink)
Senior Member
 
Sam-SonyXperia's Avatar
 
Join Date: Jun 2011
Posts: 1,042
 
Device(s):
Carrier: Not Provided

Thanks: 23
Thanked 151 Times in 138 Posts
Default

Is this also happening to you when downloading via wifi?
Sam-SonyXperia is offline  
Reply With Quote
Old November 2nd, 2012, 02:46 PM   #5 (permalink)
Senior Member
 
beau420's Avatar
 
Join Date: Nov 2010
Location: Ottawa
Posts: 1,105
 
Device(s): x10a 2.3.3 (with x10i ROM from T.E.A.M. ROM V4.0)
Carrier: Not Provided

Thanks: 29
Thanked 177 Times in 166 Posts
Default

This issue normally happens if you don't have an APN settings.

Try to connect with data and see if it works.

If it works with data, then try with Wifi one more time and make sure that you allowed to download content from the google store in your country
beau420 is offline  
Reply With Quote
Reply

Sony Ericsson Xperia X10
Current Rating:
Rate this Phone:

The Xperia X10 announced November 2009 was Sony Ericssons first flagship phone running the Android OS and at the time of announcement - the first Android handset to come with a 1 GHz Snapdragon Processor setting a path and standard for other 'h... Read More

Tags
android, connect, download, market, pause, wi-fi, wifi


Go Back   Android Forums > Android Phones > Sony Ericsson Xperia X10
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 11:16 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.