Go Back   Android Forums > Android Phones > Sony Xperia S

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

Like Tree4Likes
  • 1 Post By DerkVonUber
  • 1 Post By jaseuk
  • 1 Post By gamers.wc
  • 1 Post By wellsy1982

test: Reply
 
LinkBack Thread Tools
Old March 21st, 2012, 11:42 AM   #1 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jan 2010
Posts: 45
 
Device(s):
Carrier: Not Provided

Thanks: 8
Thanked 1 Time in 1 Post
Unhappy Dead Xperia S

Wondering if anyone else has had a problem. Since the phone is soo new I'm wondering if the issue is affecting others..
I came out of work today .. went to get my lovely new as of this past friday Xperia S to find it dead as a door nail .. Had about 80 % when i last looked at it before it went into my bag. Tried using my car charger NADA.. nothing. no indicator light etc.. Tried the mains charger when i got in still NADA..
Called Orange and a new one is being delivered tommorrow night.. Im sooo gutted i was just starting to have fun playing about with it not even had time to find out what it can do..
Anyone else have one that has died unexpectantly?????

Kaylesh is offline  
Reply With Quote
sponsored links
Old March 21st, 2012, 12:25 PM   #2 (permalink)
Senior Member
 
Tyseyh's Avatar
 
Join Date: Jun 2010
Location: Leeds, UK
Gender: Male
Posts: 2,028
 
Device(s): HTC Desire, Sony Xperia S ( Black )
Carrier: Not Provided

Thanks: 339
Thanked 298 Times in 221 Posts
Default

Quote:
Originally Posted by Kaylesh View Post
Wondering if anyone else has had a problem. Since the phone is soo new I'm wondering if the issue is affecting others..
I came out of work today .. went to get my lovely new as of this past friday Xperia S to find it dead as a door nail .. Had about 80 % when i last looked at it before it went into my bag. Tried using my car charger NADA.. nothing. no indicator light etc.. Tried the mains charger when i got in still NADA..
Called Orange and a new one is being delivered tommorrow night.. Im sooo gutted i was just starting to have fun playing about with it not even had time to find out what it can do..
Anyone else have one that has died unexpectantly?????
holy crap, man that sucks.
I ain't had anything like that happen -Touch wood- had two restarts though which was a little odd.

I assume you tried leaving it on charge for a while?
Tyseyh is offline  
Reply With Quote
Old March 21st, 2012, 12:48 PM   #3 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jan 2010
Posts: 45
 
Device(s):
Carrier: Not Provided

Thanks: 8
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by Tyseyh View Post
holy crap, man that sucks.
I ain't had anything like that happen -Touch wood- had two restarts though which was a little odd.

I assume you tried leaving it on charge for a while?

You assume correct .. and yep it sucks.. grrrrrrrrrrrr
Kaylesh is offline  
Reply With Quote
Old March 21st, 2012, 02:13 PM   #4 (permalink)
Senior Member
 
Tyseyh's Avatar
 
Join Date: Jun 2010
Location: Leeds, UK
Gender: Male
Posts: 2,028
 
Device(s): HTC Desire, Sony Xperia S ( Black )
Carrier: Not Provided

Thanks: 339
Thanked 298 Times in 221 Posts
Default

Let me know how it goes
Tyseyh is offline  
Reply With Quote
Old March 21st, 2012, 02:44 PM   #5 (permalink)
Member
 
Join Date: Apr 2010
Location: Yorkshire
Posts: 239
 
Device(s): Motorola Moto G IP5 Nokia Lumia 710 (temporary),Sony Xperia S(Sim Free, Bootloader unlocked and root
Carrier: Not Provided

Thanks: 18
Thanked 42 Times in 29 Posts
Default

Not had or heard of this problem specifically with the Xperia Kaylesh, I would take it back or else you'll be wondering when this will happen again.
jaseuk is offline  
Reply With Quote
Old March 21st, 2012, 03:21 PM   #6 (permalink)
Senior Member
 
Join Date: Sep 2010
Posts: 546
 
Device(s): HTC One
Carrier: EE-Orange

Thanks: 97
Thanked 11 Times in 11 Posts
Default

doesnt sound good
gabbyevs is offline  
Reply With Quote
Old March 21st, 2012, 03:37 PM   #7 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jan 2010
Posts: 45
 
Device(s):
Carrier: Not Provided

Thanks: 8
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by jaseuk View Post
Not had or heard of this problem specifically with the Xperia Kaylesh, I would take it back or else you'll be wondering when this will happen again.
Per my post above.. new one coming tommorrow night (Thurs) .. Not a matter of it happening again. Its dead. Not doing a thing.. Can't even get stuff i put on it off as it won't turn on,no power light nothing. Orange say they've not had any problems like this yet.. So hopefully i just a blip in the batch one..
Kaylesh is offline  
Reply With Quote
Old March 21st, 2012, 04:04 PM   #8 (permalink)
New Member
 
Join Date: Mar 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 7 Times in 1 Post
Thumbs up Problem solved!!!!!

I had exactly the same problem a few days ago.....I went to play with my new toy but alas nothing happened. Tried to speak to the so called technical Help on the sony mobile site....About as much use as a chocolate teapot!!!!

Any way aftermuch panicking and trawling the tinterweb for advice....still no joy

Then I had my eureka moment and remembered back to my Iphone days - (sorry for using the forbidden word!!!!)

I thought what would happen if you hold all buttons down????

After around 6 seconds the phone vibrated I then pressed the power button and as if by magic the phone was back up and running with nothing effected (this meant the wife was happy as well!!!!)

I think this is some sort of jump start/ reboot for the phone but since then it has been working fine!!

Try it and let me know
droidrio likes this.
DerkVonUber is offline  
Reply With Quote
The Following 7 Users Say Thank You to DerkVonUber For This Useful Post:
droidrio (October 3rd, 2012), gamers.wc (June 10th, 2012), roucou008 (April 5th, 2012), ThexperiaS (June 10th, 2012), Vanille (April 24th, 2012), WRDNTCSE (October 2nd, 2012), zombie37 (June 28th, 2012)
Old March 21st, 2012, 05:04 PM   #9 (permalink)
Member
 
Join Date: Apr 2010
Location: Yorkshire
Posts: 239
 
Device(s): Motorola Moto G IP5 Nokia Lumia 710 (temporary),Sony Xperia S(Sim Free, Bootloader unlocked and root
Carrier: Not Provided

Thanks: 18
Thanked 42 Times in 29 Posts
Default

Quote:
Originally Posted by Tyseyh View Post
holy crap, man that sucks.
I ain't had anything like that happen -Touch wood- had two restarts though which was a little odd.

I assume you tried leaving it on charge for a while?
I had two restarts too! They were on day 2 and maybe 3 but has been fine ever since, didn't think about it as my ip4 also sometimes froze so I guessed if a optimised os like Apple's can do it a open source os like android would do the same. But as I say the phone has got smoother and longer lasting every day.


Edit: Oh I read somewhere that if you may be able to force a restart by holding down vol down and power button for up to 30 secs and it will restart.
wellsy1982 likes this.
jaseuk is offline  
Reply With Quote
The Following User Says Thank You to jaseuk For This Useful Post:
wellsy1982 (June 11th, 2012)
Old March 22nd, 2012, 01:47 AM   #10 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jan 2010
Posts: 45
 
Device(s):
Carrier: Not Provided

Thanks: 8
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by DerkVonUber View Post
I had exactly the same problem a few days ago.....I went to play with my new toy but alas nothing happened. Tried to speak to the so called technical Help on the sony mobile site....About as much use as a chocolate teapot!!!!

Any way aftermuch panicking and trawling the tinterweb for advice....still no joy

Then I had my eureka moment and remembered back to my Iphone days - (sorry for using the forbidden word!!!!)

I thought what would happen if you hold all buttons down????

After around 6 seconds the phone vibrated I then pressed the power button and as if by magic the phone was back up and running with nothing effected (this meant the wife was happy as well!!!!)

I think this is some sort of jump start/ reboot for the phone but since then it has been working fine!!

Try it and let me know
Tried this and still nada.. glad the new one will be on its way tonight.. Feel weird without a mobile to use and okay play with lolol
Kaylesh is offline  
Reply With Quote
sponsored links
Old April 2nd, 2012, 07:17 AM   #11 (permalink)
New Member
 
Join Date: Apr 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have just suffered the same problem. I was on the phone to my Wife, tried to increase the volumne and nothing changed. Then there was no display even though I was still in call. After call phone was dead, nothing.
A google search brought me here and I tried the hold all buttons. It was hard to hold down the whole volume button at first but once I did the phone vibrated once quickly followed by three more vibrates and after a few more seconds came back to life at which point I let go of the buttons.
All my contacts and settings were held on the phone.
Thanks Keylesh
teamdel is offline  
Reply With Quote
Old April 5th, 2012, 07:29 AM   #12 (permalink)
New Member
 
Join Date: Apr 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default Reply

I just experienced the same thing. Just got my Experia S yesterday and was so happy playing with it. The battery was a bit low so decided to charge it. I don't know how but it suddenly shut down and there was only a red light at the top left of the screen on. I tried putting it on but it wouldn't, tried connecting it to the laptop but to no avail. I was so freaked out since i bought the phone online in UK and i live in another country. I finally tried googling the problem and i was brought here. I tried what the above user said about holding down all the buttons and it actually worked. The phone is back on and i hope it stays that way.

Thanks for the tip!
roucou008 is offline  
Reply With Quote
Old April 5th, 2012, 03:08 PM   #13 (permalink)
Junior Member
 
Join Date: May 2011
Posts: 49
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 3 Times in 2 Posts
Default

mine has frozen a few times, but after the reset it works fine.
bayhota is offline  
Reply With Quote
Old April 12th, 2012, 09:27 AM   #14 (permalink)
New Member
 
Join Date: Apr 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Intriguing, mine did the same today (I only got it yesterday) and as I was near the 3 shop I'd bought it from, I just went back and got them to change it. Had a strop at losing my messages and photos, but now have a new one and am crossing my fingers it won't do it again. But at least now I know how to restart it!
creamykiwi is offline  
Reply With Quote
Old April 12th, 2012, 11:17 AM   #15 (permalink)
Senior Member
 
Tyseyh's Avatar
 
Join Date: Jun 2010
Location: Leeds, UK
Gender: Male
Posts: 2,028
 
Device(s): HTC Desire, Sony Xperia S ( Black )
Carrier: Not Provided

Thanks: 339
Thanked 298 Times in 221 Posts
Default

Mine gets backed up every few days now via media go.
Soon as my phone connects to the same wifi as my pc, media go opens and syncs
Tyseyh is offline  
Reply With Quote
Old April 24th, 2012, 10:28 PM   #16 (permalink)
New Member
 
Join Date: Apr 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by DerkVonUber View Post
I had exactly the same problem a few days ago.....I went to play with my new toy but alas nothing happened. Tried to speak to the so called technical Help on the sony mobile site....About as much use as a chocolate teapot!!!!

Any way aftermuch panicking and trawling the tinterweb for advice....still no joy

Then I had my eureka moment and remembered back to my Iphone days - (sorry for using the forbidden word!!!!)

I thought what would happen if you hold all buttons down????

After around 6 seconds the phone vibrated I then pressed the power button and as if by magic the phone was back up and running with nothing effected (this meant the wife was happy as well!!!!)

I think this is some sort of jump start/ reboot for the phone but since then it has been working fine!!

Try it and let me know
Thanks soo much!!! xoxoxo
Vanille is offline  
Reply With Quote
Old June 10th, 2012, 08:23 AM   #17 (permalink)
New Member
 
Join Date: Jun 2012
Location: England
Posts: 1
 
Device(s): Sony Xperia S
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default Dead Xperia S recovered

Thanks guys for the info. My Xperia S gave up the ghost today. No response, no LEDs, no charging up, just a black screen. After reading the advice about restarting the phone, I pressed the on button together with the volume up button. Hey presto! Eventually the phone vibrated and sprang into life again. And it appears to have retained all its settings.
ThexperiaS is offline  
Reply With Quote
Old June 10th, 2012, 08:35 AM   #18 (permalink)
Junior Member
 
gamers.wc's Avatar
 
Join Date: Jan 2011
Location: Karlovac,Croatia
Posts: 20
 
Device(s): XPERIA X10 mini pro
Carrier: Not Provided

Thanks: 7
Thanked 2 Times in 2 Posts
Default

DerkVonUber you're the MAN, thank you so much!
I got my xperia s a week ago and today I connected it to a computer and Sony Pc companion alerted me that new update is available, I clicked ok, after some time my phone died and I couldn't turn it on, I was so screwed; I saw what you have written and it helped!
Thank you again!
p.s. Sorry for my English
wellsy1982 likes this.
gamers.wc is offline  
Reply With Quote
Old June 10th, 2012, 12:41 PM   #19 (permalink)
Senior Member
 
powerkiter's Avatar
 
Join Date: Jun 2010
Location: UK
Posts: 859
 
Device(s): X10i ROM's FreeX10 2.2.1 Froyo and Blue Sparks V5 2.1 xRecovery
Carrier: Not Provided

Thanks: 11
Thanked 107 Times in 80 Posts
Default

Did no one actually read the quick guide that came with the phone?

Power and volume button reset was the first thing I read lol
powerkiter is offline  
Reply With Quote
The Following User Says Thank You to powerkiter For This Useful Post:
Tyseyh (June 10th, 2012)
Old June 11th, 2012, 05:28 AM   #20 (permalink)
New Member
 
Join Date: Jun 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Thumbs up

Quote:
Originally Posted by jaseuk View Post
I had two restarts too! They were on day 2 and maybe 3 but has been fine ever since, didn't think about it as my ip4 also sometimes froze so I guessed if a optimised os like Apple's can do it a open source os like android would do the same. But as I say the phone has got smoother and longer lasting every day.


Edit: Oh I read somewhere that if you may be able to force a restart by holding down vol down and power button for up to 30 secs and it will restart.
Wow! So glad i read this! Thanks so much! My phone exact same problem & this fixed it, amazing! Thank you!! )
jaseuk likes this.
wellsy1982 is offline  
Reply With Quote
sponsored links
Old June 22nd, 2012, 03:02 PM   #21 (permalink)
New Member
 
Join Date: Jun 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello,
the same thing happened to me. I tried to update the software and it just went dead. But unfortunatelly, I have to say, for me, pressing all the buttuns didn't do anything!
nair is offline  
Reply With Quote
Old June 22nd, 2012, 05:09 PM   #22 (permalink)
New Member
 
Join Date: Jun 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by DerkVonUber View Post
I had exactly the same problem a few days ago.....I went to play with my new toy but alas nothing happened. Tried to speak to the so called technical Help on the sony mobile site....About as much use as a chocolate teapot!!!!

Any way aftermuch panicking and trawling the tinterweb for advice....still no joy

Then I had my eureka moment and remembered back to my Iphone days - (sorry for using the forbidden word!!!!)

I thought what would happen if you hold all buttons down????

After around 6 seconds the phone vibrated I then pressed the power button and as if by magic the phone was back up and running with nothing effected (this meant the wife was happy as well!!!!)

I think this is some sort of jump start/ reboot for the phone but since then it has been working fine!!

Try it and let me know

DUDE! I am so happy to read ur tip! YOU SAVED MY LIFE! I HAVE SOME SERIOUS EVIDENCE ON MY PHONE WHICH WILL PROBABLY GET ME OUT OF SUSPICION FOR DOING SOMETHING ILLEGAL! I WAS SO DEVISTATED WHEN MY Phone blackout out of the blue...and i tried your tip...MAN I WAS ALMOST CRYING OF HAPPINESS! THANKS!
impendinglee is offline  
Reply With Quote
Old June 28th, 2012, 03:24 PM   #23 (permalink)
New Member
 
Join Date: Jun 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by DerkVonUber View Post
I had exactly the same problem a few days ago.....I went to play with my new toy but alas nothing happened. Tried to speak to the so called technical Help on the sony mobile site....About as much use as a chocolate teapot!!!!

Any way aftermuch panicking and trawling the tinterweb for advice....still no joy

Then I had my eureka moment and remembered back to my Iphone days - (sorry for using the forbidden word!!!!)

I thought what would happen if you hold all buttons down????

After around 6 seconds the phone vibrated I then pressed the power button and as if by magic the phone was back up and running with nothing effected (this meant the wife was happy as well!!!!)

I think this is some sort of jump start/ reboot for the phone but since then it has been working fine!!

Try it and let me know
Thank you very much man , you saved my day
zombie37 is offline  
Reply With Quote
Old July 3rd, 2012, 10:34 PM   #24 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Just found this thread through google....had my phone for a few months with no issues at all so far.....yesterday I tried to do the update, which wouldnt work.
The phone continued to work fine for most of the day, sent and received texts last night, went to pick phone up and its died, no response at all?
Nothing happens when I connect it to the charger, however when I connect the USB cable to the computer I get a red light on the phone, but the computer (PC companion software) doesnt recognise the phone?
Tried the reset settings as above but nothing happened?
I have a LOT of stuff on this phone that I dont want to lose!
debsmadcat is offline  
Reply With Quote
Old July 4th, 2012, 02:46 AM   #25 (permalink)
Member
 
Del1701's Avatar
 
Join Date: Apr 2012
Location: Near Dartford, Kent
Posts: 343
 
Device(s): Nokia Lumia 820, Sony Xperia S, Xperia Neo
Carrier: T-Mobile uk (EE)

Thanks: 17
Thanked 52 Times in 49 Posts
Default

Quote:
Originally Posted by debsmadcat View Post
Just found this thread through google....had my phone for a few months with no issues at all so far.....yesterday I tried to do the update, which wouldnt work.
The phone continued to work fine for most of the day, sent and received texts last night, went to pick phone up and its died, no response at all?
Nothing happens when I connect it to the charger, however when I connect the USB cable to the computer I get a red light on the phone, but the computer (PC companion software) doesnt recognise the phone?
Tried the reset settings as above but nothing happened?
I have a LOT of stuff on this phone that I dont want to lose!
Press and hold volume up and the power button at the same time for about 15 seconds, your phone should vibrate 3 times, when it does it's turned off, leave it for about 30 seconds and then turn it back on and you should be ok.
Del1701 is online now  
Reply With Quote
The Following User Says Thank You to Del1701 For This Useful Post:
Dunc-x10 (December 6th, 2012)
Old July 6th, 2012, 07:27 AM   #26 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default dead experia

mine to deaed as a dodo gonna try out the reset tonight let you know later fingers crossed
sjmcnee is offline  
Reply With Quote
Old October 2nd, 2012, 10:06 PM   #27 (permalink)
New Member
 
Join Date: Oct 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 1
Thanked 0 Times in 0 Posts
Thumbs up Thanks

Quote:
Originally Posted by DerkVonUber View Post
I had exactly the same problem a few days ago.....I went to play with my new toy but alas nothing happened. Tried to speak to the so called technical Help on the sony mobile site....About as much use as a chocolate teapot!!!!

Any way aftermuch panicking and trawling the tinterweb for advice....still no joy

Then I had my eureka moment and remembered back to my Iphone days - (sorry for using the forbidden word!!!!)

I thought what would happen if you hold all buttons down????

After around 6 seconds the phone vibrated I then pressed the power button and as if by magic the phone was back up and running with nothing effected (this meant the wife was happy as well!!!!)

I think this is some sort of jump start/ reboot for the phone but since then it has been working fine!!

Try it and let me know

Was just about to hop in the car and take a really long drive to the Shop i got my phone from and start jumping up and down, you just saved me hours of my life and a massive headache!
Thanks!
WRDNTCSE is offline  
Reply With Quote
Old October 4th, 2012, 11:49 AM   #28 (permalink)
Junior Member
 
droidrio's Avatar
 
Join Date: Sep 2012
Location: live & direct from a satellite near you
Posts: 19
 
Device(s): sony xperia s
Carrier: Not Provided

Thanks: 14
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by Tyseyh View Post
Mine gets backed up every few days now via media go.
Soon as my phone connects to the same wifi as my pc, media go opens and syncs
What is this MEDIA GO?
And how do i set it up between my phone and my laptop, they both use the same wi-fi.
droidrio is offline  
Reply With Quote
Old October 5th, 2012, 02:13 AM   #29 (permalink)
Senior Member
 
Tyseyh's Avatar
 
Join Date: Jun 2010
Location: Leeds, UK
Gender: Male
Posts: 2,028
 
Device(s): HTC Desire, Sony Xperia S ( Black )
Carrier: Not Provided

Thanks: 339
Thanked 298 Times in 221 Posts
Default

Media go is a part of the application package you get with your phone.
Tyseyh is offline  
Reply With Quote
Old December 6th, 2012, 06:33 PM   #30 (permalink)
Junior Member
 
Join Date: Jun 2010
Posts: 93
 
Device(s): Sony Xperia S ( Black )
Carrier: Not Provided

Thanks: 20
Thanked 8 Times in 8 Posts
Default

Quote:
Originally Posted by Del1701 View Post
Press and hold volume up and the power button at the same time for about 15 seconds, your phone should vibrate 3 times, when it does it's turned off, leave it for about 30 seconds and then turn it back on and you should be ok.
You stopped me having a trip to the shop Thank you
Dunc-x10 is offline  
Reply With Quote
sponsored links
Old December 7th, 2012, 02:26 AM   #31 (permalink)
Member
 
Del1701's Avatar
 
Join Date: Apr 2012
Location: Near Dartford, Kent
Posts: 343
 
Device(s): Nokia Lumia 820, Sony Xperia S, Xperia Neo
Carrier: T-Mobile uk (EE)

Thanks: 17
Thanked 52 Times in 49 Posts
Default

Quote:
Originally Posted by Dunc-x10 View Post
You stopped me having a trip to the shop Thank you
No worries, glad I helped



Sent from my RM-825_eu_euro1_217 using Board Express
Del1701 is online now  
Reply With Quote
Old February 7th, 2013, 06:58 PM   #32 (permalink)
New Member
 
Join Date: Feb 2013
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Okay so i've bought the xperia v had it for a few weeks suddently dies when and this is what i did to get it back alive, you basically take out the batteri you rub the shit out of it till its warm then put it back in make sure you allready have the loader in the phone. hope this helps
Grovtrollet is offline  
Reply With Quote
Old February 9th, 2013, 01:22 PM   #33 (permalink)
Senior Member
 
Tyseyh's Avatar
 
Join Date: Jun 2010
Location: Leeds, UK
Gender: Male
Posts: 2,028
 
Device(s): HTC Desire, Sony Xperia S ( Black )
Carrier: Not Provided

Thanks: 339
Thanked 298 Times in 221 Posts
Default

Quote:
Originally Posted by Grovtrollet View Post
Okay so i've bought the xperia v had it for a few weeks suddently dies when and this is what i did to get it back alive, you basically take out the batteri you rub the shit out of it till its warm then put it back in make sure you allready have the loader in the phone. hope this helps

the Xperia S has no removable battery.
Tyseyh is offline  
Reply With Quote
Old February 10th, 2013, 01:59 AM   #34 (permalink)
New Member
 
Join Date: Feb 2013
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm facing the same problem where my Xperia S blacked out day b4 y'day and i took the phone to the service centre. they said i dint kw how to turn it on and said they will reset the OS. it worked till y'day nite and again it went blank. i tried all the steps ppl have mentioned here and it dint work. some1 plz help me to fix this.
sarthy_vas is offline  
Reply With Quote
Old February 12th, 2013, 03:21 AM   #35 (permalink)
Senior Member
 
Tyseyh's Avatar
 
Join Date: Jun 2010
Location: Leeds, UK
Gender: Male
Posts: 2,028
 
Device(s): HTC Desire, Sony Xperia S ( Black )
Carrier: Not Provided

Thanks: 339
Thanked 298 Times in 221 Posts
Default Re: Dead Xperia S

You could flash the OS yourself.
Though, if they flashed it and it's still broken, get a new handset?
Tyseyh is offline  
Reply With Quote
Reply

Sony Xperia S
Current Rating:
Rate this Phone:

The Sony Xperia S doesn’t differ too much from the Ion: it features a 1.5GHz dual-core processor, a 12MP Exmor R camera sensor, and a 720p display, only here it is 4.3-inches in size. If it looks familiar, it’s because we have seen this... Read More



Go Back   Android Forums > Android Phones > Sony Xperia S
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 05:39 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.