Go Back   Android Forums > Android Phones > Sony Xperia U

test: Reply
 
LinkBack Thread Tools
Old June 21st, 2012, 04:01 AM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jun 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Ziplip Wifi problem with Sony Xperia U

Hi,
I've just bought a Sony Xperia U 4 days ago. Orange (UK) have replaced it 3 twice now, yes, I'm on my third phone cos I can't get it to connect to my wifi. My wifi has several other phones and computers on it successfully and even with all of them off, it still doesn't do it. This is very strange. Could it be a batch thing do you think? Could it be my Sim Card? The Router is working fine. The phone picks up my wifi signal stating excellent strength, but cannot connect. It states... Connecting... disconnecting... scanning.:eek

Thanks for any suggestions!

Advertisements
HarryTangye is offline  
Reply With Quote
sponsored links
Old July 1st, 2012, 12:55 PM   #2 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Xperia wifi problems

Quote:
Originally Posted by HarryTangye View Post
Hi,
I've just bought a Sony Xperia U 4 days ago. Orange (UK) have replaced it 3 twice now, yes, I'm on my third phone cos I can't get it to connect to my wifi. My wifi has several other phones and computers on it successfully and even with all of them off, it still doesn't do it. This is very strange. Could it be a batch thing do you think? Could it be my Sim Card? The Router is working fine. The phone picks up my wifi signal stating excellent strength, but cannot connect. It states... Connecting... disconnecting... scanning.:eek

Thanks for any suggestions!
Hi what you need to do is alter the settings on your router.You will probably find that your security is set too high by using WPA2 even though all your other stuff (laptops,ipods or games consoles) connect with no problem.
You need to go into your routers settings and change the WLAN security to WPA and also change the channel to any number under 10 and you should find that this sorts out your problem.
colinl16 is offline  
Reply With Quote
Old July 3rd, 2012, 06:19 AM   #3 (permalink)
New Member
 
Join Date: Jul 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation sony xperia U problem

Hi,

unfortunately youre not alone. The latest sony firmware is very bad and makes wifi unusable.
I have updated last week to it and since then I have the exact same symptoms like you - wifi connected - disconnected - connected - disconnected.

I have WPA2 AES/TKIP encryption on my router and it worked fine before the update.

http://talk.sonymobile.com/message/236963
Johnny2 is offline  
Last edited by Johnny2; July 3rd, 2012 at 06:20 AM. Reason: edit with url, cause this is my first one on this forum
Reply With Quote
Old August 27th, 2012, 02:34 AM   #4 (permalink)
New Member
 
Join Date: Aug 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have the same thing happening with my phone as well got it just last week & it will connect to other wi-fi networks but not my home one (NZ)
Miss Lacey is offline  
Reply With Quote
Old August 27th, 2012, 02:54 AM   #5 (permalink)
New Member
 
Join Date: Aug 2012
Location: Salt Lake City, UT
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

@everyone, I know that is not related to this person's particular quesiton but I was hoping that someone could help me with the question I have. I don't know how to start a new forum, anyway here's the quesiton. I have a MyTouch 4g, I have a WPA key entered in my phone for my friend's wifi. My friend is gone for the week and I am unable to contact him, I need to extract this hidden WPA key from my phone so I can use it on a laptop I have. Is it possible?
kevizal is offline  
Reply With Quote
Old September 1st, 2012, 12:49 AM   #6 (permalink)
New Member
 
Join Date: Sep 2012
Location: The Netherlands
Posts: 10
 
Device(s): Sony Xperia U ST25i, Asus eee Pad Transformer TF101, My dad has my Samsung Galaxy S Plus I9001.
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have the same problem with bouncing Wifi on my xperia u. It scans, gets IP adress, is connected, and then scans again. this goes on till i turn off the Wifi on my phone again. I have newest firmware version 6.0.B.3.184. Anyone knows a way how I can downgrade my phone? I'm in the Netherlands and our wifi network is secured with WEP.

what I find on all the forum posts all over the internet, it has EITHEr to do with your wifi security type (WEP/WPA/WPA2) OR is has to do with the newest firmware update (which i installed). In the provider store where i bought my phone they told me to reset it back to factory, and iof that wouldnt work i should call the costumer service. factory reset doesn't help, unfortunately.

I just modified the Wifi settings, from hidden WEP to non-hidden WPA tkip, and it worked! then i put it back to hidden wpa tkip, and it went bouncing again. so the problem i have is with hidden networks. do you have the same?
kesje is offline  
Last edited by kesje; September 1st, 2012 at 01:55 AM.
Reply With Quote
Old September 1st, 2012, 09:22 AM   #7 (permalink)
New Member
 
Join Date: Aug 2012
Posts: 5
 
Device(s): Sony Xperia U
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by kesje View Post
I have the same problem with bouncing Wifi on my xperia u. It scans, gets IP adress, is connected, and then scans again. this goes on till i turn off the Wifi on my phone again. I have newest firmware version 6.0.B.3.184. Anyone knows a way how I can downgrade my phone? I'm in the Netherlands and our wifi network is secured with WEP.

what I find on all the forum posts all over the internet, it has EITHEr to do with your wifi security type (WEP/WPA/WPA2) OR is has to do with the newest firmware update (which i installed). In the provider store where i bought my phone they told me to reset it back to factory, and iof that wouldnt work i should call the costumer service. factory reset doesn't help, unfortunately.

I just modified the Wifi settings, from hidden WEP to non-hidden WPA tkip, and it worked! then i put it back to hidden wpa tkip, and it went bouncing again. so the problem i have is with hidden networks. do you have the same?
same problem here. my wifi works great except on the router i use when i upgrade my version same as yours now. my problem is i don't know how to set the wifi into settings i read here. the router is not installed on my lappy, i just shared with the land lady.
ferdz7187 is offline  
Reply With Quote
Old September 1st, 2012, 09:24 AM   #8 (permalink)
New Member
 
Join Date: Sep 2012
Location: The Netherlands
Posts: 10
 
Device(s): Sony Xperia U ST25i, Asus eee Pad Transformer TF101, My dad has my Samsung Galaxy S Plus I9001.
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by ferdz7187 View Post
same problem here. my wifi works great except on the router i use when i upgrade my version same as yours now. my problem is i don't know how to set the wifi into settings i read here. the router is not installed on my lappy, i just shared with the land lady.
ahwww that sucks... I'm sorry... Just have to wait for sony to bring an update fix or something i guess... maybe you could try an app who controls the wifi stuff?
kesje is offline  
Reply With Quote
Old September 1st, 2012, 09:27 AM   #9 (permalink)
New Member
 
Join Date: Aug 2012
Posts: 5
 
Device(s): Sony Xperia U
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by kesje View Post
ahwww that sucks... I'm sorry... Just have to wait for sony to bring an update fix or something i guess... maybe you could try an app who controls the wifi stuff?
i think i've seen an app that can hack a wifi password, is that legit? becoz there's other wifi available on the neigbor but i don't know the password, neither them. it's really frustrating. i can't enjoy the viber in here.
ferdz7187 is offline  
Reply With Quote
Old September 2nd, 2012, 01:50 AM   #10 (permalink)
New Member
 
Join Date: Sep 2012
Location: The Netherlands
Posts: 10
 
Device(s): Sony Xperia U ST25i, Asus eee Pad Transformer TF101, My dad has my Samsung Galaxy S Plus I9001.
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by ferdz7187 View Post
i think i've seen an app that can hack a wifi password, is that legit? becoz there's other wifi available on the neigbor but i don't know the password, neither them. it's really frustrating. i can't enjoy the viber in here.
I dont know how that works, just give it a try?
good luck!
kesje is offline  
Reply With Quote
sponsored links
Old September 4th, 2012, 09:49 AM   #11 (permalink)
New Member
 
Join Date: Aug 2012
Posts: 5
 
Device(s): Sony Xperia U
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

hi there again.
last night I was able to connect on the router i told before that seem not to work on my phone. i used the wifi to download and update some apps on my phone and i even used it for google maps and even skype. it works great, until i turned off the wifi and data 'coz i'm going to sleep. the following morning, it doesn't connect again. what seems to be the problem here? the router or my phone? i've tried already 4 routers and only to this 1 that i used to update my system my wifi cannot establish connections.
pls help! Thanks
ferdz7187 is offline  
Reply With Quote
Old September 6th, 2012, 07:42 AM   #12 (permalink)
New Member
 
Join Date: Sep 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

hello, i have bought Xperia U couple of weeks ago, my wifi works best when it does, but my problem is little different. my wifi works ok but it stops responding sometimes during working, and i have to restart my cell. it works again or sometimes restart do not solve the problem and i have to wait for a while then it works again. Problem is waiting when i m doing chat thru wifi coz it disconnects in a middle of discussion, overall i liked this phone. it has strong battery as compared to other cheap androind phones further internal memory is enough for me to install important apps and games. i just hav issue with wifi. i have latest android 2.3.7, build 6.0.b.1.564. if anyone have solution to my problem plz share, i sent emal to sony customer care, they asked me to reinstall software using PC companion, i haven't try that so far.
Ercell is offline  
Reply With Quote
Old September 6th, 2012, 07:45 AM   #13 (permalink)
New Member
 
Join Date: Sep 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

further they asked me to restart my phone daily to improved performance
Ercell is offline  
Reply With Quote
Old September 15th, 2012, 12:27 PM   #14 (permalink)
New Member
 
Join Date: Dec 2011
Posts: 4
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 1 Time in 1 Post
Default WIFI issue stopped me buying this tablet

removed as thought i was replying to an issue with tablets lol.
maax555 is offline  
Last edited by maax555; September 15th, 2012 at 12:31 PM.
Reply With Quote
Old October 5th, 2012, 04:05 AM   #15 (permalink)
New Member
 
Join Date: Sep 2012
Location: The Netherlands
Posts: 10
 
Device(s): Sony Xperia U ST25i, Asus eee Pad Transformer TF101, My dad has my Samsung Galaxy S Plus I9001.
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Ercell View Post
hello, i have bought Xperia U couple of weeks ago, my wifi works best when it does, but my problem is little different. my wifi works ok but it stops responding sometimes during working, and i have to restart my cell. it works again or sometimes restart do not solve the problem and i have to wait for a while then it works again. Problem is waiting when i m doing chat thru wifi coz it disconnects in a middle of discussion, overall i liked this phone. it has strong battery as compared to other cheap androind phones further internal memory is enough for me to install important apps and games. i just hav issue with wifi. i have latest android 2.3.7, build 6.0.b.1.564. if anyone have solution to my problem plz share, i sent emal to sony customer care, they asked me to reinstall software using PC companion, i haven't try that so far.
Maybe a silly question, have you tried resetting your router?
kesje is offline  
Reply With Quote
Old October 19th, 2012, 04:26 PM   #16 (permalink)
AF Contributor
 
Join Date: Jul 2012
Location: The Shire
Posts: 839
 
Device(s): HTC Wildfire S x 2, Xperia U, Huawei Y300, N7, Generic Allwinner tab, Bluestacks
Carrier: Not Provided

Thanks: 99
Thanked 212 Times in 159 Posts
Default

@ferdz7187 - yes there is software that can hack WPA/WPA2 passwords, but it's only legal to hack your own network. it it definitely ILLEGAL to hack your neighbour's password in most countries. Also, if you use his bandwidth, that may constitute some form of theft.
Davdi is offline  
Reply With Quote
Old November 4th, 2012, 01:16 AM   #17 (permalink)
New Member
 
Join Date: Nov 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,
I've just bought a Sony Xperia Go 4 days ago. My wifi has several other phones and computers on it successfully and even with all of them off, it still doesn't do it. This is very strange. Could it be a batch thing do you think? Could it be my Sim Card? The Router is working fine. The phone picks up my wifi signal stating excellent strength, but cannot connect. It states... Connecting... disconnecting... scanning. (
karrah dolores is offline  
Reply With Quote
Old November 28th, 2012, 06:47 AM   #18 (permalink)
New Member
 
Join Date: Nov 2012
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

YAY nothing worked but this worked for ma:
"if you have acces to root, try to delete everything in folder "/data/misc/dhcp"..worked for me"
Lanka007 is offline  
Reply With Quote
Old July 21st, 2013, 06:04 PM   #19 (permalink)
New Member
 
Join Date: Jul 2013
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Sony xperia U will NOT connect to my wifi

My sony xperia U normally connects to my wifi with no problem. However recently it will not connect to it. It comes up with 'authenticating' and flicks from 'connected' to 'disconnected' and is quite frankly annoying. I do not possibly understand why this has occured and why it will not let me connect. Ive tried turning my phone on and off but that doesnt seem to solve the problem i am having. If anyone has any advice, please share as I am completely and uttery confused and frustrated.
Bambi is offline  
Reply With Quote
Old July 24th, 2013, 09:33 AM   #20 (permalink)
AF Contributor
 
Join Date: Jul 2012
Location: The Shire
Posts: 839
 
Device(s): HTC Wildfire S x 2, Xperia U, Huawei Y300, N7, Generic Allwinner tab, Bluestacks
Carrier: Not Provided

Thanks: 99
Thanked 212 Times in 159 Posts
Default

Can you connect to another WiFi successfully - e.g. the free WiFi in a cafe. If you can, that points to a problem with your wifi. Maybe someone near you has wifi using the same band as yours, that can cause that sort of ptoblem. Download inssider from: inSSIDer for Home – Discover The Wi-Fi Around You | MetaGeek This will show all WiFi around and on which band. If yours is sharing a band with one or more other wiFi networks, log in as admin to your Router and change the setting to use another band. Your phone and other devices should still find it OK and hopefully you'll have a more stable connection.

Of course if the phone can't connect to another WiFi then there are quite a few apps in the play store which say they can boost your phone's wiFi, search for 'WiFi Booster' in the play store and try a few of the apps. They're mostly free so you've got nothing to lose.
Davdi is offline  
Reply With Quote
sponsored links
Old July 27th, 2013, 11:09 PM   #21 (permalink)
New Member
 
Join Date: Apr 2013
Location: Saudi Arabia
Gender: Male
Posts: 3
 
Device(s): Xperia Ray (white), Xperia Ray (black), Xperia U (white), Xperia U (black)
Carrier: STC

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi everyone,

The wifi issue mentioned by the OP occurs on my two U's only after I install/reinstall ICS. Upon first start, the phone behaves exactly like the OP described. The solution (for my phones at least) is to reset the phone right after installing/reinstalling ICS.

OP, reset the device (Settings>Backup & Reset>Factory data reset <or> Settings reset) and see what happens.

I hope this helps.

Shady
sjanzeir is offline  
Reply With Quote
Reply

Sony Xperia U
Current Rating:
Rate this Phone:

The Sony Xperia U is one of three smartphones which were launched with Sony's branding sans Ericsson. It's a mid-range handset compared to the rest in this line with its 1GHz dual-core processor, 512MB of RAM, a 3.5 inch display, Android 2.... Read More

Tags
sony xperia u, wifi access


Go Back   Android Forums > Android Phones > Sony Xperia U

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 01:35 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.