Go Back   Android Forums > Android Phones > LG Spectrum > Spectrum - All Things Root

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

Like Tree2Likes
  • 1 Post By Nokoko
  • 1 Post By ortrigger

test: Reply
 
LinkBack Thread Tools
Old August 20th, 2013, 10:33 PM   #1 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Aug 2012
Posts: 81
 
Device(s):
Carrier: Not Provided

Thanks: 48
Thanked 3 Times in 3 Posts
Default Cm 10.1 based ROMs laggy?!?!

I don't know if its only my device, but when I tried beanstalk and cm 10.1.2 stable ROMs, they were really laggy on my spectrum. By lag, I mean that the transitions and animations arnt smooth. For example, when pulling down the notification bar, the animation isn't smooth. I don't understand, because the spectrum has a 1.5 GHz dual core processor. It should be smooth. My droid bionic (which has a 1.2 GHz TI OMAP dual core) is very smooth on cm10.1. Can anyone please shed some light for me with my situation. I always wipe date, cache, and dalvik right before I install a ROM. Is this consistent lag on cm 10.1 roms normal?

android55555 is offline  
Reply With Quote
sponsored links
Old August 20th, 2013, 10:49 PM   #2 (permalink)
Senior Member
 
Join Date: Mar 2012
Location: Wisconsin
Gender: Male
Posts: 1,348
 
Device(s): LG Spectrum, Droid 1, Nexus 7, OUYA (yeah, it's fun)
Carrier: Not Provided

Thanks: 186
Thanked 792 Times in 421 Posts
Default

Stock CM does not use an over clocked kernel where as TDM's CM10 did. If you're having lag issue, I would grab a custom kernel and see if that helps your performance.
Neph81 is offline  
Reply With Quote
Old August 20th, 2013, 11:10 PM   #3 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Aug 2012
Posts: 81
 
Device(s):
Carrier: Not Provided

Thanks: 48
Thanked 3 Times in 3 Posts
Default

Quote:
Originally Posted by Neph81 View Post
Stock CM does not use an over clocked kernel where as TDM's CM10 did. If you're having lag issue, I would grab a custom kernel and see if that helps your performance.
Oh i forgot to mention I used azoller1's S-Kernel [A16] with the 4.2.2 ROMs and they were laggy. Is the a jelly bean ROM and kernel you recommend that has good performance. I tried to download quattrimus aokp and cm but the links won't open on my phone.
android55555 is offline  
Reply With Quote
Old August 20th, 2013, 11:36 PM   #4 (permalink)
Member
 
Join Date: Mar 2012
Posts: 436
 
Device(s):
Carrier: Not Provided

Thanks: 214
Thanked 158 Times in 120 Posts
Default

CM 10.1.2 stable runs very smooth for me. You can try adjusting the governer, I like Interactive, but different people get better results with different combinations. Is it laggy before you restore your apps? I'm on the CM kernel, all the custom ones we have cause reboots for me and don't feel any smoother or improve battery life. Personally, I'd say CM 10.1.2 has the best performance right now, very little lag at all.
android55555 likes this.
Nokoko is offline  
Reply With Quote
Old August 20th, 2013, 11:52 PM   #5 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Aug 2012
Posts: 81
 
Device(s):
Carrier: Not Provided

Thanks: 48
Thanked 3 Times in 3 Posts
Default

Quote:
Originally Posted by Nokoko View Post
CM 10.1.2 stable runs very smooth for me. You can try adjusting the governer, I like Interactive, but different people get better results with different combinations. Is it laggy before you restore your apps? I'm on the CM kernel, all the custom ones we have cause reboots for me and don't feel any smoother or improve battery life. Personally, I'd say CM 10.1.2 has the best performance right now, very little lag at all.
Thanks for telling me. I'll try installing the ROM and the gapps without a custom kernel when I have time, and I'll report my experiences then! Thank you!
And I didn't install any apps, I just updated the one with updates. I don't use my phone when apps update because it contributes to the lag.
android55555 is offline  
Last edited by android55555; August 20th, 2013 at 11:55 PM.
Reply With Quote
Old August 20th, 2013, 11:58 PM   #6 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Aug 2012
Posts: 81
 
Device(s):
Carrier: Not Provided

Thanks: 48
Thanked 3 Times in 3 Posts
Default

Oh and one more question. After installing a ROM, do you wipe date, cache, and dalvik again for a second time? Do you fix permissions and wipe battery stats after a new ROM installation?
android55555 is offline  
Reply With Quote
Old August 21st, 2013, 09:18 AM   #7 (permalink)
AF Contributor
 
ortrigger's Avatar
 
Join Date: Sep 2012
Gender: Male
Posts: 838
 
Device(s): Sony Xperia Z, Asus Nexus 7 2013
Carrier: T-Mobile

Thanks: 660
Thanked 340 Times in 234 Posts
Default

Quote:
Originally Posted by android55555 View Post
Oh and one more question. After installing a ROM, do you wipe date, cache, and dalvik again for a second time? Do you fix permissions and wipe battery stats after a new ROM installation?
You should only need to do the wipes before installing a ROM. You shouldn't need to wipe battery stats at all. Fix permissions sometimes needs to be done but I would try booting up first and see how it runs before doing it.
android55555 likes this.
__________________
Got the help you need? Join here and become a member of a great community.

Sony Xperia Z: stock; Nexus 7 2013: PSX
ortrigger is offline  
Reply With Quote
The Following User Says Thank You to ortrigger For This Useful Post:
android55555 (August 21st, 2013)
Old August 29th, 2013, 04:23 AM   #8 (permalink)
Member
 
mrryanthai's Avatar
 
Join Date: Aug 2012
Gender: Male
Posts: 490
 
Device(s): Note 2,Nexus 7
Carrier: Not Provided

Thanks: 71
Thanked 26 Times in 23 Posts
mrryanthai@gmail.com
Default

Does anyone have any issues with CM 10.1.2 lagging when pressing the home button and your icons not showing up until 5 seconds later?It's not a problem to me,but it does get annoying
mrryanthai is offline  
Reply With Quote
Old August 29th, 2013, 12:24 PM   #9 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Aug 2012
Posts: 81
 
Device(s):
Carrier: Not Provided

Thanks: 48
Thanked 3 Times in 3 Posts
Default

Quote:
Originally Posted by mrryanthai View Post
Does anyone have any issues with CM 10.1.2 lagging when pressing the home button and your icons not showing up until 5 seconds later?It's not a problem to me,but it does get annoying
That is one of the "lag" problems I was talking about. The only laggy part about cm10.1 roms is the homescreen. It lags when transitioning, going to app drawer, and pulling down notification bar. By lag I mean stutters. In apps (like settings) it's really smooth. After a while of using the Rom (after a fix permissions and cache wipe in recovery, and a couple of reboots) it got really smooth. Then I got a BSOD and had to replace battery. When I rebooted, it began to stutter in the homescreen again. .
Using stock kernal btw
android55555 is offline  
Reply With Quote
Old August 29th, 2013, 02:13 PM   #10 (permalink)
Member
 
Join Date: Mar 2012
Posts: 436
 
Device(s):
Carrier: Not Provided

Thanks: 214
Thanked 158 Times in 120 Posts
Default

Quote:
Originally Posted by mrryanthai View Post
Does anyone have any issues with CM 10.1.2 lagging when pressing the home button and your icons not showing up until 5 seconds later?It's not a problem to me,but it does get annoying
What launcher are you using? I'm using Nova right now and don't have that problem.
Nokoko is offline  
Reply With Quote
sponsored links
Old August 29th, 2013, 02:15 PM   #11 (permalink)
Member
 
mrryanthai's Avatar
 
Join Date: Aug 2012
Gender: Male
Posts: 490
 
Device(s): Note 2,Nexus 7
Carrier: Not Provided

Thanks: 71
Thanked 26 Times in 23 Posts
mrryanthai@gmail.com
Default

Nova as well
mrryanthai is offline  
Reply With Quote
Old August 29th, 2013, 03:27 PM   #12 (permalink)
Senior Member
 
Join Date: Jul 2012
Location: Newnan, GA
Posts: 619
 
Device(s): LG Spectrum
Carrier: VZW

Thanks: 451
Thanked 192 Times in 147 Posts
Default

How many widgets do you have on the home screens?
reeseboy is offline  
Reply With Quote
Old August 29th, 2013, 09:05 PM   #13 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Aug 2012
Posts: 81
 
Device(s):
Carrier: Not Provided

Thanks: 48
Thanked 3 Times in 3 Posts
Default

You guys have been using nova launcher? I've been using trebechut. Is nova smoother than trebechut?
android55555 is offline  
Reply With Quote
Old August 30th, 2013, 04:54 AM   #14 (permalink)
Member
 
mrryanthai's Avatar
 
Join Date: Aug 2012
Gender: Male
Posts: 490
 
Device(s): Note 2,Nexus 7
Carrier: Not Provided

Thanks: 71
Thanked 26 Times in 23 Posts
mrryanthai@gmail.com
Default

Quote:
Originally Posted by reeseboy View Post
How many widgets do you have on the home screens?
Just 2 but when I was using different roms it was fine
mrryanthai is offline  
Reply With Quote
Old August 30th, 2013, 05:54 PM   #15 (permalink)
Member
 
mrryanthai's Avatar
 
Join Date: Aug 2012
Gender: Male
Posts: 490
 
Device(s): Note 2,Nexus 7
Carrier: Not Provided

Thanks: 71
Thanked 26 Times in 23 Posts
mrryanthai@gmail.com
Default

Everything seems fine now
mrryanthai is offline  
Reply With Quote
Old September 7th, 2013, 01:07 PM   #16 (permalink)
Junior Member
 
Join Date: Aug 2013
Posts: 15
 
Device(s): LG G2 (VS980), LG Lucid Prepaid (VS840PP), HTC Bee
Carrier: Verizon Wireless, Straight Talk

Thanks: 9
Thanked 1 Time in 1 Post
Default

I also have been noticing that lag, it happens especially after playing a game like Max Payne, getting out of the game then scrolling through the home screen is laggy, then I let it sit for a minute and its fine again. Running CM 10.1.2-Stable (cm-10.1.2-vs920.zip) Before I was getting a lot of lag, so I put in a live wallpaper and it worked a lot better after that. I am using stock kernel that comes with CM and interactive cpu governor. So your lag issue went away on its own?
scibot is offline  
Last edited by scibot; September 7th, 2013 at 01:40 PM.
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > LG Spectrum > Spectrum - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 06:17 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.