Go Back   Android Forums > Android Phones > Samsung Galaxy S3 > (Sprint/Cricket) Galaxy S3 - All Things Root

test: Reply
 
LinkBack Thread Tools
Old March 23rd, 2013, 08:41 AM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Mar 2013
Location: Denver
Posts: 4
 
Device(s): Samsung GSIII Asus Infinity Pad
Carrier: Sprint

Thanks: 2
Thanked 2 Times in 2 Posts
Default TWRP assert failure when flashing .zip files

Hello. I would like your thoughts and help on this. I have the Samsung GSIII

I am using TWRP 2.3.1.0. When I try to install a zip, no matter what zip, I get an error. This one is related to a TWRP update.

assert failed: getprop("ro.product.device") ==
E:Error in /sdcard/twrp exfat skunk.zip
(Status 7)
E:Error flashing zip /sdcard/twrp exfat skunk.zip

I went to the build.prop to see what's what I see the line:
#ro.build.product is obsolete; use ro.product.device
ro.build.product=d2spr

Checking above this line , I see
ro.product.brand=samsung
ro.product.name=d2spr
ro.product.device=d2spr

This started when I tried to run the OTA update. I was able to update freeza's Jelly Bean 4.1.2 and firmware without issues. After, I tried the TWRP update again, getting the same errors.

I know the solution is staring me in the face but, I cannot seem to figure it out. Searching the forums is not helping much.

Any assistance you can provide would be greatly appreciated.

Thanks,

Advertisements
taaz69 is offline  
Last edited by taaz69; March 23rd, 2013 at 08:45 AM. Reason: Grammer
Reply With Quote
sponsored links
Old March 23rd, 2013, 06:00 PM   #2 (permalink)
not really so scary
 
scary alien's Avatar
 
Join Date: Mar 2010
Location: Indy
Posts: 17,513
 
Device(s): LG Nexus 5, Asus Nexus 7, Samsung Galaxy Nexus, Moto Droid X, HTC Droid Eris
Carrier: T-Mobile

Thanks: 33,129
Thanked 15,075 Times in 7,405 Posts
Default

Quote:
Originally Posted by taaz69 View Post
Hello. I would like your thoughts and help on this. I have the Samsung GSIII

I am using TWRP 2.3.1.0. When I try to install a zip, no matter what zip, I get an error. This one is related to a TWRP update.

assert failed: getprop("ro.product.device") ==
E:Error in /sdcard/twrp exfat skunk.zip
(Status 7)
E:Error flashing zip /sdcard/twrp exfat skunk.zip

I went to the build.prop to see what's what I see the line:
#ro.build.product is obsolete; use ro.product.device
ro.build.product=d2spr

Checking above this line , I see
ro.product.brand=samsung
ro.product.name=d2spr
ro.product.device=d2spr

This started when I tried to run the OTA update. I was able to update freeza's Jelly Bean 4.1.2 and firmware without issues. After, I tried the TWRP update again, getting the same errors.

I know the solution is staring me in the face but, I cannot seem to figure it out. Searching the forums is not helping much.

Any assistance you can provide would be greatly appreciated.

Thanks,
Welcome to the AndroidForums, taaz69!

Sorry for the delayed response...can you tell us which SGS3 / carrier you have (we'll probably need to move your posts re. this to an appropriate SGS3 all-things-root sub-forum (this is the VZW GNex area), but we'll take care of that later ).

So every .zip file you try to flash gives you a status 7 error? Could it be because of signature checking turned on in TWRP (I haven't got 2.3.1.0 installed on my GNex, so I'm not sure where that option is)?

Also, have you tried running my OTA Verifier app against one of the .zip files? (it doesn't matter that their not OTA files--it'll attempt a verification on any .zip with a properly built edify updater-script file).

Lemme know and I'll try to help .
scary alien is online now  
Reply With Quote
Old March 23rd, 2013, 06:31 PM   #3 (permalink)
Moderator
 
jhawkkw's Avatar
 
Join Date: Jul 2011
Location: Rochester, NY
Posts: 10,324
 
Device(s): Nexus 5, HP 14 Chomebook w/ HSPA+, Google Glass, LTE Nexus 7(2013), Chromecast
Carrier: T-Mobile USA

Thanks: 3,155
Thanked 7,009 Times in 3,774 Posts
Default Re: assert failed getprop ro.product.device

Quote:
Originally Posted by scary alien View Post
Welcome to the AndroidForums, taaz69!

Sorry for the delayed response...can you tell us which SGS3 / carrier you have (we'll probably need to move your posts re. this to an appropriate SGS3 all-things-root sub-forum (this is the VZW GNex area), but we'll take care of that later ).

So every .zip file you try to flash gives you a status 7 error? Could it be because of signature checking turned on in TWRP (I haven't got 2.3.1.0 installed on my GNex, so I'm not sure where that option is)?

Also, have you tried running my OTA Verifier app against one of the .zip files? (it doesn't matter that their not OTA files--it'll attempt a verification on any .zip with a properly built edify updater-script file).

Lemme know and I'll try to help .
Looks like sprint based on the device id in the output.
__________________
Site Rules/Guidelines / Meet the Team
If something needs attention, Report it .
If someone helped you, hit to show it.

Current Devices: Nexus 5, HP 14 Chromebook (Data Enabled), Google Glass, (2013) LTE Nexus 7, Chromecast
Retired: Samsung Fascinate, Droid Charge, Galaxy Nexus, (2012) WiFi Nexus 7, Asus TF700, Nexus 4, Logitech Revue
jhawkkw is offline  
Reply With Quote
The Following User Says Thank You to jhawkkw For This Useful Post:
scary alien (March 23rd, 2013)
Old March 23rd, 2013, 07:40 PM   #4 (permalink)
not really so scary
 
scary alien's Avatar
 
Join Date: Mar 2010
Location: Indy
Posts: 17,513
 
Device(s): LG Nexus 5, Asus Nexus 7, Samsung Galaxy Nexus, Moto Droid X, HTC Droid Eris
Carrier: T-Mobile

Thanks: 33,129
Thanked 15,075 Times in 7,405 Posts
Default

Quote:
Originally Posted by jhawkkw View Post
Looks like sprint based on the device id in the output.
Good catch and thank you, jhawk!

Posts moved to the SGS3 Sprint all-things-root area (I'll send taaz69 a PM, too).

taaz69, let us know what else you can tell us.

Thanks!
scary alien is online now  
Reply With Quote
The Following User Says Thank You to scary alien For This Useful Post:
jhawkkw (March 23rd, 2013)
Old March 24th, 2013, 04:18 PM   #5 (permalink)
New Member
Thread Author (OP)
 
Join Date: Mar 2013
Location: Denver
Posts: 4
 
Device(s): Samsung GSIII Asus Infinity Pad
Carrier: Sprint

Thanks: 2
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by scary alien View Post
Welcome to the AndroidForums, taaz69!

Sorry for the delayed response...can you tell us which SGS3 / carrier you have (we'll probably need to move your posts re. this to an appropriate SGS3 all-things-root sub-forum (this is the VZW GNex area), but we'll take care of that later ).

So every .zip file you try to flash gives you a status 7 error? Could it be because of signature checking turned on in TWRP (I haven't got 2.3.1.0 installed on my GNex, so I'm not sure where that option is)?

Also, have you tried running my OTA Verifier app against one of the .zip files? (it doesn't matter that their not OTA files--it'll attempt a verification on any .zip with a properly built edify updater-script file).

Lemme know and I'll try to help .
Thanks you for the welcome and getting me to the right place.

Signature checking is turned off. Not every zip. I first noticed this when I tried to install the OTA update. It failed with basically the same message. I tried updating TWRP with the same result.

I thought I'd try flashing freeza's rom and firmware update. These flashed fine. Strange, huh? I would like to flash to a version of twrp that handles the 64gig sd card. I see twrp 2.3.2.3 works.

I ran OTA Verifiy. If found 6 frozen apps, non of which should effect this:
ChatOn, Game Hub, Kies air, Kies via Wi-Fi, Nfc test, Nfc Service. Outside of this, no issues seen.

Thoughts?

Thanks for taking the time to help. It is very much appreciated.
taaz69 is offline  
Reply With Quote
The Following User Says Thank You to taaz69 For This Useful Post:
scary alien (March 24th, 2013)
Old March 24th, 2013, 04:47 PM   #6 (permalink)
not really so scary
 
scary alien's Avatar
 
Join Date: Mar 2010
Location: Indy
Posts: 17,513
 
Device(s): LG Nexus 5, Asus Nexus 7, Samsung Galaxy Nexus, Moto Droid X, HTC Droid Eris
Carrier: T-Mobile

Thanks: 33,129
Thanked 15,075 Times in 7,405 Posts
Default

No problem, taaz69--thank you also for the additional info.

It is interesting that there's a note in the change log for TWRP 2.3.1.0 which is suspiciously similar to what you are reporting:

Quote:
What's new in 2.3.1.0:
  • Unmount system after boot to prevent some status 7 symlink failed errors on zip install
  • USB Mass Storage code improvements
  • Better handling of mounting storage during boot for some devices
  • Fixed a problem with sizes of images (boot & recovery) after resetting defaults
  • Fixed size errors during backup for some devices on recovery, etc.
  • Fixed a problem with restoring backups when multiple archives were present
TeamWin Projects - TWRP 2.4 - | TeamWin

Sounds like maybe they didn't address all of the issues?

Perhaps upgrading to a more recent version will fix your issues (looks like 2.4.4.0 is the latest version).

Let us know if you try that .

Cheers!
scary alien is online now  
Reply With Quote
The Following User Says Thank You to scary alien For This Useful Post:
taaz69 (March 25th, 2013)
Old March 24th, 2013, 07:44 PM   #7 (permalink)
New Member
Thread Author (OP)
 
Join Date: Mar 2013
Location: Denver
Posts: 4
 
Device(s): Samsung GSIII Asus Infinity Pad
Carrier: Sprint

Thanks: 2
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by scary alien View Post
No problem, taaz69--thank you also for the additional info.

It is interesting that there's a note in the change log for TWRP 2.3.1.0 which is suspiciously similar to what you are reporting:



TeamWin Projects - TWRP 2.4 - | TeamWin

Sounds like maybe they didn't address all of the issues?

Perhaps upgrading to a more recent version will fix your issues (looks like 2.4.4.0 is the latest version).

Let us know if you try that .

Cheers!
LOL, I am trying to get to a more updated version.

I checked those logs but, that specific issue does not seem to be it. The system is not mounted unless I'm missing something.

I was looking at this site to update twrp to a version that supports exfat.

TWRP Custom Recovery with EXFAT Support - Android Forums at AndroidCentral.com

Again, you are awesome for taking the time to help.
taaz69 is offline  
Reply With Quote
The Following User Says Thank You to taaz69 For This Useful Post:
scary alien (March 24th, 2013)
Old March 24th, 2013, 10:12 PM   #8 (permalink)
Senior Member
 
GTWalling's Avatar
 
Join Date: Sep 2012
Location: Alabama USA
Posts: 1,273
 
Device(s): T-Mobile SG3 SGH-T999 Stock Rooted 4.3 No Knox
Carrier: T-Mobile US

Thanks: 23
Thanked 409 Times in 326 Posts
Default

Quote:
Originally Posted by taaz69 View Post
Thanks you for the welcome and getting me to the right place.

Signature checking is turned off. Not every zip. I first noticed this when I tried to install the OTA update. It failed with basically the same message. I tried updating TWRP with the same result.

I thought I'd try flashing freeza's rom and firmware update. These flashed fine. Strange, huh? I would like to flash to a version of twrp that handles the 64gig sd card. I see twrp 2.3.2.3 works.

I ran OTA Verifiy. If found 6 frozen apps, non of which should effect this:
ChatOn, Game Hub, Kies air, Kies via Wi-Fi, Nfc test, Nfc Service. Outside of this, no issues seen.

Thoughts?

Thanks for taking the time to help. It is very much appreciated.
Just an FYI, you must have Stock Recovery for OTA updates and frozen system app, does not mater which ones, can sometimes cause a problem for OTA.
__________________
T-Mobile US SGH-T999
Rooted Stock 4.3 (No KNOX)

If my post is helpful please hit Thanks.
*Unused Ram is Wasted Ram*
GTWalling is offline  
Reply With Quote
The Following 2 Users Say Thank You to GTWalling For This Useful Post:
scary alien (March 24th, 2013), taaz69 (March 25th, 2013)
Old March 25th, 2013, 01:40 PM   #9 (permalink)
New Member
Thread Author (OP)
 
Join Date: Mar 2013
Location: Denver
Posts: 4
 
Device(s): Samsung GSIII Asus Infinity Pad
Carrier: Sprint

Thanks: 2
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by GTWalling View Post
Just an FYI, you must have Stock Recovery for OTA updates and frozen system app, does not mater which ones, can sometimes cause a problem for OTA.

Point taken. Thanks for the reminder. It has been a while since I have had to mess with this.

To tell you the truth, I'm not sure how/when I got twrp. I probably did this a while back. This rom has been running so good, I did not need to mess with it. I updated freeza's rom and all so I'm good there.

I'm not really concerned with getting OTA's since I just flash a rom when the need arises. It just happened that when I tried, I got the error which led into the same error flashing twrp. The only thing I would like to do at this point is update twrp to get exfat support.

Thanks for the help!

Update: I finally got time to work on this. I installed the latest twrp via Goo Manager. All is good.

May the force be with you!
taaz69 is offline  
Last edited by taaz69; March 26th, 2013 at 07:10 PM. Reason: Update.
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > Samsung Galaxy S3 > (Sprint/Cricket) Galaxy S3 - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 03:47 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.