Go Back   Android Forums > Android Phones > HTC Hero (Sprint) > Sprint Hero - All Things Root
Sprint Hero - All Things Root Rooting, ROMS, Overclocking, etc.

test: Reply
 
LinkBack Thread Tools
Old June 22nd, 2011, 03:31 PM   #1 (permalink)
Senior Member
Thread Author (OP)
 
Join Date: Aug 2010
Posts: 836
 
Device(s):
Carrier: Not Provided

Thanks: 82
Thanked 60 Times in 52 Posts
Default Phone won't read SD card

I'm running the latest aospCMod with firats at 100 18. I use an app called Cache Cleaner NG because it cleans the internal memoery and the SD memory. I've Bennett using it for about 6 months with no issues. I was using the app and for some reason it was taking way too long to clean the cache. I pressed the home button because back wouldn't work at the time. Afterwards my phone was very laggy. I noticed that the cache cleaner was still running in the background also. I tried wiping the data on the cache cleaner but kept getting force closes on Titanium Backup. So I booted into recovery and wiped cached and dalvik cache. The phone rebooted fine, but not it will not read the SD card at all. When I check storage settings it says unavailable. I've tried taking the card out and pitting it back in several times with many reboots, nothing's working. I've read online that a possible fix is to do a factory reset on the phone. Is this the only option?

Forgive the lack of paragraphs. I'm on the phone typing this and am in a hurry and can't see where to break the lines. Thanks for album help guys.

Advertisements
oOMavrikOo is online now  
Reply With Quote
sponsored links
Old June 22nd, 2011, 03:43 PM   #2 (permalink)
Senior Member
 
LBPHeretic's Avatar
 
Join Date: May 2010
Location: Wilmington, Delaware
Posts: 2,368
 
Device(s): Sprint HTC Hero (OEM Android 2.1) [Rooted] B&N Nook Color
Carrier: Not Provided

Thanks: 46
Thanked 507 Times in 407 Posts
Default

Sounds like you might have corrupted your microSD card. Perhaps you canceled the process by rebooting while it was in the middle of writing something.

Are you able to read the card using a microSD card reader? You may have to format your microSD card.
__________________
Nokia 638 > Motorola Talkabout > Motorola V60t > Motorola V60i > Motorola V505 > Samsung Epix > HTC Hero & Barnes & Noble Nook Color

Tweet with me about Android on Twitter. (Please follow to see my tweets.)
LBPHeretic is offline  
Reply With Quote
Old June 22nd, 2011, 03:55 PM   #3 (permalink)
Senior Member
Thread Author (OP)
 
Join Date: Aug 2010
Posts: 836
 
Device(s):
Carrier: Not Provided

Thanks: 82
Thanked 60 Times in 52 Posts
Default

I don't have a SD card reader. Is a factory reset from the phone settings the same thing as wiping data from recovery? I think the answer is no but I just wanna make sure.
oOMavrikOo is online now  
Reply With Quote
Old June 22nd, 2011, 04:06 PM   #4 (permalink)
Senior Member
 
LBPHeretic's Avatar
 
Join Date: May 2010
Location: Wilmington, Delaware
Posts: 2,368
 
Device(s): Sprint HTC Hero (OEM Android 2.1) [Rooted] B&N Nook Color
Carrier: Not Provided

Thanks: 46
Thanked 507 Times in 407 Posts
Default

Quote:
Originally Posted by oOMavrikOo View Post
I don't have a SD card reader. Is a factory reset from the phone settings the same thing as wiping data from recovery? I think the answer is no but I just wanna make sure.
If you plug your handset in with a USB cable, can you mount it and see the contents of your microSD card on your computer? If not, then it is probably hosed and either needs to be formatted or replaced.

I hosed an SD card in a digital camera when it was writing to it after taking a video. I stupidly shut it off before it was done writing the data. You can try wiping data, which is technically a factory reset. If I were you, I would put an alternate microSD card in and do a Nandroid backup first.
LBPHeretic is offline  
Reply With Quote
Old June 22nd, 2011, 04:16 PM   #5 (permalink)
Senior Member
Thread Author (OP)
 
Join Date: Aug 2010
Posts: 836
 
Device(s):
Carrier: Not Provided

Thanks: 82
Thanked 60 Times in 52 Posts
Default

Quote:
Originally Posted by LBPHeretic View Post
If you plug your handset in with a USB cable, can you mount it and see the contents of your microSD card on your computer? If not, then it is probably hosed and either needs to be formatted or replaced.

I hosed an SD card in a digital camera when it was writing to it after taking a video. I stupidly shut it off before it was done writing the data. You can try wiping data, which is technically a factory reset. If I were you, I would put an alternate microSD card in and do a Nandroid backup first.

I'll have to try using the CPU when I get home later. I also want to correct myself from earlier. It doesn't say it can't read it. It says its not mounted. That there is no external storage. Is that the same thing?
oOMavrikOo is online now  
Reply With Quote
Old June 22nd, 2011, 04:30 PM   #6 (permalink)
Senior Member
 
LBPHeretic's Avatar
 
Join Date: May 2010
Location: Wilmington, Delaware
Posts: 2,368
 
Device(s): Sprint HTC Hero (OEM Android 2.1) [Rooted] B&N Nook Color
Carrier: Not Provided

Thanks: 46
Thanked 507 Times in 407 Posts
Default

Quote:
Originally Posted by oOMavrikOo View Post
I'll have to try using the CPU when I get home later. I also want to correct myself from earlier. It doesn't say it can't read it. It says its not mounted. That there is no external storage. Is that the same thing?
Go into Settings, then SD & Phone Storage, and there you can mount it. That might solve your issue.

Let us know if that helped. Cheers.
LBPHeretic is offline  
Reply With Quote
Old June 22nd, 2011, 07:37 PM   #7 (permalink)
Senior Member
Thread Author (OP)
 
Join Date: Aug 2010
Posts: 836
 
Device(s):
Carrier: Not Provided

Thanks: 82
Thanked 60 Times in 52 Posts
Default

Just plugged into the cpu, not even showing usb mass storage options. I've also tried a different sd card and that's not working either. I'm gonna try a factory reset from the settings and see what that does...

Edit: Factory reset fixed it. Still sucks that I gotta set everything up again.
oOMavrikOo is online now  
Last edited by oOMavrikOo; June 22nd, 2011 at 07:45 PM.
Reply With Quote
Old June 23rd, 2011, 06:31 AM   #8 (permalink)
♡ Spidey Sense !! ♡ ™
 
DonB's Avatar
 
Join Date: Nov 2009
Location: 18th Hole Of the Golf Course
Gender: Male
Posts: 18,625
 
Device(s): Moto X 16 GB Cricket Wireless®/ Stock Galaxy Note 10.1 ®
Carrier: Crickets Wireless ®

Thanks: 6,674
Thanked 7,080 Times in 4,173 Posts
Default

Sorry I was busy yesterday, I don't think you needed to do a FR, you could of tried it with a reader first, then you could of also used the media scanner in the phone and try it again
__________________


Site Rules/Guidelines
If something needs attention, Report it .
If someone helped you, hit to show it.

CRICKET Referral Program Bonus $ PM me if you need a referral



DonB is online now  
Reply With Quote
Old June 23rd, 2011, 07:39 AM   #9 (permalink)
Senior Member
Thread Author (OP)
 
Join Date: Aug 2010
Posts: 836
 
Device(s):
Carrier: Not Provided

Thanks: 82
Thanked 60 Times in 52 Posts
Default

Quote:
Originally Posted by DonB View Post
Sorry I was busy yesterday, I don't think you needed to do a FR, you could of tried it with a reader first, then you could of also used the media scanner in the phone and try it again

It's ok. After restoring with TB, fixing the settings, and adding some widgets, I'm back up and running.
oOMavrikOo is online now  
Reply With Quote
Old June 23rd, 2011, 08:00 AM   #10 (permalink)
Senior Member
 
LBPHeretic's Avatar
 
Join Date: May 2010
Location: Wilmington, Delaware
Posts: 2,368
 
Device(s): Sprint HTC Hero (OEM Android 2.1) [Rooted] B&N Nook Color
Carrier: Not Provided

Thanks: 46
Thanked 507 Times in 407 Posts
Default

Did you ever try mounting it like I said above? Sometimes, in very rare cases, it will just show as unmounted.

In that case you have to remount it yourself. You could have potentially saved yourself some trouble.
LBPHeretic is offline  
Reply With Quote
sponsored links
Old June 23rd, 2011, 09:54 AM   #11 (permalink)
Senior Member
Thread Author (OP)
 
Join Date: Aug 2010
Posts: 836
 
Device(s):
Carrier: Not Provided

Thanks: 82
Thanked 60 Times in 52 Posts
Default

Quote:
Originally Posted by LBPHeretic View Post
Did you ever try mounting it like I said above? Sometimes, in very rare cases, it will just show as unmounted.

In that case you have to remount it yourself. You could have potentially saved yourself some trouble.

Yeah I tried that. It didn't work.
oOMavrikOo is online now  
Reply With Quote
Old June 23rd, 2011, 03:14 PM   #12 (permalink)
Senior Member
Thread Author (OP)
 
Join Date: Aug 2010
Posts: 836
 
Device(s):
Carrier: Not Provided

Thanks: 82
Thanked 60 Times in 52 Posts
Default

Ever since this happened to my phone, Facebook wont load the profile pics in my contacts. I can see all of my friends, just not their profile pics. I normally join my phone contacts with my Facebook contacts in order to use the pics for each contact. I've had Facebook synced since early this morning. Maybe I've just never paid any attention, but does it normally take more than an hour or so to fully sync with Facebook?
oOMavrikOo is online now  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > HTC Hero (Sprint) > Sprint Hero - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 09:29 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.