Go Back   Android Forums > Android Phones > Samsung Galaxy S4 > (AT&T) Galaxy S4 - All Things Root

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

Like Tree2Likes
  • 1 Post By BadTA
  • 1 Post By Atma

test: Reply
 
LinkBack Thread Tools
Old June 17th, 2013, 05:07 PM   #1 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jul 2011
Posts: 44
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 3 Times in 3 Posts
Default No data after CM-10.1 nightly

I don't know if it too early to expect custom ROMs to be available and working, but I found that CM-10.1 has some out there.

Anyway, I used motochopper to root and then GooManager to install TWRP.

I did a full backup, then wipe cache, dalvic cache and wipe factory in TWRP. Then flashed the latest nightly from CM.

No issues were noticed during the above steps, but I do not get a data connection once booted. No 4G, 3G....nothin.

Any thoughts?

BadTA is offline  
Reply With Quote
sponsored links
Old June 18th, 2013, 09:52 AM   #2 (permalink)
Senior Member
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,070
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,901 Times in 1,850 Posts
Default

You might try a factory reset and see if that helps. Or turn airplane mode off and on a couple times. Also, check your apn settings to see if they are correct.
__________________
Helpful FAQ's, Site Rules/Guidelines
Atma is offline  
Reply With Quote
Old June 18th, 2013, 10:10 AM   #3 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jul 2011
Posts: 44
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 3 Times in 3 Posts
Default

Quote:
Originally Posted by Atma View Post
You might try a factory reset and see if that helps. Or turn airplane mode off and on a couple times. Also, check your apn settings to see if they are correct.
Thank you. I have tried factory reset and toggling airplane mode. I have done those things many times. I am not sure about the apn settings. What are those?
BadTA is offline  
Reply With Quote
Old June 18th, 2013, 10:28 AM   #4 (permalink)
Senior Member
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,070
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,901 Times in 1,850 Posts
Default

The apn is what you need for data to work.

Go to settings > connections > more networks > mobile networks > access point names. You should see an apn for AT&T. If you don't you will need to add it. I have the T-Mobile S4 so I'm not sure what the settings would be for AT&T.

I found these for the AT&T S4. You can see if they work if you don't have it. Press your menu button and select New APN.

Name: ATT Phone
APN: phone
Proxy: Not set
Port : Not set
User name: Not set
Password: Not set
Server: Not set
MMSC: http://mmsc.mobile.att.net
MMS proxy: proxy.mobile.att.net
MMS port: 80
MCC: 300
MNC: 410
Authentication type: None
APN type: default,mms,supl,hipri
APN protocol: IPv4
APN roaming protocol: IPv4
Enable/disable APN: APN enabled
Bearer: Unspecified
Atma is offline  
Reply With Quote
Old June 18th, 2013, 01:18 PM   #5 (permalink)
Junior Member
Thread Author (OP)
 
Join Date: Jul 2011
Posts: 44
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 3 Times in 3 Posts
Default

Thank you!

I had that apn, but did not have 'hipri' listed in 'APN Type'

Seems to work now.

Quote:
Originally Posted by Atma View Post
The apn is what you need for data to work.

Go to settings > connections > more networks > mobile networks > access point names. You should see an apn for AT&T. If you don't you will need to add it. I have the T-Mobile S4 so I'm not sure what the settings would be for AT&T.

I found these for the AT&T S4. You can see if they work if you don't have it. Press your menu button and select New APN.

Name: ATT Phone
APN: phone
Proxy: Not set
Port : Not set
User name: Not set
Password: Not set
Server: Not set
MMSC: http://mmsc.mobile.att.net
MMS proxy: proxy.mobile.att.net
MMS port: 80
MCC: 300
MNC: 410
Authentication type: None
APN type: default,mms,supl,hipri
APN protocol: IPv4
APN roaming protocol: IPv4
Enable/disable APN: APN enabled
Bearer: Unspecified
Atma likes this.
BadTA is offline  
Reply With Quote
The Following User Says Thank You to BadTA For This Useful Post:
Atma (June 18th, 2013)
Old June 18th, 2013, 04:55 PM   #6 (permalink)
Senior Member
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,070
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,901 Times in 1,850 Posts
Default

Quote:
Originally Posted by BadTA View Post
Thank you!

I had that apn, but did not have 'hipri' listed in 'APN Type'

Seems to work now.

You're welcome. Glad it worked.
BadTA likes this.
Atma is offline  
Reply With Quote
Reply


Go Back   Android Forums > Android Phones > Samsung Galaxy S4 > (AT&T) Galaxy S4 - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 09:51 AM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.