Go Back   Android Forums > Android Phones > T-Mobile G2

New Forums: Nexus Player | Nexus 9
test: Reply
 
LinkBack Thread Tools
Old November 14th, 2010, 03:32 PM   #1 (permalink)
Member
Thread Author (OP)
 
dbgrigg189's Avatar
 
Join Date: Apr 2010
Location: Gaston Co. NC
Posts: 120
 
Device(s): T-Mobile G2 (stock Froyo)
Carrier: Not Provided

Thanks: 0
Thanked 11 Times in 11 Posts
Send a message via AIM to dbgrigg189 Send a message via Yahoo to dbgrigg189
Default G2 going to speaker phone in call

During calls, my phone keep randomly going into speaker phone mode. Is anyone else having this problem/Have any ideas for a solution. I called tech support a few days ago and they said it is affecting 1 in 20 phones, and that it has increased since the update. Also that 50% of the time doing a master reset fixes the problem, no luck on my first one, and I just reset the second one, so I guess we will see what happens. In the mean time, any info anyone else has would be great. Thanks

Advertisements
dbgrigg189 is offline  
Reply With Quote
sponsored links
Old November 19th, 2010, 02:32 PM   #2 (permalink)
Member
Thread Author (OP)
 
dbgrigg189's Avatar
 
Join Date: Apr 2010
Location: Gaston Co. NC
Posts: 120
 
Device(s): T-Mobile G2 (stock Froyo)
Carrier: Not Provided

Thanks: 0
Thanked 11 Times in 11 Posts
Send a message via AIM to dbgrigg189 Send a message via Yahoo to dbgrigg189
Default

So seriously, 45 views and no one even has any ideas or any input? I am on my 3rd phone here...
dbgrigg189 is offline  
Reply With Quote
Old November 19th, 2010, 03:42 PM   #3 (permalink)
Member
 
Join Date: Sep 2010
Location: California
Posts: 154
 
Device(s): HTC G2
Carrier: Not Provided

Thanks: 3
Thanked 19 Times in 18 Posts
Default

Oh, we've got ideas. We just didn't think that 45 posts saying "stop holding the phone such that you touch the speaker button" would be constructive. Not to be condescending, but you've had three phones doing the same thing, and no one else on any android forums has the same issue? Not even on XDA, and they complain about EVERYTHING there. Maybe it's you? The tech probably told you that just to make you feel better.

For this to be true, you'd have to be holding the phone so that the lower right corner of the screen is touching your cheek, and the upper left is far enough away from your ear so that the proximity sensor isn't triggering. Try not doing that. The microphone is extremely sensitive, you do not need to hold the phone near your mouth for it to work.
justme8800 is offline  
Reply With Quote
Old November 19th, 2010, 03:46 PM   #4 (permalink)
Member
Thread Author (OP)
 
dbgrigg189's Avatar
 
Join Date: Apr 2010
Location: Gaston Co. NC
Posts: 120
 
Device(s): T-Mobile G2 (stock Froyo)
Carrier: Not Provided

Thanks: 0
Thanked 11 Times in 11 Posts
Send a message via AIM to dbgrigg189 Send a message via Yahoo to dbgrigg189
Default

I'm aware of what I would be doing to cause it to happen, and I'm making sure I'm not doing that, I appreciate the smart ass remarks though, quite helpful.
dbgrigg189 is offline  
Reply With Quote
Old January 13th, 2011, 08:28 AM   #5 (permalink)
New Member
 
Join Date: Jan 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

This is not a problem with how the person is holding the device against their cheek as this is happning when held away.

It is a very unique problem and one that we are currently investigating and one that is not resolved by any form of reset, soft or factory.

Currently the only thing that we can suggest is that you speak to the HTC technical support to escalate the problem and more than likely get the phone replaced.
HTC_Agent is offline  
Reply With Quote
Old January 13th, 2011, 10:35 AM   #6 (permalink)
Member
 
Join Date: Dec 2010
Location: Who? Stun?
Posts: 119
 
Device(s): Nexus One, Samsung Vibrant, HTC G2, Samsung Galaxy Epic 4G Touch *whew*
Carrier: Not Provided

Thanks: 11
Thanked 10 Times in 7 Posts
nonickname90
Default

Why don't you try talking away from the phone, like talk and stare at the phone, and see if it goes into Speaker phone mode. Like say open your VoiceMail and I guess navigate thoughout your voice mail and see. If it never goes into Speakerphone when you're in your voicemail, then maybe its the cheek thing.

I just played around in my voicemail, and seen that I'm able to hit the "mute" button if the screen doesn't lock in time. But I had to really aim for the mute button. LoL!!

I don't have this issue, and you being on your 3rd phone. No one can be that lucky to get 3 defects in a row like that.

If it bothers you so much though, you can get a bluetooth headset or use the headset that came with the phone.
No_Nickname90 is offline  
Reply With Quote
Old January 14th, 2011, 03:27 PM   #7 (permalink)
Member
Thread Author (OP)
 
dbgrigg189's Avatar
 
Join Date: Apr 2010
Location: Gaston Co. NC
Posts: 120
 
Device(s): T-Mobile G2 (stock Froyo)
Carrier: Not Provided

Thanks: 0
Thanked 11 Times in 11 Posts
Send a message via AIM to dbgrigg189 Send a message via Yahoo to dbgrigg189
Default

Well just to clear up this issue, since i forgot about this posting, there is a small issue with the proximity sensor and being in direct sunlight. If the sensor isn't completely covered the sunlight can cause the sensor to trip and the screen to wake.
dbgrigg189 is offline  
Reply With Quote
Old January 26th, 2011, 09:21 PM   #8 (permalink)
New Member
 
Join Date: Jan 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm so relieved that I'm not the only one this happens to!! My phone calls also randomly go on mute! I'm on my 3rd G2 (I got my third replacement yesterday) and the problem is persisting! I thought I was doing something wrong but I'm glad to know it's HTC. . . I'm not too glad to find out that there's no resolution
SmartHusky is offline  
Last edited by SmartHusky; January 26th, 2011 at 09:23 PM.
Reply With Quote
Old January 27th, 2011, 12:30 AM   #9 (permalink)
Member
Thread Author (OP)
 
dbgrigg189's Avatar
 
Join Date: Apr 2010
Location: Gaston Co. NC
Posts: 120
 
Device(s): T-Mobile G2 (stock Froyo)
Carrier: Not Provided

Thanks: 0
Thanked 11 Times in 11 Posts
Send a message via AIM to dbgrigg189 Send a message via Yahoo to dbgrigg189
Default

Check out the post before this one, Think about when and where you are using it. Is it when you are outside in direct sunlight? If so make sure you have the sensor completely covered.
dbgrigg189 is offline  
Reply With Quote
Old June 9th, 2011, 07:44 AM   #10 (permalink)
New Member
 
Join Date: Nov 2010
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

This is happening on one of my G2's also and is becoming increasingly frustrating. It just started happening in the last 3-4 weeks, but seems be more frequent and pretty much effects every single call now. I can guarantee you that mine is not from my cheek or sunlight. I was just sitting here at my desk on a conference call with the supplied headphones. The G2 was siting on my desk and it suddenly switched to speaker mode.

I have noticed when it switches, a message pops up on the screen. The message that appears is relay server verified.

I've had mine happen while on wired headset, while on BT headset, and while just on the phone. It also happens frequently right after I answer a call. This is causing issues when I'm connected to BT on my motorcycle helmet and a call comes in and my phone decides to go to speaker mode instead of BT like it should. My phone is usually tucked away in a pocket and instead of the caller hearing me nice and quiet in my helmet, they hear nothing but wind noise. So aggravating especially when its calls I'm expecting.

I actually have two G2 phones (1 work and 1 personal). My work phone is the one being affected, but I do spend a lot more time talking on it for conference calls etc, then my personal phone. I have not seen my personal G2 do this yet.

I would definitely be interested in some more ideas and ways to fix this. The fact this is starting to affect almost every call I use, the phone is becoming increasingly frustrating to use.

Phone details
Stock phone running Android 2.2
Baseband: 12.28b.60.140eU_26.03.02.26_M
Kernal: 2.6.32.17-g9ab3677
htc-kernal@and18-2 #1
Build 1.22.531.8 CL277427 release-keys
BlueLghtning is offline  
Last edited by BlueLghtning; June 9th, 2011 at 02:33 PM.
Reply With Quote
sponsored links
Old June 9th, 2011, 02:16 PM   #11 (permalink)
Junior Member
 
Join Date: Dec 2010
Posts: 15
 
Device(s): HTC G2
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
heisdnice@gmail.com
Default

ive also had this issue.
i rebooted the phone and it would go away.
has happened about 5 times.
heisdnice is offline  
Reply With Quote
Old June 9th, 2011, 02:35 PM   #12 (permalink)
New Member
 
Join Date: Nov 2010
Posts: 8
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

I just updated my original post. I was just on a hour long conference call. I was using my wired headset and 1hr 4mins into the call, it switched to speaker phone by its self. I saw the screen light up and it said "relay server verified".

I've also answered my phone about 5x times today and every single time I answer it, it automatically goes into speaker phone mode.
BlueLghtning is offline  
Reply With Quote
Old September 1st, 2011, 09:27 AM   #13 (permalink)
New Member
 
Join Date: Sep 2011
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs down HTC G2 automatic speaker phone

I have the same problem on my G2 phone. It started happening right after the upgrade. It only happens when certain people call but I've just started to begin experiencing these problems. I googled it and found this forum hoping I could find a solution. Are you saying that t-mobile has no solution to this problem and may or may not be working on solving this bug? THis is a major inconvenience. When I answer my phone I dont expect for everyone else to hear my conversation. Whats the point of buying these expensive phones if they dont work properly.
ZiggyM is offline  
Reply With Quote
Old January 16th, 2013, 07:30 PM   #14 (permalink)
New Member
 
Join Date: Jan 2013
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default Still Happening

This is the only link I found via Google that has this search term. I see this is an old thread. I was wondering if anyone has found a solution.

Atrix 2 At&t ICS.

I use the BT almost exclusively. Lately I will answer the phone and notice that a message will appear of relay server verified. A little later both my speaker phone option will activate while the blue tooth will continue to function. I can then switch off the speaker phone but will get echoes of myself thru the blue tooth.

This happens no matter if it is in sunlight, in the dark, in a pocket, on a desk, in the heat, or in the cold.

Any Ideas?
VMXTech is offline  
Reply With Quote
Reply

T-Mobile G2
Current Rating:
Rate this Phone:

The T-Mobile G2 came as the successor to the G1, the worlds very first Android phone. The G Series has come a long way since then, but has retained one major element: a stock Android experience that forgoes any manufacturer customizations to the us... Read More



Go Back   Android Forums > Android Phones > T-Mobile G2
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 05:22 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.