Go Back   Android Forums > Android Phones > Samsung Galaxy S4 > (T-Mobile) Galaxy S4 - All Things Root

Get excited for the Samsung Galaxy S5! Find everything you need and discuss it in our Galaxy S5 Forum!

Like Tree2Likes
  • 1 Post By XxKINGxX40
  • 1 Post By XxKINGxX40

 
 
LinkBack Thread Tools
Old May 8th, 2013, 01:16 AM  
New Member
Thread Author (OP)
 
Join Date: Jan 2013
Location: US
Posts: 7
 
Device(s): Samsung Galaxy S4
Carrier: T-Mobile

Thanks: 3
Thanked 1 Time in 1 Post
Default Can't connect to wifi/ prevention information help!

ok. so, when i try to turn wifi on, i get a notification saying "The device has detected an application attempting unpermitted actions and has stopped loading. To protect your device, it is recommended you reboot." Please help?

ezequielin2580 is offline  
The Following User Says Thank You to ezequielin2580 For This Useful Post:
XxKINGxX40 (May 8th, 2013)
sponsored links
Old May 8th, 2013, 06:14 AM  
Senior Member
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,070
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,901 Times in 1,850 Posts
Default

Follow k0ane's Odin guide and install the firmware again. Something similar happened to me except I couldn't turn on wifi at all. People are also having the same problem when trying to root the MDL firmware.
__________________
Helpful FAQ's, Site Rules/Guidelines
Atma is offline  
Old May 8th, 2013, 11:14 AM  
New Member
Thread Author (OP)
 
Join Date: Jan 2013
Location: US
Posts: 7
 
Device(s): Samsung Galaxy S4
Carrier: T-Mobile

Thanks: 3
Thanked 1 Time in 1 Post
Default

I already tried that, and factory reset. and nothing.
ezequielin2580 is offline  
Old May 8th, 2013, 12:02 PM  
Senior Member
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,070
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,901 Times in 1,850 Posts
Default

Try a factory reset, power off, go to Odin and install the firmware again. I think that's how I got it to work. If it doesn't you can use k0ane's guide and install the firmware the phone came with. The one named Stock Tar. You can also take a look in this thread. A few others have that problem.
Atma is offline  
Old May 8th, 2013, 12:06 PM  
Junior Member
 
Join Date: May 2013
Location: ATL, GA
Gender: Male
Posts: 16
 
Device(s): HTC One M8
Carrier: T-Mobile

Thanks: 2
Thanked 2 Times in 2 Posts
Default

Thanks Atma. im having the exact same problem. hope it fixes it.
XxKINGxX40 is online now  
Old May 8th, 2013, 12:26 PM  
Senior Member
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,070
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,901 Times in 1,850 Posts
Default

Quote:
Originally Posted by XxKINGxX40 View Post
Thanks Atma. im having the exact same problem. hope it fixes it.
Welcome to the forum King.

I know its a pain. I think when it happened to me, I restored a rooted nandroid backup I had of the original build. I went to recovery and did a factory reset, then used Odin to install the new build again and it was working ok. So you may need to go back to the first build, factory reset and install the new one.
Atma is offline  
Old May 8th, 2013, 12:49 PM  
Senior Member
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,070
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,901 Times in 1,850 Posts
Default

mattlgroff, one of the devs at XDA updated the thread with a fix for the wifi problem and the the "Modified" notification. If reinstalling the stock with Odin doesn't work, you can install a custom recovery and then flash ROOT_M919UVUAMDL.zip. Read the OP of the thread for more.
Atma is offline  
Old May 8th, 2013, 01:17 PM  
Junior Member
 
Join Date: May 2013
Location: ATL, GA
Gender: Male
Posts: 16
 
Device(s): HTC One M8
Carrier: T-Mobile

Thanks: 2
Thanked 2 Times in 2 Posts
Default

thanks. I did what you said. i downloaded UVUAMDB and flashed it with odin. now, i can connect to wifi and i dont get the error anymore. but, i cant update ota. it still says device has been modified.
XxKINGxX40 is online now  
Old May 8th, 2013, 01:33 PM  
Senior Member
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,070
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,901 Times in 1,850 Posts
Default

You can try a factory reset and see if that works, or try a factory reset and Odin the update again or just leave it since you already have the update.
Atma is offline  
Old May 8th, 2013, 04:48 PM  
Senior Member
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,070
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,901 Times in 1,850 Posts
Default

Quote:
Originally Posted by Atma View Post
You can try a factory reset and see if that works, or try a factory reset and Odin the update again or just leave it since you already have the update.
Sorry, let me rephrase that. I misread your post. If you have MDB, then try a factory reset in the stock recovery and then Odin MDL and see if that clears everything up.
Atma is offline  
sponsored links
Old May 9th, 2013, 12:06 AM  
Junior Member
 
Join Date: May 2013
Location: ATL, GA
Gender: Male
Posts: 16
 
Device(s): HTC One M8
Carrier: T-Mobile

Thanks: 2
Thanked 2 Times in 2 Posts
Default

Hey Atma, I tried what you said. I went to the stock recovery and did a factory reset, and then went to download mode and used odin to flash MDL. but, i couldnt connect to wifi again and i got the same message. so, i re-flashed MDB.
XxKINGxX40 is online now  
Old May 9th, 2013, 08:15 AM  
Senior Member
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,070
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,901 Times in 1,850 Posts
Default

Sorry King. I don't know why I was able to get mine to work and other people are having such a problem. I can only think of one other thing to try.

If you're on the MDB build, use Odin and install TWRP. Reboot into TWRP recovery. Select Wipe. Then select Advanced. Check the boxes for wiping cache, dalvik cache, system and data. Swipe to wipe. Then back in the main wipe menu, swipe to do a factory reset. Now power off your phone, start Odin, put your phone in Odin mode and install the new MDL update.
Atma is offline  
Old May 10th, 2013, 06:32 PM  
Junior Member
 
Join Date: May 2013
Location: ATL, GA
Gender: Male
Posts: 16
 
Device(s): HTC One M8
Carrier: T-Mobile

Thanks: 2
Thanked 2 Times in 2 Posts
Default

did that, and still. same thing. I dont get it. When i had the S3 with Metro before i moved to t mobile, I did the same thing, and it went back to stock perfectly. i could update ota. but now, i cant no matter what i do...
XxKINGxX40 is online now  
Old May 11th, 2013, 08:25 AM  
Senior Member
 
Atma's Avatar
 
Join Date: Dec 2011
Location: North Carolina
Gender: Male
Posts: 6,070
 
Device(s): Samsung Galaxy S4, Samsung Galaxy S2; Nexus 10
Carrier: T-Mobile

Thanks: 3,427
Thanked 2,901 Times in 1,850 Posts
Default

Quote:
Originally Posted by XxKINGxX40 View Post
did that, and still. same thing. I dont get it. When i had the S3 with Metro before i moved to t mobile, I did the same thing, and it went back to stock perfectly. i could update ota. but now, i cant no matter what i do...

Ok, something else you can try if you want to. Install the MDL update and use the instructions for rooting it. An option besides using the ROOT_M919UVUAMDL.zip file he has listed is to install this kernel. If the root file doesn't do it, the kernel fixes the problem with no wifi. Then you can either stay rooted like that or try installing the stock MDL again and see if it works.
Atma is offline  
Old May 11th, 2013, 11:23 AM  
Junior Member
 
Join Date: May 2013
Location: ATL, GA
Gender: Male
Posts: 16
 
Device(s): HTC One M8
Carrier: T-Mobile

Thanks: 2
Thanked 2 Times in 2 Posts
Default

actually, i tried this, and it worked. http://forum.xda-developers.com/showthread.php?t=2261013
Atma likes this.
XxKINGxX40 is online now  
The Following User Says Thank You to XxKINGxX40 For This Useful Post:
Atma (May 11th, 2013)
Old May 15th, 2013, 01:44 AM  
Junior Member
 
Join Date: May 2013
Location: ATL, GA
Gender: Male
Posts: 16
 
Device(s): HTC One M8
Carrier: T-Mobile

Thanks: 2
Thanked 2 Times in 2 Posts
Default

the thing that worked for me, was that i used kies. i had the MDB build, and i used kies to download the MDL update. and via kies, i updated, and now when i click on software update on the phone, it says its up to date instead of the device has been modified. and now on the device status it says official instead of custom.
Atma likes this.
XxKINGxX40 is online now  
The Following User Says Thank You to XxKINGxX40 For This Useful Post:
Atma (May 15th, 2013)
Old August 2nd, 2013, 03:46 PM  
New Member
 
Join Date: Oct 2010
Posts: 1
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

i wrote up a full solution walkthrough that will let you maintain your data and fix the problem on my site. ("add http here"://goo.gl/qotrIz
jejogo is offline  
 

Go Back   Android Forums > Android Phones > Samsung Galaxy S4 > (T-Mobile) Galaxy S4 - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 02:28 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.