Go Back   Android Forums > Android Phones > HTC One > (AT&T) One - All Things Root

New Forums: Nexus Player | Nexus 9
test: Reply
 
LinkBack Thread Tools
Old September 18th, 2013, 05:18 PM   #1 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jul 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default I rooted my HTC one and now camera doesn't work..

Any suggestions? It either freezes, or the screen is just completely black and won't take any pictures..

Advertisements
Hiruki is offline  
Reply With Quote
sponsored links
Old September 18th, 2013, 05:24 PM   #2 (permalink)
Dr. Feelgood
 
Rxpert83's Avatar
 
Join Date: Aug 2011
Location: MN
Gender: Male
Posts: 17,369
 
Device(s): Nexus 7, Nexus 5
Carrier: Sprint

Thanks: 14,857
Thanked 12,627 Times in 7,286 Posts
Default

Well, did you do anythibg else to it? Root by itself cant really break your camera.

However, if you flashed Roms or kernels that could he a different story
Rxpert83 is offline  
Reply With Quote
The Following User Says Thank You to Rxpert83 For This Useful Post:
scotty85 (September 19th, 2013)
Old September 18th, 2013, 05:29 PM   #3 (permalink)
New Member
Thread Author (OP)
 
Join Date: Jul 2012
Posts: 2
 
Device(s):
Carrier: Not Provided

Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for reply, I did add a kernel. It's the kernel for the HTC logo button to actually function. Now do I have to reset to actually get it normal?
Hiruki is offline  
Reply With Quote
Old September 18th, 2013, 05:38 PM   #4 (permalink)
Dr. Feelgood
 
Rxpert83's Avatar
 
Join Date: Aug 2011
Location: MN
Gender: Male
Posts: 17,369
 
Device(s): Nexus 7, Nexus 5
Carrier: Sprint

Thanks: 14,857
Thanked 12,627 Times in 7,286 Posts
Default

I'd start by flashing the stock kernel again.

If it works, you know where the issue came from
Rxpert83 is offline  
Reply With Quote
The Following User Says Thank You to Rxpert83 For This Useful Post:
scotty85 (September 19th, 2013)
Old September 18th, 2013, 08:08 PM   #5 (permalink)
Senior Member
 
Join Date: Apr 2013
Location: FLA. USA
Posts: 626
 
Device(s): iPhone 4S,HTC One
Carrier: AT&T

Thanks: 66
Thanked 533 Times in 382 Posts
Default

Quote:
Originally Posted by Hiruki View Post
Thanks for reply, I did add a kernel. It's the kernel for the HTC logo button to actually function. Now do I have to reset to actually get it normal?
indeed flashing the wrong kernel can/will break the camera ... reflash the rom and leave the stock kernel
clsA is offline  
Reply With Quote
The Following User Says Thank You to clsA For This Useful Post:
scotty85 (September 19th, 2013)
Old September 19th, 2013, 10:38 AM   #6 (permalink)
Member
 
Join Date: May 2011
Posts: 265
 
Device(s):
Carrier: Not Provided

Thanks: 8
Thanked 76 Times in 59 Posts
Default

i did the same thing, used the bulletproof 2.1 for android 4.1.2 kernel, then tried bulletproof 4.4 for 4.2.2, and it lost the ability to read my internal SD and i still couldn't use the camera. ultimately i flashed my twrp backup that i made before i did ANYTHING (i used a temp recovery to do it, as advised in the guide) and it fixed both of the problems. so it wasn't a hardware issue, for me at least.
Ssith is offline  
Reply With Quote
The Following User Says Thank You to Ssith For This Useful Post:
scotty85 (September 19th, 2013)
Reply


Go Back   Android Forums > Android Phones > HTC One > (AT&T) One - All Things Root
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -5. The time now is 06:58 PM.
Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.