[02/Nov/2011] Android 2.3.7 Gingerbread (Swiftdroid) CM 7.1 For LG GT540 [New Method]


Last Updated:

  1. biep

    biep Member

    I've modded my LG with this rom and now I cannot set a ringtone. I assign one but when the phone rings he chooses a song out of my media map, and I cannot change it. Tried almost everything. Can anyone help me with this ?

    Advertisement
  2. biep

    biep Member

    Sorry for the double post, did something wrong here :p
    I reflashed my LG and now everything works, all my ringtones ringtones work now and my rom is fully functional !!! I love it. Was my first flash and it was a bit of a job for me, but the satisfaction is COMPLETE !!! Thanks MU4rik ! ;)
  3. pRoSpA

    pRoSpA Active Member

    i have tried 3 times to download the .exe file from fileserve and this has taken 30mins because it makes u wait! :( each time the download stops after like 2mb downloaded and says interupted. that was with google chrome. ive tried with internet explorer and got similar results... could you or anyone else upload the file to a different hosting site please? :) ive used this before its a great way of installing the ROM :)

    EDIT: Oooooh! Just tried again and now fileserve is saying 'file not found'
  4. Androids:3

    Androids:3 Member

    How do u install the android_usb mentioned in Step 3 for Windows XP 64 but ? I cant right click it and click install o_O Help plz. Thx
  5. jonroger

    jonroger New Member

    Thanks for the nice program. Here are some of the issues I ran into:

    1) make sure that LG's USB drivers are installed
    2) disable LG's virtual modem in Windows
    3) make sure you have a reasonable size for your Windows swap/virtual memory file
    4) install android SDK and android USB drivers
    5) turn on USB debugging and turn off "mass storage"
    6) I used a Baltic Black 2.1 rom to get fastboot capability
    7) The camera button is the lower one on the right side
    8) The icon to switch to english has an "A".
    9) Find and install Google's apps when done.
  6. zaqrider

    zaqrider New Member

    installed, had problems with driver while i was already in fastboot mode (brick thoughts(:)), but I manually updated driver from SDK google folder.
    Everything works like charm BUT widgets does'nt appear on widget list(edit: by this i mean new widgets, original widgets are fine) :S

    Any thoughts?
  7. Delsus

    Delsus Well-Known Member

    If the apps for those wigets are on the SD card they will not show, move the app to the phone and it should work
  8. poolegooner

    poolegooner Active Member

    help i've upgraded from 2.3.4 to 2.3.5 and nothing seems to work anymore my phone crashes every time i start an app it sends me to the cyanogenmod boot screen and then restarts, what's happened!!! anyone got any ideas on how to rectify this or can i go back to 2.3.4 where it worked fine? where can i get the 2.3.4.exe? thanks in advance.


    (UPDATE) i've gone back to 2.3.4 for now and it works fine again not sure how to install thru recovery will try that thread you recommend Phantogenic at a later date when i get a new LCD screen as that's now f**ked!
  9. Phantogenic

    Phantogenic Well-Known Member

    Install via recovery - exe's can have major issues as they are a program rather than an image. You can find the link to the latest update and how to install via recovery in the other 2.3.4 thread.
  10. biep

    biep Member

    Came back from holiday and saw there was an update....joehoe !!!
    Installed it immediatly and it is working fine without loosing any data !
    This is so GREAT !!!:)
    I even bought an LG for 60 $ for my son from someone who didn't like it :confused:, phone was brandnew, just for having the pleasure of flashing it with the same rom as mine, and now we can play together :rolleyes:
  11. EggNogg05

    EggNogg05 New Member

    This is my first update from official android 2.1 and i'm hooked on my LG GT540 again! But...

    1) Need for speed SHIFT and Raging Thunder 2 don't work on my gt540 anymore :(
    with need for speed it only gets to the EA logo then returns me to the previous screen I was on. With raging thunder it says 'authorizing license' then goes to the 'downloading game data to your SD card. one time only download' message. The download bar comes on but when it completes, it returns me to my previous screen again and if I launch the app again the whole process repeats! Plz help!

    2) Is there any way of getting official android 2.2 and 2.3 apps after mod has been successfully installed?

    P.S. I'm a newbie and this is my first ever message so tell me if i've done sumthin wrong :)
    Any answers much appreciated.
  12. poolegooner

    poolegooner Active Member

    I've just tried to install 2.3.5 thru recovery and clockworkmod just said "installation aborted" anyone got any ideas? i downloaded the recovery.zip file from 2.3.4 thread and put it in the root dir of the sd card, i also wiped the dalvik cache before installing, cheers.
  13. Phantogenic

    Phantogenic Well-Known Member

    You'll need to extract the first zip file and use the next zip file inside that to do the recovery with :)
    poolegooner likes this.
  14. poolegooner

    poolegooner Active Member

    Thanks for your help Phantogenic i am now running 2.3.5 i think! as the Android Version still says 2.3.4! but the Mod Version says v2.0 preRC2 (Based on CyanogenMod-7.1.0-RC1) that was different before! everything seems to be running ok no fc's yet!!! cheers!:)
  15. Phantogenic

    Phantogenic Well-Known Member

    If you're running 2.3.5 it will say the same as my signature. Otherwise you're not running 2.3.5

    You may need to reflash again.
  16. prwnd

    prwnd New Member

    Hi! In my country somebody also made ​​a ROM for GT540 based on 2.3.2 and he creates a d2s (data to system, these partitions are reversed) release. With this method there will be ~200 MB free internal storage after install instead of ~80 or whatever.


    My question is: how much internal storage will I have after CM 7.1 v2 RC3 installation and will there be a data to system release? (If there is nothing something like that, maybe I create.)
    With moving apps to sd I have 30 MB free space, so I need this version.
  17. Phantogenic

    Phantogenic Well-Known Member


    If you follow the original thread 2.3.4 there is a how to for creating a d2s, which will stay with each update you make.
    In regards to your question about how much space is left I'm unsure as I already had d2s before updating to 2.3.5
  18. dkcheong1127

    dkcheong1127 New Member

    when i installing 2.3.5 to my gt540, the error message prompt that "decompression error", system.img cannot be extract...cagsabit,can u upload only the system.img ? so i can ignore it and extract others?
  19. Phantogenic

    Phantogenic Well-Known Member

    You'll need to find a new system.img file or try flashing the rom via fastboot or recovery as he hasn't been on in a long time.
  20. dkcheong1127

    dkcheong1127 New Member

    thanks for your help, but the 2.3.5 system.img seems difficult to find it...if u spot that can u give me the links ?
  21. Phantogenic

    Phantogenic Well-Known Member

    Your best bet is to install via recovery.
  22. Slatuh

    Slatuh Member

    I upgraded from 2.3.4 to 2.3.5 using your upgrade method, and all was fine.

    A few days later though, it appears my phone doesn't turn on past the 'blue circle CyanogenMod' splash page and just sticks on that screen, the only way I've managed to get it to turn on is to plug it into the computer with the USB lead, much like a tethered jailbreak on an apple device. However this method is not convenient as I'm currently away from home without a lead - yup, no phone while I'm away.

    Any ideas?
  23. Phantogenic

    Phantogenic Well-Known Member

    As per my previous post...

    you may need to install via recovery. If you can access the sd card copy the extracted zip file over and flash through clockwork mod. If your bootlooping you have access to recovery.
  24. gregor_y

    gregor_y Member

    Hey i just wanted to thank you everything works fine and faster than 2.1 from LG.This was my first unofficial update done it with no problems.

    Only thing that worried me a bit was that you did write that some parts would be done in 15 minutes in my case it was betwean 5-7 minuts still phone works fine with 2.3.5 so i quess it's done right maybe my notebook is too fast :)

    Only thing left is im doing battery callibration and i got stuck at 99% 4195mV is that correct? it never charged too 100% always 99%... If someone would be kind and give me answear my phone is still pluged it into charger thanks :)

    Also is 700Mhz safe for cpu i did read people overclock up to 800-825Mhz with no problem still i don't want to over do it.And i set memory compresion to 26%.

    And again thanks works like a charm.

    Edit: Ok i did calibrate my battery at those settings 99% 4195mV.

    Also on 2.1 i could listen to mp3 for about 10 hours and it took 40-50% of battery is that correct?
  25. Phantogenic

    Phantogenic Well-Known Member

    It won't reach 100%

    And yes, anything up to 825Mhz is fine.

    As for the mp3 - I'm not sure.

Share This Page