1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

[1st Gen] Cannot move .apk files to system/app

Last Updated:

  1. ruffyreborn

    ruffyreborn New Member

    The device is rooted, of course. I was following rooting and market installation instructions word-for-word, and this is the first bump Ive hit. In the app folder, I do mount it as read-write. After that, I attempt to copy vending.apk, and also com.amarket.apk as well, unsuccessfully. Ive even tried moving a random empty folder into the app folder, to no avail.

    Ive even manually switched the permissions of the app folder and checked every option, it still did not work.

    I have noticed, however, that after I enable RW in file expert, and then check a different explorer application, the app folder is switched back to read only.

    Im stuck and cant figure out what to do next. Im trying to access the android market.

  2. RawRmon

    RawRmon Active Member

    did you install the google frameswork apk???
  3. ruffyreborn

    ruffyreborn New Member

    Yeah, i did install it
  4. ruffyreborn

    ruffyreborn New Member

    The problem has been solved i believe... for some reason, the permissions worked this time. I really have no idea what i did differently.
  5. RawRmon

    RawRmon Active Member

    awesome glad it worked, that actually happened to me too when I tried rooting mine.
  6. Superfrick

    Superfrick New Member

    Every time I try to move vending.apk to system/app it fails.

    I'm using File Expert and ES File Explorer. neither works.
  7. parkerskouson

    parkerskouson Well-Known Member

    You need root explorer. you need to chnge ro to rw or whatever way it is. just change it from whtever it is or else it wont work...
  8. flywatt

    flywatt Well-Known Member

    Where is this root explorer app? I can't find it anywhere, not on the market, and not online.

    I'm having the same issue. I rooted my phone, installed google framework, and can't move the file to system/app. I've tried using other file managers and changing to read/write, still nothing. I've had success with several other android devices, this just isn't making any sense to me. My kindle fire is about to become kindle firewood.
  9. 2012

    2012 Well-Known Member

  10. ovrrdrive

    ovrrdrive Well-Known Member

    Root Explorer really is the best app for this. You may need to download it on your phone and transfer the .apk to your kf to get it. It's an app I didn't mind paying for at all because it's the only one that does everything. It's really a must have.
  11. louiedee279

    louiedee279 New Member

    r u able to buy apps from the android market?
    where did u get .comandroidmarket.apk
    did u replace the vendor.apk file?

    i can doenload free files from the android market on my kindlegire but i cant buy apps! i get a error message forces closure!
  12. jspidey

    jspidey Member

    I ran into the same thing when trying to move an apk to the /system/app folder. I got it to work by enabling the option to "Mount File System" in the the Settings and it allowed me to move it. I disabled that setting afterward for safety's sake.

Share This Page