[1st Gen] Help, stuck in "Kindle Fire" screen

Last Updated:

  1. KX4SAM

    KX4SAM Well-Known Member

    I had been rooted, with TWRP recovery, and CM7, and Gapps.

    Wanted to go back to stock. Brought up Kindle fire utility, downloaded stock update, transferred to fire via usb, used TWRP to flash stock update.

    Vola, back to stock kindle fire. Re-rooted with Kindle fire utility, and then my mistake, I flashed the CM7 Gapps into stock kindle.

    Got stuck on "touch me android screen". Went back into recover, wiped all, deleted all, and rebooted. Now i'm stuck in the opening Kindle fire screen.

    I still have TWRP recover working, but ADB won't connect either in start up screen or recovery.

  2. Does your computer recognize that its connected when you turn it on? If it is showing the usual exclamation point next to the driver then you'll need to take the steps again to re-install the Google USB Driver. I know its a pain, but it works. Then after that, make sure to open KFU just to make sure after reinstalling that the status shows that its rooted/adb rooted. After that open Command Prompt, cd to your adb spot. It should be somewhere like C:\Program Files (x86)\Android\android-sdk\platform-tools. That's if your using Windows 7/Vista. If your running something like Ubuntu or Linux then I'm sure someone here is too and would post the file directory to it. After you open and get to the correct location in the file then copy the file line and go back into Command Prompt and do this:
    1. cd C:\Program Files (x86)\Android\android-sdk\platform-tools
    2.adb devices (just to make sure that your Kindle is really connected after redoing the drivers and that KFU wasn't screwing with you lol). If it shows something like 15DC000600000001 then your good to go on to the next step.
    3. Type in adb shell
    4. Once the adb shell gets connected then type in idme bootmode 4000.
    5. Then type reboot.
    After each of the command prompt lines that I have posted make sure that you push enter after each one. If you get stuck with an error somewhere in that process then comeback here and list what happened. If it worked then your welcome ahead of time :)
  3. KX4SAM

    KX4SAM Well-Known Member

    ADB devices shows my kindle

    running the shell command gives:

    - exec 'system/bin/sh' failed. No such file or directory (2)
  4. KX4SAM

    KX4SAM Well-Known Member

    After looking again and again, there must be no system files there. Used TWRP to mount via USB, moved update.zip onto fire, and flashed using TWRP.

    I now have stock rooted system, and CM7 backed up.
  5. So I see that you were able to flash CM7 over using TWRP? Now, the main question is, are you getting any google process force closure messages? I've been hearing that a lot of people have. So if you are then here is a better version of the CM7 that runs pretty smoothly in my opinion. You don't need to run GO Launcher with this one if I might add :)

    Basically is what that command is saying from, my past experiences is that it couldn't find the correct installation folder of your adb folder. It detects that there are devices that have the USB drive, but I don't think that you had cd to the right directory of where the actual file was. That's what my experience has been with that issue in the past when I was doing it on phones way before tablets came out. LOL
  6. awilliams4505

    awilliams4505 New Member

    NEED HELP!!! Have a new kindle fire, tried to root and was successful then installed TWRP. Went to restore to factory defaults in Kindle launcher and somehow ERASED EVERYTHING!...now when i boot up my kindle it goes to the TWRP screen and thats it...everything i try to do it either says cannot find device or something about "exec '/system/bin/sh' failed: No such file or directory"....tried using kindleunbirckutility and now it just loads to the kindle fire screen. i can still get to TWRP by pressing power button til it turns orange....Really just want to restore it back to factory default...is this even possible?....also forgot to back up in TWRP before doing all this....tried to find someone online that might could send me backup file they have, wasnt sure it that would work either?....thanks for anykind of help from you guys
  7. enhbat

    enhbat New Member

    I'm new to rooting and my Kindle Fire is stuck on same condition too. I can mount with TWRP and can see the folder TWRP on my computer. But what was your next step and where can I get that update.zip?
  8. Ok, to start things off, you can't grab a stock backup file from anyone as it is their own personal device's programming and coding and info. So, if you do try it on your's you're more than like to ruin your kindle for good. The best thing to do is go into TWRP wipe everything and then do a System Restore. It'll put you back to factory settings, then go in and download the Google apps that I'm in the process as we speak to make it easy access for everyone knew to the Kindle Fire rooting scene and download them with the step-by-step instructions that I'll be posting in along with the link to download them.
  9. gimoss

    gimoss New Member

    Thank you to have accepted me like member.
    I write from Italy
    My Kindle Fire it's stopped in the beginning on the logo after I istalling CM7.
    Now it's dead when I swith on it stopped on the logo
    and by Kindle_Fire_Utility_v0.9.3 and Kindle_Unbrick_UtilityV1.1
    the answer on every command is
    exec 'system/bin/sh' failed no such file or directory (2)
    The problem is thant the kindle cannot go to recovery and every command
    in adb have the same answer
    exec 'system/bin/sh' failed no such file or directory (2)
    Can you help me?
  10. sanjeeva7

    sanjeeva7 Well-Known Member

    My KF is bricked.

    I was rooted using the KFU 0.9.6 and installed TWRP, Clockwork, Superuser, FireFireFire.

    I was in recovery tried to run an ICS.zip update. I did a backup, wipe cache, installed the zip update, wiped cache, rebooted, now the KF is stuck in a boot loop. ADB does not see the device neither does device manager.

    I think I messed up applying the ICS update. I did not completely wipe the device, wipe the cache, then apply the ICS update.

    Kindle (white letters) fire (blue) and at the bottom says "booting." I can shut off and turn it back on but it goes back to the hung screen. It does let me select between Normal Boot, Recovery, and Reset Boot Mode. None of the options do anything.
  11. mazarate

    mazarate Member

    i'm having this same problem. any luck?
  12. Xtremedays

    Xtremedays Well-Known Member

    When your pc is on and you turn on your KF, does your pc beep when the KF starts up? If so, try and open the KFU and go to the set bootmode option. With the KF off, select recovery mode in the KFU. It should say waiting for device. power on your KF and see if it will boot to recovery.
    Drogyn and sanjeeva7 like this.
  13. sanjeeva7

    sanjeeva7 Well-Known Member

    Yes it makes a noise like it's connected to my pc. I did as you instructed in the KFU, and it reboots the KF, but once again stuck in the same spot.

    I've ordered a fastboot cable from ebay (I don't trust myself to sodder it) but the only seller is in Hong Kong so it can take up to a month to ship.
  14. mazarate

    mazarate Member

    requesting your feedback with my case. My KF is stuck in kindle fire logo. I followed many instructions around the web. I'm getting no where. In your latest post to a previous member, I followed your suggestion in opening kfu and do a recovery mode. My pc recognizes the kindle however in the command prompts i get waiting for device everytime. I'm also getting exec 'system/bin/sh' failed no such file or directory (2).
    Please Help.
  15. Xtremedays

    Xtremedays Well-Known Member

    Did this happen after the 6.3.1 update unrooted you or are you trying to root for the first time? I have 2 KF that are rooted. When the 6.3.1 update came out, one got stuck at the boot screen and the other would still work. I ended up unrooting the one and going back to stock using this guide. I then redownloaded KFU and reinstalled the drivers and it worked perfectly. This may have been the long way around but it worked for me. I was also using KFU 0.9.5 so you might give that one a shot as it should still be available in the KFU thread on XDA. I also installed a CM9 rom on both devices so that I don't have to worry about OTAs anymore.
    mazarate likes this.
  16. Xtremedays

    Xtremedays Well-Known Member

    When your KF is on and you have it plugged in, does the KFU see your KF and tell you its online? if so, does it tell you the bootmode it is in? Have you tried a different USB port on the pc? Did you try and uninstall the drivers and reinstall them?
  17. mazarate

    mazarate Member

    thx for your reply.
    This happened after the update unrooted me. I followed your suggestion and downloaded KFU 0.9.5 and in uninstalled and reinstalled the drivers. My computer recognizes the KF. Whenever I plug the KF to my usb (tried different slots) the computer beeps and recognizes the KF. I used KFU 0.9.5 and the ADB status: ONLINE.... However the boot status is UNKNOWN. I've made several attempts in bootmode activating all modes and I recieve THE SYSTEM CANNOT FIND THE DRIVE SPECIFIED 2460 KB/s <510876 BYTES IN 0.202S> exec 'system/bin/sh' failed no such file or directory (2).
    The kindle has been told to reboot...
    So, KFU 0.9.5 reboots the KF but thats the extent of where I'm at. I'm still stuck at kindle fire logo.
    thx again
  18. Xtremedays

    Xtremedays Well-Known Member

    I would follow this guide and get it back to stock os and recovery. Then use KFU to reroot it.

    [Guide] How to restore to pure stock (no root, FFF, etc.) with TWRP - xda-developers

    That is what I had to do with one of mine. There may be another way around it but this worked for me.

    Edit: Nevermind.....you need to get into recovery for that. Not sure where to go from here. Have you tried to reinstall the recovery and FFF bootloader from KFU?
    mazarate likes this.
  19. mazarate

    mazarate Member

    I tried reinstalling recovery however i get:

    exec 'system/bin/sh' failed no such file or directory (2).
    kindle has been told to reboot

    < waiting for device >

    Then it just stays at waiting for device.....
  20. Xtremedays

    Xtremedays Well-Known Member

    mazarate likes this.
  21. mazarate

    mazarate Member

    I installed kindle fire unbrick utilitity 1.1. I executed the options and Unfortunately, I am still stuck at kindle fire logo. It replied exec 'system/bin/sh' failed no such file or directory (2).
    In addition to this I attempted a program using ubunto. I followed the command scripts under ubunto and I get waiting for OMAP44xx device..
  22. pugsley42

    pugsley42 New Member

    I'm pretty much stuck in the same boat. I had some issues and was able to get it back to a stock Amazon image. Then I tried the Kindle Fire Utility, and just attempting to do the option to grant root, it rebooted and now I'm stuck at the Kindle Fire logo. It doesn't have TWRP and no way that I know of to install it. My PC will only recognize it as an unknown USB device. I've tried every driver trick I know of, and got limited success in adding a line in the winusb ini file to recognize "usb\unknown" as a Kindle Fire, but it won't fully initialize the driver. I dual boot with Win7 and Ubuntu 12.04, so tried the FireKit deal with the shorting trick, and it didn't make a difference. It would be stuck at the OMAP44xx or just waiting for device. I can't get ADB to see it under Win7 anymore either.
  23. k28king1

    k28king1 Well-Known Member

    I'm gonna try that on my kf. I screwed mine up attempting to install twrp. But the antivirus software on the PC I was using messed it up. So I got a kf stuck in fast boot mode.
  24. sanjeeva7

    sanjeeva7 Well-Known Member

    I needed a factory cable to unbrick mine. Bought one off ebay and luckily it came in about 10 days from overseas.

Share This Page