[1st Gen] Very Unusual Root Problem with Kindle Fire

Last Updated:

  1. mikeynooch

    mikeynooch New Member

    This is my second time rooting my Gen1 Kindle Fire. (The first time was very successful but stupid me, I went back to factory settings for no good reason).

    From KF's updated software (6.3.2) I used Kindle Fire Utility 0.9.9, to install TWRP 2.6 and other google apps. I loaded TWRP and cleared cache etc. I then installed the new CM 10.1 SGT 7 rom. When i rebooted the KF, i didnt get the option to boot into twrp. What happens now is, it shows the orange Kindle Fire boot screen, and then continues to the CM10.1 boot screen. I may have installed CM10 over the KF software somehow. Now, my PC recognizes it as a Kindle Fire when I plug in the USB but there's an error in the device manager. Basically, KFU doesn't recognize it's a Kindle anymore. When I try to reboot it in recovery mode, it just does a regular reboot. Nothing about my KF looks like there's twrp installed in the background. I can't access it no matter what.

    I tried sideloading Google Play and installing the TWRP Manager app but that doesn't do anything at all. I feel like my KF is going to be stuck like this forever. Any way to hard reset everything without TWRP? I have the proper "update.zip" file on the sdcard but I can't access any way to Wipe it and Install it.

    Just so you know, the kindle isn't bricked it just seems like it's permanently stuck the way it is and my PC won't recognize its harddrive via USB.

    (When I plug my KF into my PC, the Kindle Fire drivers get an error so i change it into an Android ADB Composite device. It still won't recognize the device properly. When I open up the console and try "adb devices" nothing shows as connected. I've installed the SDK and changed the files but it's the same thing. All that to say, the KFU no longer recognizes when the KF is plugged in.)

    Any suggestions?

  2. SwoRNLeaDejZ

    SwoRNLeaDejZ Well-Known Member Contributor

    Somehow it seems like you managed to root and all that, but somehow the FFF bootloader didn't get flashed to your Kindle. Without that bootloader it is impossible to get into recovery. Have you tried using the Kindle Unbrick Utility? If you can get back to stock you could at least try again from the beginning.. There may be a way to push the bootloader to the phone through adb but if your computer doesn't recognize it as connected then that probably won't be possible.. There is something you can do in the device manager to fix it not showing up. I'll look and see if I can find it and let you know.
  3. mikeynooch

    mikeynooch New Member

    Thanks for getting back to me. I have tried the unbrick utility but it just sits there waiting for me to connect a device even though the Kindle is connected. I tried some device manager stuff but it still doesn't recognize the hardware aside from saying "Kindle Fire is plugged in". It doesn't recognize the harddrive or anything though.

Share This Page