2.1 upgrade phone won't dial 1-888 numbersSupport


  1. firefight16

    firefight16 Active Member

    Yes thats right thought it was weird but I have tried 4-5 differant phone numbers and the new 2.1 update on my Telus Milestone on the Bell network will not dial 1-888 numbers, it has a buzz and hangs up pretty quick, won't work from a contact wont work manually entered! No problem with 1-800 and I am not trying any 1-900 we will leave those alone. Wifes work uses a 1-888 for out of area toll free and I have to use on landline, but with cell the regular number is not long distance, so I can still get her through cell. Did a google search can not find any mention perhaps someone else can try a 1-888 number just google for a number lots of weather related ones.

    Advertisement
    :
  2. Szadzik

    Szadzik Well-Known Member

    Not a dvice issue but caused by network.
  3. firefight16

    firefight16 Active Member

    Should i call bell weird how it just quit?


  4. firefight16

    firefight16 Active Member

    Well turns out to be a Bell issue only affecting BC, judging by the 2 complaints.
Loading...

Share This Page