2.2 and AppsSupport


Last Updated:

  1. Nodzarf

    Nodzarf Well-Known Member This Topic's Starter

    Joined:
    Apr 16, 2010
    Messages:
    91
    Likes Received:
    7
    Just thinking ahead for when 2.2 is released to the incredible, will all the apps i have work? or will they have to be upgraded to 2.2 also? My experience from playing online games with addons that almost everytime there was a patch to the game, most of the addons did not work until it was upgraded by the developer.
     

    Advertisement
  2. samuelk

    samuelk Member

    Joined:
    May 14, 2010
    Messages:
    13
    Likes Received:
    7
    The only people who know the answer to that question are the people who built the individual apps.

    Whether or not an app will work with 2.2 depends on each individual app. Some may work without patching, some may not.
     
  3. waynester

    waynester Well-Known Member

    Joined:
    Oct 11, 2008
    Messages:
    677
    Likes Received:
    65
    I have noticed quite a few of my apps have been recently updated to support 2.2
     
  4. jon2datymuls

    jon2datymuls Member

    Joined:
    Mar 9, 2010
    Messages:
    20
    Likes Received:
    1
    I also read somewhere that if the person who made the app decided to lock the app down it will not be upgraded unless they want to go back in and change it. Then again where i read it is full of idiots so who knows. :confused:
     
  5. TokedUp

    TokedUp Well-Known Member

    Joined:
    May 1, 2010
    Messages:
    377
    Likes Received:
    38
    In the last week a bunch of my apps updated and in the summary of what was upgraded it usually stated support for 2.2 i Froyo is closer than we think
     
  6. rushmore

    rushmore Well-Known Member

    Joined:
    Nov 13, 2008
    Messages:
    8,267
    Likes Received:
    1,355
    Based on dev input, all apps will need to be revised to install or import to a card. Also, it is MUCH easier to incorporate the feature when the app is being developed than it is to modify after the fact. The level of this factor depends of course on the complexity of the app.
     
  7. mrjinglesusa

    mrjinglesusa Well-Known Member

    Joined:
    May 3, 2010
    Messages:
    381
    Likes Received:
    119
    Remember, most apps are designed for all Android phones. Developers don't make apps specifically for the Incredible. Since some Android phones are already getting 2.2, developers are updating their apps to support 2.2. By the time we get 2.2 on our Incredibles, I would venture to guess that 95% of the apps we use will have already been updated to support 2.2.

    Don't worry about 2.2 and apps - we'll be fine.
     
  8. Needz_Android

    Needz_Android Well-Known Member

    Joined:
    Apr 1, 2010
    Messages:
    613
    Likes Received:
    98
    wtf does froyo stand for? jw...
     
  9. najaboy

    najaboy Well-Known Member

    Joined:
    May 3, 2010
    Messages:
    390
    Likes Received:
    68
  10. rushmore

    rushmore Well-Known Member

    Joined:
    Nov 13, 2008
    Messages:
    8,267
    Likes Received:
    1,355
    That would be cool, but i have over two hundred apps and only two so far have updated for 2.2 function. I do agree that sometime this year, things will smooth out- unless the dev does not care to update for microsd installs or importing.
     
  11. najaboy

    najaboy Well-Known Member

    Joined:
    May 3, 2010
    Messages:
    390
    Likes Received:
    68
    Of course, it's up to the individual dev on whether or not they choose to revise their apps to support installation on the sd card. Depending on the app, they either may not want it to install on the card or may feel that it's too much trouble to implement and just leave it as is.
     

Share This Page

Loading...