1. Good things coming in just a couple hours, stay tuned!
    Dismiss Notice

2.2 Battery Manager Force CloseSupport


Last Updated:

  1. lexluthor

    lexluthor Well-Known Member

    I'm getting an error in the battery manager in 2.2

    I get that new battery icon in the battery manager. When I click on it, I get an error saying "process com.android.settings has stopped unexpectedly."

    Anyone else have this issue (I know some people said it does work) or have any ideas what I might be able to look at to fix this?

    Advertisement
  2. bosox2k1

    bosox2k1 Well-Known Member

    I have same exact issue..
  3. lexluthor

    lexluthor Well-Known Member

    Ok, sorry, but at least someone's in the same boat with me :)

    Who else?
  4. just4747

    just4747 Well-Known Member

  5. just4747

    just4747 Well-Known Member

    Doing a factory restore now for all this...
  6. lexluthor

    lexluthor Well-Known Member

    Not sure what I did, but it's working now.

    Here's some of the steps I did.

    I used titanium to delete data for battery manager. I think froze and defrosted battery manager. I rebooted.

    I thought after the reboot it still didn't work.

    When I plugged in, it said something about night mode being on (I had set it to performance) right after I got 2.2.

    I then when back in and it was working. Switched to performance and still working. Rebooting now to see if it's still working.

    Hopefully, someone can figure out exactly which step fixed this.

    EDIT:
    Broken again after reboot

    But, then I plugged in and then unplugged and it works.

    I bet this is a bug everyone has.

    So I guess after a reboot, just plug in quickly and you won't ever have this issue?!
  7. chrlswltrs

    chrlswltrs Well-Known Member

    Mine hasn't had any problems at all, I really like it now that it is actually useful as opposed to the crap they had on 2.1
  8. just4747

    just4747 Well-Known Member

    Just finished a factory restore,

    so far they all work now after the restore (minus the Tesla app- maybe a compatibility issue with the app since other ppl have this issue too besides us), let's see if they still work after I do a Titanium restore...
  9. travishamockery

    travishamockery Well-Known Member

    i had this happen earlier too, i just did a reboot and its been fine since. I didn't have to plug in or anything.
  10. caveritt

    caveritt Well-Known Member

    Is it still working? Mine works for about 10 minutes after a reboot then starts force closing. Very frustrating and really don't want to do a factory reset. Besides are we 100% sure that a factory reset fixes this problem?
  11. just4747

    just4747 Well-Known Member

    Just an FYI, after it was working after my factory restore, it eventually started doing it again.

    I'd say it happens about 50% of the times I try to go into it. So how can we fix this? It's hard to believe that not everyone will have this issue at some point since we are all using the same rom.
  12. FoxtrotUniform

    FoxtrotUniform Well-Known Member

    As far as I'm concerned it's random when it wants to work or not :p I can't find any set instance to make it crash or not. It is pretty friggin sweet when it wants to work though. Now I can get rid of SystemPanel Lite since it seems to have issues ending some tasks now.
  13. caveritt

    caveritt Well-Known Member

    This is really frustrating the heck out of me as this is the only problem I am having with 2.2. Everything else is perfect, but this one little bug is like the thorn in my side!
  14. caveritt

    caveritt Well-Known Member

    Does everyone that has this problem confirm or deny if they have the battery left widget? Just saw over at MyDroidLife that someone is saying they fixed this problem by removing that widget. I am testing now.

    <EDIT>
    Close to an hour later and is still no problems with the BM. Really starting to think it might have been the battery left widget.

    <EDIT>
    Still happening :(
  15. FoxtrotUniform

    FoxtrotUniform Well-Known Member

    Ah bummer. I do use that widget and was about to uninstall it :\
  16. DrWurm

    DrWurm Well-Known Member

    Mine only seems to work when plugged in.
  17. Travisimo

    Travisimo Well-Known Member

    It's the same with me... sometimes it'll work, sometimes it'll FC. At this point, I cannot detect a pattern. Obviously, there has to be something tripping it up under certain conditions. But before we can try to fix it, we need to know what those conditions are!
  18. humungus

    humungus Well-Known Member

    I had this issue on my first 2.2 install. I've since sbf'd, rerooted using birdman's guide, and update.zip'd. I haven't had this issue since reinstalling. I've had 1 or 2 instances of LauncherPro hanging at boot, but that hasn't been an issue lately.
  19. acmonster

    acmonster Well-Known Member

    Bump to the top. I updated to 2.2 the morning it was released. Other than that i keep my phone pretty stock. I have root and all original programs. I deleted Battery Left Widget but still have this problem. Mine is almost 80% force close and 20% working.

    Anyone fix this issue yet?
  20. Exiled

    Exiled Well-Known Member

    I'm loving froyo but this is pretty much the only issue I have. It was perfectly fine yesterday, but its come back this morning. I think it may have something to do with the level of battery-- I only see it when my battery is full, like 90% and up. It could be that the program force closes when theres nothing to measure or its uncertain of the percentages of what is affecting the battery.
  21. rolltide1

    rolltide1 New Member

    I'm rooted on the DX. Updated to 2.2. Getting a FC error when checking battery usage. It's pretty hit or miss on mine. I've noticed that if I connect either via USB at Charge Only or AC adapter then disconnect I can open the usage status if I do so immediatlely. If I wait a short period of time and try it no longer works. But that's not the case every time. It's very sporadic.

    Any ideas/suggestions?

    Everything else works fine by the way. One thing I have not tried is a full charge and rundown of the battery since I've upgraded to 2.2. Not sure if that will help but I'm out of ideas over here. :confused:
  22. farrellcollie

    farrellcollie Well-Known Member

    I have the same problem. I went back and reflashed everything, wiped agan and it was working fine for a couple of days, but now I get a fc.
  23. gehx

    gehx Member

    I'm also experiencing this...sorry, i don't have any useful info on how to resolve the problem, just thought i'd chime in...
  24. skbest11

    skbest11 New Member

    i have this issue too, is there any solution for this?
  25. colchiro

    colchiro Well-Known Member

Share This Page