2.2 Froyo can't hear callsSupport


Last Updated:

  1. someotherguy

    someotherguy Well-Known Member This Topic's Starter

    Joined:
    Apr 15, 2010
    Messages:
    154
    Likes Received:
    22
    So I took my stock 2.1 Droid x and rooted it using the long method by birdman.

    Moved SU and did the upgrade to froyo.

    Now I'm on froyo with root

    Everything is fine. Besides I can't hear people when they call and they can't hear me. Like my Mic and my speaker is disabled?

    Didn't factory reset because I didn't want to loss all my apps and have to re-do everything. Tried reboot / battery pull.

    I read something about resetting cache. Does that screw my apps up like a hard reset?

    Any ideas?
     

    Advertisement
  2. racinwarrior

    racinwarrior Well-Known Member

    Joined:
    Aug 25, 2010
    Messages:
    50
    Likes Received:
    3
    same exact thing happened to me. I tried a re flash back to 2.1, i tried to reload 2.2. cleared everything, battery pulls, factory resets........nothing worked. I had to return it to walmart for another yesterday. sorry dude but you may be SOL
     
  3. someotherguy

    someotherguy Well-Known Member This Topic's Starter

    Joined:
    Apr 15, 2010
    Messages:
    154
    Likes Received:
    22
    Had to return it?

    How the heck could a upgrade make the hardware not function. Did you do the 2.1 sbf with RSD?
     
  4. racinwarrior

    racinwarrior Well-Known Member

    Joined:
    Aug 25, 2010
    Messages:
    50
    Likes Received:
    3

    yep i had to return it for another X.

    No idea. thats what i was wondering as well. weird thing is the speaker would still play all other sounds. just not on calls.

    i did do the sbf flash with RSD lite back to 2.1

    I decided not to load the 2.2 leak on my new replacement X, just to wait for the official OTA
     
  5. LaZeR

    LaZeR Well-Known Member

    Joined:
    Aug 10, 2010
    Messages:
    428
    Likes Received:
    65
    I had this occur once when running Froyo 2.2 . A reboot resolved it. Nevertheless, it bothered me enough to resort to RSD and the .sbf back to 2.1. Note: I wasn't even rooted when on 2.2. Now I'm rooted on 2.1 with the easy 'Universal Easy Root' or whatever it's called and haven't had issue since. I'll be waiting on the sidelines until the official Froyo at this point.
     
  6. farrellcollie

    farrellcollie Well-Known Member

    Joined:
    Jun 6, 2010
    Messages:
    80
    Likes Received:
    4
    The call with no sound happened to me when I first flashed over to 2.2. I had been rooted, failed to see the what to do if rooted directions and so lost root. It cleared up within a few hours for some reason. I had some other small but irritating issues so I flashed back to 2.1 and re rooted and am good to wait.
     
  7. someotherguy

    someotherguy Well-Known Member This Topic's Starter

    Joined:
    Apr 15, 2010
    Messages:
    154
    Likes Received:
    22
    Still nothing. Tried multiple battery pulls. Really not wanting to go back to 2.1 and racinwarrior's story of it still being broke after the .sbf is making me sick to my stomach.

    I tried playing music while in call because I read that kicked it in for someone. Nothing.
     
  8. sodaboy581

    sodaboy581 Well-Known Member

    Joined:
    May 8, 2010
    Messages:
    105
    Likes Received:
    18
    Happened to me too. Rebooting also solved it for me. Good thing it's only happened once so far... if it happens again, I'll definitely be flashing back to 2.1
     
  9. racinwarrior

    racinwarrior Well-Known Member

    Joined:
    Aug 25, 2010
    Messages:
    50
    Likes Received:
    3
    yeah it was a hassle to switch to a new X. I had to drive 50 miles to find one at a walmart so i could exchange. I had to have the manager at the store i purchased it from (which did not have any) call the manager at the store that had them and explain the situation and give me the ok to exchange there.

    I still cant understand how software can cause the speakers to stop working.

    I also have my phone connected through bluetooth to my truck's sync system. I tried to make a call using that and i still didnt have any sound. I have a feeling that the 2.2 leak corrupted my phone apk files some how.

    anyway i tried for a day and a half to get it to work by reloading and reflashing before I gave up and just exchanged it for a new one, and like i said i will not be installing the 2.2 leak again
     
  10. Romoko

    Romoko Active Member

    Joined:
    Jun 7, 2010
    Messages:
    41
    Likes Received:
    4
    I had this problem with 2.1 actually.

    *228 solved it for me. You just need to update your phone. :)
     
  11. someotherguy

    someotherguy Well-Known Member This Topic's Starter

    Joined:
    Apr 15, 2010
    Messages:
    154
    Likes Received:
    22
    Hallelujah!

    Powered off.
    Pulled battery for 5 minutes.

    All is well again!@
     
  12. antnyh

    antnyh Well-Known Member

    Joined:
    Aug 6, 2010
    Messages:
    198
    Likes Received:
    26
    Glad to see you got it fixed. I am updated and rooted. Mine did the same thing the other day. I noticed that it had done it after I used the slide button to silence my ringer. I had to pull the battery to get it to work again.
     
  13. racinwarrior

    racinwarrior Well-Known Member

    Joined:
    Aug 25, 2010
    Messages:
    50
    Likes Received:
    3
    Tried that. Twice.
     
  14. someotherguy

    someotherguy Well-Known Member This Topic's Starter

    Joined:
    Apr 15, 2010
    Messages:
    154
    Likes Received:
    22
    Heh thinking about it, after I upgraded last night, I was laying in bed I was playing around with the flash on webpages and didn't want to wake my wife. I silenced the phone that way (Which I didn't even know you could do, I just always use Beautiful Silent Widget), I think we may have found the culprit.

    However I know last night it let me put the phone in silent mode (I saw the icon popup with the speaker with the cross through it.) But now when I try to turn the volume down it just goes to vibrate. Am I missing something. I wanted to try to reproduce the problem.
     
  15. aleis

    aleis Well-Known Member

    Joined:
    Nov 14, 2009
    Messages:
    1,055
    Likes Received:
    33
    i had this problem with 2.1!!
    made a post about it and everything. but 2.2 saved me!
    i took it to a store with 2.1 and it was rooted...the verizon corp store guy noticed (he had a friggin nexus one rooted!) and said he would call me after he researched it...
    he know i was in for a world of hurt so he didnt note the account or call me back. he basically was saying dude, unroot it first :)
    but i didnt need to go back because the magical 2.2 update fixed my phone!! :)
     

Share This Page

Loading...