2.3.6 Battery life sucksSupport


  1. jdCaptivate

    jdCaptivate Well-Known Member

    1d 3h 26m 9s on battery, WiFi turned off, except on occassions when I wanted/needed to use it (prior to that, it was set to go on/off with screen). Battery at 21% right now. Voice calls #1, Display #2, Android OS 4th.

    Once again, proof that Android OS/WiFi is the culprit with extreme battery drain on 2.3.6.
    FlyingPigL and rmreid like this.
  2. BWRpota

    BWRpota Well-Known Member

    Hmm... very interesting idea. I'll be trying that one!
  3. rush67

    rush67 New Member

    Ok did a two day test .....and wow what a difference wifi off mod use with phone battery lasted 2days 2hours .....2.3.6 has to have a bug w/battery drain....just wanted to pass this info on and I tweeted them no answer back ...and I called again both at t and samsung the both told me again that this was the first that they have heard of it.witch I say is bs . cuz I called two days ago and reported it .hope something happens soon....:eek::confused: rock RUSH.....2112
  4. jdCaptivate

    jdCaptivate Well-Known Member

    Sent out my tweets today. Hope others did to.
  5. rmreid

    rmreid Well-Known Member

    Ditto, I try to hit them up at least twice a day on twitter as well
  6. meackerman

    meackerman Active Member

    what about posting on their facebook page about it too?
    FlyingPigL likes this.
  7. jdCaptivate

    jdCaptivate Well-Known Member

    Done that to. :D
  8. jdCaptivate

    jdCaptivate Well-Known Member

    Well, I have US Support's attention. They subscribed to my tweets, yesterday.
    FlyingPigL likes this.
  9. schwenger

    schwenger Well-Known Member

    Ok, my girlfriend noticed her android os was using most of her battery when the phone was on standby, Turning off wifi when she wasn't using it seems to stop this from happening. I reported this bug to the samsung support facebook. Hopefully we get a fix.
    rmreid likes this.
  10. IndyDave

    IndyDave Active Member

    Unfortunately I don't have a twitter or facebook account, but some snooping around the corporate site earlier turned up this:
    In the US, for technical support contact :
    Samsung North American Contact Center
    Tel: 1800-SAMSUNG (726-7864)
    Fax: 864-752-1632

    So I think Monday morning I'll write a long explanation letter, and program my fax to send it to them every 15 minutes. I'm just really ticked off at having made what I consider a major investement in the phone, accessories, etc... and a "fix" renders it unusable for the very reason I got it. Right now I'd be better off reactivating my Rugby.
    rmreid likes this.
  11. iHuman

    iHuman Active Member

    Okay, now that we've found out that wifi is the main culprit, I want to update to 2.3.6. (downgraded to 2.3.4. because battery life was horrible). However, I rooted, so now the update won't install. Is there any way to fix this?
  12. BWRpota

    BWRpota Well-Known Member

    My WiFi has been off for quite a while, but my battery life STILL sucks. I, too, suspect the OS as the culprit. How might I determine what OS I'm running, and how to downgrade to one which improves batt. life?
    Also, how to change to black wallpaper? Download?
  13. BWRpota

    BWRpota Well-Known Member

    "Oh, well" hell! After THOUSANDS AND THOUSANDS of calls voicing the same issue, our battery complaints are being cleverly dismissed with their sly methodology. Utterly na'ive to think they are STILL unaware of this problem.
    Got my SGSII at Walmart. This is the first phone the wireless associate pointed out to me...also the model which seemed to have been positioned so anyone would notice first from the checkout counter. Sent my dad to Wally-World to get a DELL laptop on Black Friday. The associate steered him to an HP instead, saying that it was the one everyone was snapping up. Two days later, the HD in the HP was clicking in it's death throes.
    Does Wally-World first push stock which has been found to have issues by customers?
    Could this be why the SGSII, with it's horrendous battery life issues but appealing display size, seemed to have been so seductively positioned in the wireless center at Wally-World?
  14. (G)

    (G) Well-Known Member

    Same here.
  15. BWRpota

    BWRpota Well-Known Member

    Anybody have experience with one or more of the "high capacity" batteries now available, Innocell, Seido, etc.? I saw one that was 3200 maH. Adds one centimeter to the thickness of the phone, however, but comes with a replacement backing for the device which by one account is secure and well designed for a proper fit.
  16. topekahawk

    topekahawk New Member

    Turned Wi-Fi off and my battery now lasts for almost 23 hours with moderate use. Trouble is now I am using more of my data plan.
    Turned wi-fi on and noticed that it is constantly searching for a connection. Even though it is already connected to my home network.
  17. rmreid

    rmreid Well-Known Member

    Folks we need to keep bugging AT&T and Samsung on this issue if we want a chance to get a fix sooner then later!
  18. Angelsnecros

    Angelsnecros Member

    I had 76% battery before installing 2.3.6. I updated it and after rebooting my battery level suddenly said 45% battery. Then just a minute later it dropped to 14%. I rebooted and still at 14%. There's no way the battery would drain 62% over the course of <10 min. So now I don't know what to trust.

    Was my battery really charged to 76% prior to updating? Is my OS now reading it incorrectly at 14%? I'm letting the battery drain completely and then recharging.
  19. jdCaptivate

    jdCaptivate Well-Known Member

    Yes, Samsung... it IS possible to get battery life close to this, if you fix your damn update!

    [​IMG]
  20. dapheel

    dapheel New Member

    I called Samsung Support and they helped me to change the wifi sleep policy from "never" to "when screen turns off". I will let you know if this results in a resolution to battery drain issue. It sounds like it will fix it.

    Action Taken:
    1. Settings
    2. Wireless and Network
    3. Wifi Settings
    4. Click Menu Button (next to Home Button) and Select Advanced
    5. Select Wi-Fi sleep policy
    6. Change it from "Never" to either "Never when plugged in" or "When Screen turns off".
    Tarnlight likes this.
  21. dwykofka

    dwykofka Well-Known Member

    That's not really a fix, I want to get my email while my device is sleeping.
  22. Tarnlight

    Tarnlight Member

    Well, it was worth a try. I just tried it and unfortunately, it didn't work. I tried the "When screen is turned off" option. Oh well!
  23. jdCaptivate

    jdCaptivate Well-Known Member

    The problem is a firmware update. Not a hardware related error. At least, mine, worked perfectly with 2.3.4.

    I finally got acknowledgement from @GalaxySsupport, so hopefully this gets some attention. Everyone should hit them up on Twitter. The have responded to 2 of my tweets, so far.
  24. jdCaptivate

    jdCaptivate Well-Known Member

    Mine have ALWAYS been set to that, even on my Captivate. No, it does NOT fix the problem. You have to actively turn OFF WiFi and turn it back on, when you need it.

    P.S. Keep up the Tweets. They're WORKING!
  25. jdCaptivate

    jdCaptivate Well-Known Member

    You will still get it, regardless of that setting.

Share This Page