1. Download the #1 Android News App:   EarlyBird - News for Android
    Dismiss Notice

2.3 Gingerbread. Should I have gotten it by now?

Last Updated:

  1. FaroeseViking

    FaroeseViking Well-Known Member

    I just got the Nexus One about a week ago. Been using it on TMobile w/out data plan, but using my home wifi. It seems by now 2.3 should have been installed through my wifi connection. Or can I only get it over a mobile data connection? Can I just drop my AT&T SIM in there(It has data)? Or is there another way to get the officail install on there?

  2. Dolmangar

    Dolmangar Well-Known Member

    You should have gotten it by now. You should verify exactly which version you have through the settings menu. It's possible that you have a custom ROM installed, which would prevent you from getting an OTA update.

    Assuming that you are stock, you can get and install the updates manually. I've included a link that has info on installing 2.3.3. The current Nexus One ROM is 2.3.4. You'll have to go back and likely install any other ROMs to get you up to date (ie I don't think you can just install the latest, you have to go in order - I'm sure someone will be able to give you more info on that). The manual update is easy. The files are signed so the device verifies them.

    Like I said, THIS one may not be the install you need, but there are similar pages for all the updates, you'll just have to search for them.

    How to manually update your Nexus One to Android 2.3 Gingerbread | Android Central
    FaroeseViking likes this.
  3. FaroeseViking

    FaroeseViking Well-Known Member

    Big thanks. I'll give it a try. Bought this off the dailysteals website, and I'm sure its stock. There was no SIM lock on it. It's run both on AT&T and TMobile, and TMobile, it picks up 3G. Again, thank you.
  4. Dolmangar

    Dolmangar Well-Known Member

    Sounds good. As long as you start at the right update version you shouldn't have any troubles. You can also try the CHECKIN command (you'll have to seach on it) it's supposed to contact the server and ask if there are any updates available, but it only really works if there is a pending update and you phone (by id number) is on the list to receive it.

    BTW the N1 doesn't have a SIM lock at all. You can run it on either network, the limitation will be the data speeds you get, the T-Mobile version will only get EDGE on AT&T's network etc.
  5. JeepWK2

    JeepWK2 Active Member

    *#*#2432546#*#* or *#*#CHECKIN#*#* checks for updates
    FaroeseViking likes this.
  6. FaroeseViking

    FaroeseViking Well-Known Member

    I got this error code.

    e:failed to verify whole-file signature

    What does it mean? And is there anything else I should try? I did try to install the zip 2 times (deleting the first one of course). Anything else?
  7. Dolmangar

    Dolmangar Well-Known Member

    One quick thing to try is to verify that you haven't named the file "update.zip.zip". Depending on your view settings it might be hiding extensions. Not sure if you would get that error code if that was the case though.

    Go to your Settings - About Phone screen and post your Model, Android Version, Baseband, Kernel and Build Versions.

    Example from my phone:
    Nexus One
    Kernel: android-build@apa28 #1
    Build GRJ22

    Also it might be helpful to post your part number. You'll have to remove your battery to see it. Mines with T-Mobile ####E002-00 (I think -01 is AT&T).

    All of this might allow someone to specify exactly which files you need.
    FaroeseViking likes this.
  8. FaroeseViking

    FaroeseViking Well-Known Member

    I actually did that correctly, I named the file "update" w/out the zip.

    Nexus One
    Android build 2.2
    BB Version 32.41.0032u_5.08.00.04
    Kernal Version haley@m4-dev#1
    build Number 2.16.405.1 CL223106 Release-keys

    Hope this helps.
  9. Dolmangar

    Dolmangar Well-Known Member

    I quick search on Google using your Kernel version gave me this link to the Google Nexus one support pages:

    I am on Android 2.2 and keep checking for the 2.2.1 update with no joy. - Android Help

    Where are you located? This link says that that Kernel version is for the Vodafone version of the Nexus One. The link that I send you was probably only for US versions of the phone (which would be why the signature failed), which means we'll have to track down update files for your specific phone/country so that it passes the initial validation check.

    Looks like you can get the images right from HTC, but I don't know which on you need:
    FaroeseViking likes this.
  10. FaroeseViking

    FaroeseViking Well-Known Member

    I'm in NY, but this mobile could have come from anywhere. As I said, I got it from dailysteals.com but no idea where they procured it from.
  11. Dolmangar

    Dolmangar Well-Known Member

    Sounds like you'll need to either find a way to get the Vodafone files, or perhaps someone at XDA can tell you how to set your phone back to US spec.

    There is a lot of cross posting between here and XDA, my guess is that someone should be able to tell you what you'll need to do it. I wonder if Vodafone has even released an upgrade to 2.3.4?

    I don't have the skills to help much further, but if I come across any info that might help I'll post it here.
    FaroeseViking likes this.
  12. Dolmangar

    Dolmangar Well-Known Member

    Goodbye Vodafone UK Nexus One ROM! Hello Gingerbread. The Open Source Administrator

    This link looks like it contains all the information you'll need to do this yourself (as well as some details about why you're stuck at 2.2).

    The basics are that it drops the phone all the way back to bone stock, then rebuilds Android up from there, but using the US Google (unbranded) release and updates. This should clear out the Vodafone ROM. Apparently Vodafone is what's stopping you from upgrading since they haven't released 2.3.

    Warning, I haven't gone through these instructions, and there is always a chance something will get messed up. So you should make sure that you're comfortable with these, and maybe verify if others have had success.

    I read through more of this, and it looks like all you really have to do is downgrade to the base Google release of Android and the OTA updates will start to come in. So you don't have to do the rest of the manual updates if you don't mind waiting. Apparently they start to come in pretty quick.
    FaroeseViking likes this.
  13. FaroeseViking

    FaroeseViking Well-Known Member

    Wow, thanks a lot. This looks like it, and I'll get to it when I go home and can close my door and give it my full attention. Looks like there's alot of steps.
  14. Dolmangar

    Dolmangar Well-Known Member

    No problem at all, happy to help. Looking forward to hearing if you're successful.
  15. FaroeseViking

    FaroeseViking Well-Known Member

    OK, now I've tried numerous times to do the PASS.IMG install, but nothing happens. I've downloaded the FRG33 form 3 different websites, and this never worked. And it looked like this is the one option that would work. What happens if I just wait for the Vodafone update to take effect? Will it always be at the mercy of waiting for Vodafone updates?
  16. Dolmangar

    Dolmangar Well-Known Member

    Just to be sure, are you unzipping the original zip file first:
    Passion_Google_WWE_2.16.1700.1_FRG33_MFG_Shipment_ROM.zip (84.8 MB)

    Then renaming the file that is in that zip:
    PASSIMG_Passion_Google_WWE_2.16.1700.1_FRG33_release_signed.zip (85.1 MB)

    to: PASSIMG.ZIP (verify that it's not getting and extra ".zip" on the end)

    I have no way to test the process (without resetting my phone), but it seems like this is the only step that is likely to get messed up. It seems unlikely that all of the files you downloaded are bad (perhaps your Unzip utility is causing the issue?)

    Once you have that file, saved at the root of your SD card (very important) the boot process to run the install is pretty straight forward. However in can be tricky to get the right buttons pressed in the right order. The Nexus One might not be registering the power-on button.

    Are you getting as far as the HBOOT screens? At what point is it failing? Is it finding the passimg.zip file and allowing you to select it?
  17. FaroeseViking

    FaroeseViking Well-Known Member

    OK, now I think I see my mistake. When I tried to unzip on my windows 7, it said it was unzippable. Then I tried on my Vista, and again said it was unzippable. Both times I tried with the unzipped file. Now I was able to unzip from my XP (Work) computer. It's on my thumb drive now, and I'll give it a try when I get home.
  18. FaroeseViking

    FaroeseViking Well-Known Member

    and yes, I was getting to the HBOOT screen, but it was not finding the passimg.zip file. And from what I've read, it seems the mobile takes over from there. I'll try again tonight and give you an update.
  19. Dolmangar

    Dolmangar Well-Known Member

    Damn it, I can't take all the stress of not knowing if it worked. You should have gotten up early to keep me informed of your success!!!

    Hope it worked :)
  20. FaroeseViking

    FaroeseViking Well-Known Member

    没有, tidak ada, 없음, нет, , هیچyok, نہیں

    If you don't understand Chinese, Malaysian, Korean, Russian, Persian, Turkish or Urdu, in short no (Love that google translate). I 100% unzipped the FRG33 properly, renamed it, installed in the root, did the HBOOT, and the mobile just doesn't recognize it. I even took a picture when it does that check, and I saw it looked for the passimg.zip (Had to take a picture because it does it so fast).

    Sorry to take so long to get back to you, but my work schedule kicked my ass this morning. . .

    Could this be part of the problem? I didi the unzip here at work becasue both my laptops at refuse to do the unzip. So I unzip here on my work comp, save the unzipped file on my thumb drive, save the new file on my laptop, rename it, then copy and paste it to the root of the SD card. Does it matter if I use the mobile for the data connection? O r do I have to do it directly on the SD using an adapter and SD card reader (Which I tried both actually)? Honestly, the only reason I want the GB is I'm hoping it will fix my screen problems for when I'm trying to type an SMS.
  21. navnav

    navnav New Member

    FaroeseViking/ Other members of forum,

    I am in exacly same boat as you are in. I bought N1 on ebay and got yesterday. This is a gift phone for someone and I am afraid to brick it. Still I wish it could have latest Android version.

    I also have same device Info:
    Android Version:2.2
    Baseband version:
    Kernel version: haley@m4-dev#1
    Build number: 2.16.405.1 CL223106 release-keys

    I already tried some updates from whichever website told me to download. 2 attempts failed with signature error.

    Please keep your results posted. I will be monitoring the thread daily till you succeed in upgrading.

    thanks a lot
  22. navnav

    navnav New Member

    Please read message fully, good news is it was extremely simple. i have attached links to original forum on vodafone (since mine is vodafone version as mentioned above).

    MOST IMP: EVEN AFTER upgrade , I DONT have Cy..mod ROM or so called "custom ROM", all i have is 2.3.4. That's what i wanted.

    After reading thread again and found that my nexus phone might be vodafone version, i searched for any clues. I found that vodafone version is raodblock for getting me OTA update.

    I found a vodafone forum, where there were 2 links to big downloads ~85-90MB.

    First one by posted by moderator, is to upgrade to FRG83 (not sure what that means) and 2nd one he says directly upgrades to GRJ22 (not sure what that means either).

    Link for discussion,
    My Nexus One - will it update to Gingerbread? - Vodafone eForum

    Link for older version ( It would upgrade to, FRG83 and then you again have to upgrade to 2.3.4 manually or OTA)
    Rusty : 01-03-2011 04:02 PM - last edited on 01-03-2011 04:03 PM

    Link for newest version ( I used this one, file name says GRJ22.)
    Look for RustY message,
    "New passimg to go straight to GRJ22: http://shipped-roms.com/download.php?&model=Passion%20(Nexus%20One)&file=PASSIMG_Passion_Google_WWE_..."
    Re: Easy (no root) Gingerbread Update for all Nexu... - Page 3 - Vodafone eForum

    STEP 1. With heartbeat over 500/s, I tried 2nd link (GRJ22) and renamed file to passimg (no .zip, since on my XP PC, .zip ext did not show). I attached USB cable to phone and PC, turned on as file sync allowed thingy and copied "passimg" to send to D drive (phone sd card is showing as D on my PC).

    STEP 2. Disconneted the USB and restarted phone. It AUTOMATICALLY starting reading passimg.xxx (error no image), then AUTOMATICALLY went to another passimg.xxx(still error no image) and finally to passimg.zip.

    STEP 3. I then saw a vertical blue bar on top right, filling up slowly.
    When blue bar went 100% blue, I saw 2 options, restart YES or NO.

    STEP 4. I selected YES and then phone restarted, though took 5 sec extra. and on restart, It started with Android toy thing asking me to setup my phone.

    (This was exactly same as yesterday when I got my phone and started first time and followed setup as guided)

    STEP 5. I saw different and some new Icons in applications window. Immediately checked my OS from phone setting and WOOOOOOOOOOW, it said 2.3.4. I don't anymore need to take any risk ever again.

    Please ask any questions, though I am sure it would be exactly straightforward for you too.
  23. FaroeseViking

    FaroeseViking Well-Known Member

    None of this is working. I've tried all these different solutions to the letter. The one thing that I find strange, I'm not even getting a error code now, when I attempt to install the FRG33 or the zip files. It's as if the Nexus isn't even seeing these files. Could it be the HBOOT? I'm running 0.35.0017 . Also, on the HBOOT page, at the top it says "NEXUSONE PVT SHIP S-ON" Any ideas what this means?
  24. Dolmangar

    Dolmangar Well-Known Member

    You've gone way past what I know about the system. XDA tends to have more technical users, if you're not already a member over there you should be.

    The other option would be to try a custom ROM. Cyanogen is a popular one, also the technical forums on the ROM sites will be filled with people who are used to troubleshooting ROM flashing issues.
  25. FaroeseViking

    FaroeseViking Well-Known Member

    Big revelation today. This Nexus wasn't made for Vodafone, but for some rinky dinky carrier called Videotron that operates up in Quebec. So I must search for someone smart enough to reverse flash one of these French Canadian mobiles. Wish me luck!

Share This Page