232/ICS, no option to connect to USB for Charge Only?Support


Last Updated:

  1. desmofan

    desmofan Well-Known Member This Topic's Starter

    Joined:
    Nov 14, 2009
    Messages:
    194
    Likes Received:
    13
    I just installed the Nook ap, and added some free books to my library online to see if I like the reader better than the Kindle or Google Play. My Bionic was about to die (makes sense since it's been off the charger for over 6 hours, but that's another thread), so I plugged it into my laptop to charge while I downloaded the books to my Bionic. The Nook app won't let me do this because it says there is no SD card mounted. This is because my Bionic is connected by USB as a mass storage device, and there's no option to set it to connect for charging only. This is the first version of the OS that I have not seen this option, and it's ridiculous. Am I missing something?
     

    Advertisement
  2. OhBe1

    OhBe1 Well-Known Member

    Joined:
    Jan 10, 2010
    Messages:
    101
    Likes Received:
    16
    I just connected to test this out, and you're right: there is no "charge only" option. I only recently installed .232, and I hadn't noticed this.

    I guess this is o.k. for me, since I haven't had any device conflicts like you're experiencing. Hopefully someone with more expertise will chime in. Anyone?
     
  3. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Joined:
    Oct 28, 2009
    Messages:
    9,415
    Likes Received:
    1,919
    Charge only mode is there, but now only shows when you're in a dock of some sort.
     
  4. Maddog241

    Maddog241 Well-Known Member

    Joined:
    Aug 25, 2011
    Messages:
    95
    Likes Received:
    14
    The charge only option was eliminated in ICS when connecting to computer by USB. When you plug in, you should see a menu of options. MTP mode is media transfer protocol and should work for you. The phone will charge and you can transfer back and forth. Also, the phone must be unlocked for transfer to work.
     
  5. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Joined:
    Oct 28, 2009
    Messages:
    9,415
    Likes Received:
    1,919
    If you look at my screenshot, and read what I posted while you were typing, you'll see what is really going on:

    2012-10-07 20.02.45.jpg
     
  6. SirEagle

    SirEagle Well-Known Member

    Joined:
    Feb 21, 2010
    Messages:
    707
    Likes Received:
    80
    Looks like you go to Settings/Storage, then hit your Menu button, then select USB computer connection, then check one of the other settings instead of mass storage and see it it works.
     
  7. SirEagle

    SirEagle Well-Known Member

    Joined:
    Feb 21, 2010
    Messages:
    707
    Likes Received:
    80
    There's no charge only mode though.
     
  8. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Joined:
    Oct 28, 2009
    Messages:
    9,415
    Likes Received:
    1,919
    I have the screen caps already from previous builds - it showed in a car dock, and it showed in webtop.
     
  9. Maddog241

    Maddog241 Well-Known Member

    Joined:
    Aug 25, 2011
    Messages:
    95
    Likes Received:
    14
    I see what you are saying. What I meant ( and probably didn't explain clearly) was that the charge only option does not appear when you plug straight into a computer via USB anymore.

    I thought that was what the OP was referring to.

    Was the information I provided incorrect?
     
  10. desmofan

    desmofan Well-Known Member This Topic's Starter

    Joined:
    Nov 14, 2009
    Messages:
    194
    Likes Received:
    13
    I'll try one of the other settings to see if it allows access to the "SD Card" from the phone, as that is what I was trying to do. The reason I noticed this is I was trying to open Nook and download a book while charging my phone through the USB. Nook requires access to the SD card, and when it is unmounted, due to being attached to my laptop, this is not possible. It strikes me as very odd that Google would remove this option, because there does not seem to be a reason.
     
  11. Maddog241

    Maddog241 Well-Known Member

    Joined:
    Aug 25, 2011
    Messages:
    95
    Likes Received:
    14
    It should work in the other mode. I transfer files with no issue using MTP mode.
     
  12. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Joined:
    Oct 28, 2009
    Messages:
    9,415
    Likes Received:
    1,919
    No, we were both saying the same thing in different manners.

    I think the problem is that while charging the microSD is unavailable (b/c it is unmounted) to the Phone. Maddog may be right, I've never tried to see if the phone can see the microSD in the other two modes before. Won't hurt to try.
     
  13. Maddog241

    Maddog241 Well-Known Member

    Joined:
    Aug 25, 2011
    Messages:
    95
    Likes Received:
    14
    Did you get this resolved?
     
  14. Thom

    Thom Guides Guide

    Joined:
    Feb 16, 2011
    Messages:
    10,177
    Likes Received:
    3,951
    In 5.9.905 the access to the SD and SD-Ext cards that are permitted are shown in the attachment. I don't know what they are in any ICS leak.

    ... Thom
     

    Attached Files:

  15. desmofan

    desmofan Well-Known Member This Topic's Starter

    Joined:
    Nov 14, 2009
    Messages:
    194
    Likes Received:
    13
    I had not tried again, because my phone charged the other day, so I disconnected it from my laptop. I just tried, and the MTP connection still did not allow access to the SD card, so it was still unmounted, but the Camera mode (PTP) seemed to leave the card mounted, and allowed the battery to be charged via USB simultaneously.
     
  16. Maddog241

    Maddog241 Well-Known Member

    Joined:
    Aug 25, 2011
    Messages:
    95
    Likes Received:
    14
    When I connect my Bionic, set to MTP mode, I get a "Droid Bionic" entry in my windows explorer. When I open that I get Internal Storage and SD Card. I can open either one of those and access files and folders.

    Do you have the latest Moto drivers?
     
  17. desmofan

    desmofan Well-Known Member This Topic's Starter

    Joined:
    Nov 14, 2009
    Messages:
    194
    Likes Received:
    13
    Sorry for the long delay in answering. I can access my Bionic from the laptop well. What I was having a problem with was charging my Bionic from my laptop and accessing the SD card from an app on the phone. Connecting the Bionic via USB in any manner except Camera Mode (PTP) unmounts the SD card from the phone, making it inaccessible.
     
  18. HopeMcCloud

    HopeMcCloud Member

    Joined:
    Oct 26, 2012
    Messages:
    8
    Likes Received:
    1
    The corporate policy at my job is to disallow any foreign usb device from connecting to my pc. Therefore, I NEED the charge only option, and I do NOT have a docking station for my Droid Bionic. Or, I could violate the corporate policy. Or, I can carry a wall-charger to work.

    Any way to ask for this feature to be returned in a future release?
     
  19. Thom

    Thom Guides Guide

    Joined:
    Feb 16, 2011
    Messages:
    10,177
    Likes Received:
    3,951
    It is doubtful that it will return. I suggest you use a wall charger. You could get an OEM wall charger and leave it in your office.

    ... Thom
     
  20. Richy_T

    Richy_T Member

    Joined:
    Nov 2, 2010
    Messages:
    20
    Likes Received:
    1
    Would something like this be acceptable?

    Amazon.com: PureGear Charge Only Cable for Universal Micro USB - Retail Packaging: Cell Phones & Accessories

    Has the advantage that you wouldn't be at risk of accidentally leaving your phone on mass-storage and breaking policy.
     
  21. SNeitzel

    SNeitzel Well-Known Member

    Joined:
    Aug 11, 2010
    Messages:
    629
    Likes Received:
    98
    So I brought my car mount in and was playing with it here at my desk.
    When the phone is in "car" mode and connected to my PC, it will charge, the SD cards are accessible from the phone and Win7 does not try to mount anything. So, if there was an app that fools the phone into thinking it is in a dock and puts it in car or media mode that would work.
    It's too bad the magnet trick from the OG DrOID doesn't work on the bionic...
     
  22. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Joined:
    Oct 28, 2009
    Messages:
    9,415
    Likes Received:
    1,919
  23. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Joined:
    Oct 28, 2009
    Messages:
    9,415
    Likes Received:
    1,919
    I can't find the latter, and the former is not loading car mode.
     

Share This Page

Loading...