2X USB connection not working - help !Support


  1. foreal

    foreal New Member

    Hi everyone!

    I am new to this forum and also to the android platform.

    LG Optimus 2X is my first android phone. I have a problem with the USB connection. I cannot connect my phone to the computer via cable. When I plug the phone to the computer it just starts to charge. I read dozens of articles regarding this issue and tried everything, but nothing helped.

    I am using Windows XP SP3. When I first plugged in the phone to the computer it didn't recognize it so I downloaded the drivers from a LG website. When I plugged it in after installing the drivers windows recognized it and continued finishing the instalation. After it was all done I entered "my computer" but the phone wasn't shown there. I checked the "mass storage" in phone options and tried again, but that didn't help. After that I installed LG PC Suite and tried to connect the phone via it, but pc suite also didn't recognize that the phone is connected to the computer. It says that I should "check if the phone is connected to the computer". I tried turning on "USB Debugging" but that didn't help either.

    After that I downloaded LG update tool. When I select the phone model and when I plug it in the computer the program says that there is a new driver for it and starts downloading it. When it is installed I plug the phone in again and lg update tool again wants me to download that same driver again and again and again....and it just cannot finish. It wants me to download and install the same driver dozens of times.

    I reinstalled lg drivers, lg pc suite, hard and soft reseted the phone....NOTHING HELPED! I hear that short sound from windows when I plug it in the computer and that's it, it is just charging.

    I tried on other computers and with another cable (from Nokia N97 Mini), but it just starts to charge again.

    Everything else on the phone works fine. It has Android 2.2.

    I am using "software data cable" to transfer files from the phone via WiFi, but I cannot update the OS without the USB connection.

    Please help me!!!

    Thanks in advance!

    Advertisement
    :
  2. foreal

    foreal New Member

    Anyone knows how to fix this problem???? :(

    I also have another problem....I cannot root my phone via Z4Root...I start the program and hit "permanent root" but when it says that is done and when the phone restarts I start "Rom Manager" and it says that I have to root my phone first....

    I don't know if this is some kind of factory error on my phone or what...

    Help guys!!!!
  3. foreal

    foreal New Member

    I managed to root it via Gingerbreak v1.2 and installed custom rom cm 7.1 stable. now usb connection works!
  4. jackdsparker94

    jackdsparker94 Well-Known Member

    Download drivers via LG drive tool to root download unlock root
Loading...

Share This Page