Support 3G connection issue on the HTC Hero

Discussion in 'Android Devices' started by stevebal, Aug 11, 2009.

  1. stevebal

    stevebal New Member
    5

    Aug 11, 2009
    1
    0
    5
    Luxembourg
    Hi,

    I bought the HTC Hero from an internet shop a week ago. It was unlocked. Unfortunately, the internet connection (3G Edge etc.) disconnects whenever the phone goes into sleeping mode ("keyboard lock"). This means that the mail push (gmail account) does not work when in sleeping mode and it takes quite a while for the data connection to restart. The always on button for the data connection is switched on in the data connection menu, but that does not help. Could the problem come from my service provider?

    Thank you for your help.

    Steve
     

    Advertisement
  2. winmarc

    winmarc New Member
    5

    Sep 3, 2009
    4
    0
    5
    I have sent you a private message.
     
  3. kikal

    kikal New Member
    5

    Feb 23, 2010
    2
    0
    5
    please, I have the same issue, can anybody help? It
     
  4. Duncs

    Duncs Well-Known Member
    48

    Sep 21, 2009
    112
    23
    48
    Male
    Southampton, UK
    try - settings, wireless controls, mobile network settings, enable always-on mobile :)
     
  5. kikal

    kikal New Member
    5

    Feb 23, 2010
    2
    0
    5
    it doesnt work for me, I always have these option checked and is the same thing.
    regards
     
  6. parkaml

    parkaml New Member
    5

    Mar 20, 2010
    2
    0
    5
    Hey, even I am facing the similar issue. with me, the connection turns off and never gets connected at all. & this even happens with wifi connection. Also, the mobile is not able to find the 3G networks.

    Is there any patch or update which can solve this issue.

    OR can anybody tell me how do I format the phone completely and install the Andriod 1.6 from scratch (like we install Windows OS).

    Picasa Web Albums - 10904214446349656... - HTC hero
     
  7. foxuniform

    foxuniform New Member
    5

    May 10, 2010
    1
    0
    5
    I have had this EXACT problem for a couple weeks. Like you, I am missing out on my push Gmail service on the phone (among other services). I have noticed that once you go to the appropriate settings menu on the phone, you can see that the phone has disconnected from the data network and actually you can see that it re-connects (checks itself and says re-connecting) then and there. Sometimes it takes a while to do so, even if done manually. I am still searching for help on the matter. I have an idea for a work-around, and I will post again if it works.
     
  8. prenticehill

    prenticehill New Member
    5

    Sep 10, 2010
    2
    0
    5
    I am having an issue with receiving email when my phone is on 3G, it just says "network error". It works fine on WIFI. Does anyone have an idea of when it could be?
     
Tags:

Share This Page

Loading...