3G internet connection problem!Support


  1. wengyew90

    wengyew90 Active Member

    Hi all,

    Lately I have been facing problem with my 3G internet connection as it will switch off on its own occasionally (3G icon disappear) and will only switch on after 30 seconds or so. I'm not using any data toggle by the way. I believe it is not the problem of the carrier network as my sibling's 3G has no problem at all. Does anyone have any idea about the problem? Thanks a lot

    Advertisement
  2. Gearu

    Gearu Well-Known Member

    You still have the signal bars yes?

    Currently I myself am going through a related problem but my whole connection goes, every 1-2 minutes no joke.

    Someone once posted on here about a latency/timeout setting for the 3G/H in the engineer menu, if someone has that bookmarked or something that'd be fab, I can't find it.
    wengyew this setting can keep the connection active for longer and may fix the rpboelm.
  3. Russell Ng

    Russell Ng Well-Known Member

    Do you have any power saving app in your phone? Like Juice Defender? Any recently downloaded apps? You using the power saving mode of the phone? Maybe check those settings and see if they can interfere with data connection.
  4. wengyew90

    wengyew90 Active Member

    Yeah, I still have the signal bars and have no problem with calls and sms. You are right, I'm facing the exactly same problem as you. The 3G seems to have a timeout everytime I switched it on. It's really frustrating when my downloads halted midway and the whole file's gone :mad:
  5. wengyew90

    wengyew90 Active Member

    Nope, I don't have any power saving apps nor activated any. I'm currently on GB2.3.6 and the apps I downloaded lately don't really interfere my data connection in terms of permission requirement. Just that previously I was using widgetsoid to toggle my data and coincidently, that was the period when I stopped using it lately that my problem started. I have cleared the widgetsoid permission as administrator and uninstalled it besides deleting any leftover data files
  6. Gearu

    Gearu Well-Known Member

    I found the post with the thing I was looking for, it was a dormancy setting not latency:
    Courtesy of steslatt.
    wengyew90 likes this.
  7. wengyew90

    wengyew90 Active Member

    I tried it but fast dormancy has already been enabled
  8. Gearu

    Gearu Well-Known Member

    I've been looking into this and it seems there is a problem with the S2 and certain networks, some problem with juggling 3G, H and H+, having that 3rd internet variety just blows it's mind, but there may be a way to fix it by flashing a different modem file.

    Slight alternative - Dial *#301279# and choose Change HSPA revision, then experiment by choosing one of the options, the 3rd option [HSDPA/HSUPA] is the default I believe, but yeah you choose an option, then menu key>Select>(leave blank) and press ok, you'll get an error that breaks the connection, ok that and after a few secs the connection comes back.

    HSPA off leaves you with 3G, and HSDPA Only should give 3G and H, but not H+, but after a while H+ came up for me anyway.

    Here is a huge thread about this: http://forums.whirlpool.net.au/archive/1714413

    Just before halfway down there's a guy called inoblivion claiming that firmware KF3 fixed this issue for him, I might experiment with just using it's modem file when I can be bothered.
    wengyew90 likes this.
Loading...

Share This Page