3G not workingSupport


Last Updated:

  1. Zelbinian

    Zelbinian Member This Topic's Starter

    Joined:
    Sep 16, 2009
    Messages:
    6
    Likes Received:
    0
    Hey there.

    I got a brand new, unlocked Samsung Galaxy about a week and a half ago. I had two immediate problems with the phone:

    1. No Market
    2. 3G didn't seem to be working

    I fixed the lack of Market problem by upgrading to the H7 firmware. I was hoping this would also fix the 2nd problem, but it hasn't. I've also tried getting a new SIM card from AT&T, and this hasn't seemed to work either.

    Obviously I may end up having to call Samsung USA at some point and request a fix, but not only might that mean I have to live without the phone for a long time, I have no idea if Samsung USA will even want to help me since I bought it 3rd-party unlocked and it isn't even officially in the states yet.

    So if anyone has some ideas, that'd be appreciated. :) (And yes, the "Use only 2g networks" setting is unchecked)
     

    Advertisement
  2. bitxboi

    bitxboi Well-Known Member

    Joined:
    Aug 21, 2009
    Messages:
    323
    Likes Received:
    6
    Hi Zembilian,

    have you tried to setup your APN settings? I understand that when you say you've no 3G, you mean data HSPA and not just UMTS coverage, am I right?
    Menu -> Settings -> Wireless -> Mobile Networks -> APN
     
  3. Rastaman-FB

    Rastaman-FB Well-Known Member

    Joined:
    Sep 11, 2009
    Messages:
    6,113
    Likes Received:
    1,010
  4. Zelbinian

    Zelbinian Member This Topic's Starter

    Joined:
    Sep 16, 2009
    Messages:
    6
    Likes Received:
    0
    @Rastaman-FB: I live in Seattle, and the 3G doesn't work anywhere, so I'd be amazed if that was it. Also, the phone is quad band.

    @bitxboi: I have not tried that, mostly because I do not know how. :)
     
  5. Rastaman-FB

    Rastaman-FB Well-Known Member

    Joined:
    Sep 11, 2009
    Messages:
    6,113
    Likes Received:
    1,010
    AT&T in alot of areas including seattle according to google use 850 and 1900 making it incompattible with the current i7500 double check with AT&T

    if they do support the frequencies that are used buy the galaxy then get the apn settings from at&t
    go to menu>settings>wireless>Mobile networks>Access point names
    and enter the gprs/3g apn details there
     
  6. Zelbinian

    Zelbinian Member This Topic's Starter

    Joined:
    Sep 16, 2009
    Messages:
    6
    Likes Received:
    0
    Ahh. When I looked up the specifications for the phone originally (when I was deciding whether to buy it), what I found was these frequencies:

    GSM 850 / 900 / 1800 / 1900

    I was like, ok, awesome. Quad-band, works everywhere.

    In response to your contention that this wasn't true, I looked at specifications on a few different websites until I finally found one that is more detailed:

    2G Network GSM 850 / 900 / 1800 / 1900
    3G Network HSDPA 900 / 2100 / 1700

    Damnit. So I guess I'm screwed, unless I'm lucky enough for T-Mobile to broadcast 3G on different frequencies. Anyway, thanks for the help.
     

Share This Page

Loading...