3G off, wi-fi on?Support


  1. Robsia

    Robsia Member

    I have just bought the Samsung Galaxy Apollo i5800 for my daughter.

    I want her to be able to connect to our home wi-fi network when at home, and any other free ones she can find, but not have the 3G kick in, as her SIM is a very cheap rolling monthly contract with no data plan.

    We connected to the home wi-fi no problem, but after a while I looked at the phone and saw that it said 3G - she was still at home and surfing happily, thinking she was on wi-fi.

    Now I'm worried she will be racking up a huge bill without knowing it.

    How can I turn 3G off?

    Advertisement
  2. jahhus

    jahhus Member

    Hi mate,

    Just hold down the power button, and it should give you four options, one of them will be to switch Data Network Off.

    The above applies if the phone has froyo installed on it.

    Hope this helps!

    Viva la Free Wifi!! :)
  3. Robsia

    Robsia Member

    Hi

    Thanks for your reply.

    I tried that, but that option is not there, only silent, flight mode and power off.

    I am pretty certain the phone is only running Android 2.1. Is it possible to upgrade it? I am new to Android - I've had an iPhone for the last two years.
  4. jahhus

    jahhus Member

    Yes, you should be able too, download and install KIES software from samsung website, once installed connect your phone via usb cable provided.

    It's not as hard as it sounds.

    Please don't swear in this forum ;-)
  5. Robsia

    Robsia Member

    I didn't swear :confused:
  6. jahhus

    jahhus Member

    You said the "i" word :)
  7. jahhus

    jahhus Member

    Also as majority of these phones are on froyo nowadays, one would have thought purchasing a new model, one would have received froyo as standard.

    If you don't feel comfortable doing it yourself, take it back to purchase point, I'm sure they will update it, as an after sale service.
  8. Robsia

    Robsia Member

    Well, I've downloaded KIES but when I try to upgrade it, it just errors. I bought it second hand from CEX, although they do offer a one year warranty - I'm not sure it would go as far as upgrading the software for me.

    I'm worried now - I checked her usage and she racked up 61p in the first day - it doesn't sound like much, but I'm not paying
  9. Tigsteroonie

    Tigsteroonie Member

    If you go into the Mobile Network Settings, click on the APN, and then scroll all the way to the bottom of those settings - you should be able to find an option that has MMS, Internet, or Internet & MMS. (I'm sorry that I can't remember what it's called, I've upgraded to 2.2!) If you switch to MMS (ie not an Internet option), it turns off all the 3G connectivity but leaves the wifi intact.

    However, on mine it also stopped me receiving MMS too. Only an occasional annoyance as most people I know put their photos up to FB rather than send them by text.

    If you want to manually upgrade to Froyo 2.2, the instructions in the sticky at the top of this forum are very good. I'm a phone tech numptie, and the instructions worked for me!
    SuburbanSteve, jahhus and Robsia like this.
  10. Robsia

    Robsia Member

    Thank you so much!! I would never have looked down there! Hopefully that will solve everything.

    Hopefully I will figure out how to upgrade soon. We weren't using the Samsung-provided cable as it didn't come with one - we were using a Nokia one that my dh had which was the right size. It should have worked, but maybe that was the problem.

    I only say that as my daughter has an MP3 player and we HAVE to use the cable that came with it to charge it; he tried another one the same size and it did nothing. But as soon as we swapped it for the proper one - it charged!
  11. TigerMan007

    TigerMan007 Member

    Hi

    I had exactly the same issue with my Samsung Galaxy Apollo 5800. I downloaded APNdroid which lets you switch off the 3G
  12. Robsia

    Robsia Member

    Thanks - although I did what Tigsteroonie said and it worked perfectly. :)
  13. SuburbanSteve

    SuburbanSteve Member

    Thanx Tigsteroonie done what you said and fingers crossed it's working great, thanx mate

Share This Page