1. Hot New Devices! HTC One M9 | Samsung Galaxy S6 | LG G4

4.1.2 Update for rooted users


  1. RichSz

    RichSz Not Entitled VIP Member

    I'm having the same problem but didn't equate it to the update. Interestingly I just bought the DLSR Controller and it works fine. Same cable just not remote storage.
  2. Teknologic

    Teknologic Well-Known Member

    Pretty sure it still worked for me after 4.1.2 testing in a sec.
    Yup, working fine. Running titanium backup to my mSD card as we speak.

    Fully stock btw.
  3. Modman

    Modman Well-Known Member

    I do not know how to check it.
    All I know is that when I check off md5 checksum
    In twrp it says it failed. And it scares me that I can brick my tablet.
    Please explain clearly how to check it. I am thinking about googling how to disable ota updates because my tablet is running fine. I redownloaded the file without the changed system apps and I go to flash and check md5 and it fails.

    I don't know if twrp changes system apps or if I should use your other file. If I it wasn't failing the md5 checksum in twrp I would've taken a chance and flashed it. The ota update prompting is obnoxious would maybe just disable if I could.

    ALL POSTED FILES NOT CLEARING CHECKSUM WHEN CHECKED IN TWRP! FRUSTRATED! really don't want to brick. Can I just do the ota with survival mode enabled in super SU? Or please explain I only know how to check off check md5 checksum in twrp and its failing.
  4. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    Yes. Just do the OTA if you haven't deleted any system apps


    You can check the md5 using most file explorer apps such as es file explorer or root explorer. Once you have the file on your sd card navigate to it in the app and long press it. Then select properties and there should be an md5 check. You then compare the numbers.
    Modman likes this.
  5. Modman

    Modman Well-Known Member

    Well I didn't delete any system apps does twrp?
  6. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    No, deleting system apps is something you'd have to have done
  7. artman540

    artman540 Well-Known Member

    I had a bad download that bricked my device others have had no problems.
  8. Modman

    Modman Well-Known Member

    OK then what is the difference between using the ota and flashing the zip file through twrp? Will ota update overwrite twrp or root?
  9. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    The OTA and stock zip will fail if you have modified system apps because it does a check to verify everything is there.

    My modified flashable simply removed those system checks for those that have modified the system partition.
    Modman likes this.
  10. Modman

    Modman Well-Known Member

    Thanks gonna try survival mode super such with ota cause checksums are not panning out in twrp or root explorer
  11. Claghorn

    Claghorn Well-Known Member

    OK, just got a notice that the update is available on my Nexus 7. Now I gotta go read all these threads to see what I should do with it since I've rooted the tablet (but haven't installed different rom or anything drastic like that)...
  12. Teknologic

    Teknologic Well-Known Member

    If you haven't installed a new kernel or touched /system in any way (removed system apps or modified system files for instance), I'd say go for it. Be prepared to re-root tho. Shouldn't take a minute, but if you can't be bothered to, look at supersu or ota rootkeeper for keeping root.
  13. Modman

    Modman Well-Known Member

    OK updated successfully with ota. Only thing that sucks is root survival doesn't seem to have worked. Gonna try to hook up to root toolkit to reroot
  14. Claghorn

    Claghorn Well-Known Member

    Yea, I think re-rooting will be simplest. I did actually write down everything I did to root it last time, so it shouldn't be hard to do again :).
  15. Modman

    Modman Well-Known Member

    Wug toolkit says it rooted me but I'm still unrooted
  16. Modman

    Modman Well-Known Member

    Need help lost root. Wugs toolkit says it rooted me.
    Checked with root checker not rooted.

    Need help
  17. viper689

    viper689 Well-Known Member

    Are you using the latest version of Wugs?
  18. Claghorn

    Claghorn Well-Known Member

    Except for the part where the OTA update fails to install saying something about the whole-file checksum not matching :).

    Do I have to remove stuff I've added as well as not have deleted anything? I do have su and busybox out there which weren't on the stock system.
  19. Modman

    Modman Well-Known Member

    Solved my own problem reinstalled all nexus root kit drivers.
    Had to reroot. Reflash twrp the one in the toolkit.
    Then manually flash rooting files busy box.zip,cwm-supersu-vo.94.zip
    and disableautoflash.zip as instructed by the toolkit when it drops you in twrp. Not impressed with this update at all. Anyone know how to enable auto rotate? This was the ota update.
  20. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    There's a thread for rooted users in the all things root subforum :D

    If you're rooted I'd suggest flashing the stock OTA zip
  21. miseryguts

    miseryguts Well-Known Member

    What option do i need to choose here..?
    The default is Wipe Dalvik Cache but there is also Wipe Data and Cache, Backup Existing Rom.
    Is there anything else that I need to do or be aware of..?
    I've already backed up my root with Voodoo OTA.

    Thanks.
  22. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    Moved to all things root section. It stated in the OP of my thread that you would lose root. Also merged duplicate threads
  23. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    If you are trying to manually flash the OTA file you'll only need to wipe dalvik cache and cache
  24. sleezecheeze

    sleezecheeze Well-Known Member


    USB debugging is/was on and is fastboot just recovery mode?

    I've tried everything that I know of and nothing will work. I got the toolkit to say that I was rooted and install superSU and busybox but the device isn't actually rooted. When running the root validator it told me that I had no busybox applets. I can't push the applets though because I get an error saying that I don't have the correct privileges or something along them lines.

    Shouldn't have updated :/
  25. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    Fastboot is your bootloader.

    Power+volume up+ volume down gets you there.

    Could just flash the Su file manually

    Optionally have the toolkit unroot first and then reroot
    sleezecheeze likes this.

Share This Page