4.1.2 update has totally KILLED wifiSupport


Last Updated:

  1. GiggityGiggity

    GiggityGiggity Well-Known Member

    Hey all. I upgraded to 4.1.2 yesterday and noted that straight after it wouldn't connect to the router it always connects to. I rebooted the phone several times, eventually pulling the battery and it finally started working again.

    I went out this morning, came back and the phone simply will not connect to my router. :mad: I know it's not the router as 5 other things I have can connect just fine. After a quick search it seems it's a problem many people are having. It's pointless having this phone with no wifi. How the hell do I roll back to 4.1.1 without rooting? (I'm on a mac, not a pc)

    Advertisement
  2. breadnatty08

    breadnatty08 pain rustique VIP Member

    Rolling back from an update is next to impossible without rooting.
    Have you tried a factory reset on your phone? Have you tried reseting your home router? Have you been able to connect to any other wifi networks?
    ScandaLeX likes this.
  3. Nobby Sheep

    Nobby Sheep Well-Known Member

    Sorry you've had a problem with the upgrade.

    Have you checked you router settings as I once had my phone on a fixed IP address that was assigned to another device by mistake (family descended with mobiles a plenty) and it took me an hour to figure out why they could connect and I couldn't!

    Alternatively (and I've not done this myself), but post #6 appears to give the relevant details.

    http://androidforums.com/samsung-galaxy-note-2/687561-4-1-2-updated-battery-drain.html
  4. SixtyDashOne

    SixtyDashOne Well-Known Member

    I would try resetting the router first of all. Sounds like it may be a simple IP conflict.
  5. GiggityGiggity

    GiggityGiggity Well-Known Member

    Well, I can't fault Samsung for the speed of their reply. Direct from the horses mouth:

    "Old systems settings can be left on the phone after an update occurs, which is why we usually recommend a full factory reset after updating. If this isn’t done your device may begin to give false readings from system resources, or experience technical problems, which may explain the issue you are having.

    We would advise on doing the following, which is designed to reset the settings on your device. Please back up your device using Samsung KIES before you do this.

    1) Remove the battery for at least 40 minutes, put the battery back in and allow it to fully discharge. Afterwards, perform a full battery charge with the device turned off. Do not interrupt the charging process.
    2) After the battery is fully charged, we would like you to perform a full factory reset, which can be done via Settings > Backup > Reset.

    This process will reset your device, remove old system files that are no longer needed and enable your device to operate normally again."

    So, I've done all that and wifi still didn't work. I factory reset a second time and wifi is working again. Now I have to reinstall everything and get the phone back to how I had it (which will take bloody hours). Next time I'm going to search the web to see if the next update causes any problems BEFORE I update.
  6. GiggityGiggity

    GiggityGiggity Well-Known Member

    And now we're back to it not connecting. This is beyond a joke. I'm on the verge of taking a hammer to this POS.
  7. twister6

    twister6 Guides Guide

    As it was asked before, are you able to connect to another wifi network?
  8. NeoGrandizer

    NeoGrandizer Well-Known Member

    Agree. If it works fine on other networks, it can be something with the router settings or security that need to be tweaked. Check the router's logs and see if there is something amiss. I know mine at one point failed to release IP addresses. Also another time where my IP address pool and amount of users logged were exceeded. Had to make the appropriate adjustments with the router to get it all working again.
  9. GiggityGiggity

    GiggityGiggity Well-Known Member

    I don't have access to another wifi network so I can't check. But I'm experiencing exactly the same symptoms that many others have had and it wasn't their routers causing the problem. I'm 99.9% certain it's not my router (which I have reset twice, changed channels on, removed the security settings and several other things, none of which worked). Everything else I have connects just fine and there are no IP or MAC restrictions set up on the router. I'm waiting for another reply from Samsung.
  10. NeoGrandizer

    NeoGrandizer Well-Known Member

    Worst case scenario would be that the firmware exposed a critical flaw or incompatibility between hardware/software. Usually hard to tell until it rears its ugly head. Could be drivers/hardware conflict. In which case it will either need to be fixed or replaced. It's happened with the original Note GPS after an ICS update. It happened to a few unfortunate users.
  11. GiggityGiggity

    GiggityGiggity Well-Known Member

    I would happily root the phone and roll back to 4.1.1 except I have no idea how to do that. Any mention of rooting I've looked at involves using a pc and I'm on a Mac.
  12. Liam548

    Liam548 Well-Known Member

    Go into your router settings and find your address for your Note 2, delete it and then delete the wi fi connection from your note 2.

    Re connect to your network as if it was a new network like when you first got your phone home, see if that helps.

    Ive had this before with laptops when they update and the router sees the same laptop as a conflict.
  13. GiggityGiggity

    GiggityGiggity Well-Known Member

    I gave it a go but no joy. Cheers for the suggestion though.
  14. GiggityGiggity

    GiggityGiggity Well-Known Member

    Right, I managed to test it on 2 other networks and got the same result so now I'm 100% sure it's the phone. I emailed Samsung again and they got back to me this morning. They want me to send it to their main service centre. However, there is a smaller service centre 2 miles from me so I asked if I could take it there. They said I could but warned that as they weren't a main service centre all they would really be able to do is re-flash it.

    I've got nothing to lose so I dropped it in to my local centre. I asked if they could roll it back to 4.1.1 but they said they could only flash newer versions. So they're going to re-flash it with 4.1.2. My pessimistic side thinks that it won't cure the problem but you never know.
  15. GiggityGiggity

    GiggityGiggity Well-Known Member

    Got the phone back this morning and lo and behold..... it still doesn't work. So, it's off to Samsung. This handset is 5 weeks old, I don't see why they can't send me a replacement so I don't have to be without a phone for who knows how long.
  16. bonerp

    bonerp Well-Known Member

    takes about 5 days
  17. GiggityGiggity

    GiggityGiggity Well-Known Member

    :( This will be the longest time without a mobile phone I've had to deal with since 1996.
  18. SLRdude

    SLRdude Well-Known Member

    I had the same problem after installing the update a couple of months ago or so. Nothing fixed it... Had to a warranty exchange.
  19. NeoGrandizer

    NeoGrandizer Well-Known Member

    Did you apply the 4.1.2 update on the exchanged unit? Does it work properly? It'll be interesting to know. Might indicate unit was already defective since day 1 and the update exposed this critical flaw.

    Almost similar to the original ICS update for the original Note. Totally messed up the GPS on some units.
  20. bugpack6

    bugpack6 Active Member

    Does anyone know if Samsung is aware of this and will they do an update to fix the wifi issues?????
  21. GiggityGiggity

    GiggityGiggity Well-Known Member

    Hey all. Thought I'd post a follow up in case anyone is interested. I posted my phone to Samsung on Fri 1st March and got it back Weds 6th March. They included a letter letting me know what they did. They've replaced the mainboard (the phone was only 5 weeks old!), so I can only assume that although wifi stopped working after I installed the 4.1.2 upgrade, the upgrade itself wasn't the cause of it failing.

    As I said in an earlier post after I did the upgrade the phone wifi wouldn't connect to anything so eventually I pulled the battery and rebooted and it started working fine. It also worked the following day first thing, then later that morning it stopped working completely. I can only assume it would have failed whether I'd done the upgrade or not, but I'm still not convinced the upgrade didn't play a part in it.

    Either way I have my phone back and it's working fine. Nice work Samsung for repairing it so quickly. I have to say though, it's staggering just how much I missed it when it was away. Never again hopefully. :D
    PiscesCloud and NeoGrandizer like this.
  22. NeoGrandizer

    NeoGrandizer Well-Known Member

    I'm glad to hear all is in working order. As I have stated, sometimes an update will expose the flaw in the device. It's unfortunate, but it does happen. I guess the bright side of this is that it happened earlier, rather than later. While you're still within your warranty period.

    Thanks for the update. :)
  23. BetaMan

    BetaMan Well-Known Member

    I've been having the same problem since the update. I called Verizon and they are sending me out a replacement and should have it tomorrow. Hope it doesn't have the same problem. I use WiFi all the time.
  24. BetaMan

    BetaMan Well-Known Member

    Well, an update. I got the replacement and it did an over-the-air update to the current Verizon ROM. I then checked WiFi and it was STRONG and worked PERFECTLY!

    I then rooted the phone and tried it again. Works PERFECTLY! WiFi tether works GREAT as well! Clearly, it must've been the phone! I've been on the replacement phone for 2 days and it works absolutely great! I'm in a hotel right now connected to my Note2 via WiFi tether and it is working the way it is SUPPOSED to! (I'm still on unlimited data because I bought the phone at full price!)

    Just thought I'd share my experience in the hopes that it will help someone having the same problem that I was!
    NeoGrandizer likes this.

Share This Page