1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

4.2.1 Update Discussion for rooted users


Last Updated:

  1. mkvoran

    mkvoran Well-Known Member This Topic's Starter

    Joined:
    Jul 20, 2011
    Messages:
    89
    Likes Received:
    32
    Got notified of OTA, I am rooted and unlocked. I downloaded and installed, CW mod kicked in and asked if I wanted to install the 'untrusted package' I said yes. Install seemed to go smooth, but still showing 4.2 and OTA not an option now. Not a big deal but now do I have to side load?
     

    Advertisement
  2. skelms

    skelms Well-Known Member

    Joined:
    Aug 23, 2012
    Messages:
    89
    Likes Received:
    11
    I'm guessing this shouldn't affect bunches of apps making them incompatible since it's a small update. Please post if the new update screws anything up. I'll update later when I time to root againif ota root keeper doesn't work
     
  3. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    Joined:
    Aug 30, 2011
    Messages:
    17,885
    Likes Received:
    13,071
    I haven't gotten a chance to go through the update yet. I'll download it now and look through the script

    Err- I read that completely wrong.


    No, there shouldnt be any new app incompatibilities with this update
     
  4. Modman

    Modman Well-Known Member

    Joined:
    May 31, 2011
    Messages:
    538
    Likes Received:
    37
    Gonna block it till I know its safe.
    Can it be rerooted?
    Does ota root keeper work with it?
    Any issues with stick mount or other apps?
     
  5. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    Joined:
    Aug 30, 2011
    Messages:
    17,885
    Likes Received:
    13,071
    There should not be any new app incompatibilites, its pretty much just fixing the people-calendar issues.

    It is rootable. This is a nexus device, it will always be rootable :p

    I'm going to move all root-related posts to the ATR section
     
  6. GamerKingFaiz

    GamerKingFaiz Member

    Joined:
    Nov 11, 2012
    Messages:
    7
    Likes Received:
    1
    I updated manually using TWRP and now I've lost my root but I am running 4.2.1 successfully.

    I had OTA RootKeeper installed, so I'm not sure why it didn't keep root. Root stayed fine when I had updated from 4.1.2 to 4.2 with CWM and OTA Root Keeper. Maybe it was TWRP's fault, it didn't ask me to save root like CWM did.

    Can I simply get root back by running my Nexus 7 through the root procedure in the 3.2.0 version of the Nexus 7 Toolkit?

    Or do I have to wait for it to be updated?
     
  7. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    Joined:
    Aug 30, 2011
    Messages:
    17,885
    Likes Received:
    13,071
    Select the any build/version number option in wugs toolkit under nexus 7 and you'll be good to go.
     
    GamerKingFaiz likes this.
  8. GamerKingFaiz

    GamerKingFaiz Member

    Joined:
    Nov 11, 2012
    Messages:
    7
    Likes Received:
    1
    Worked like a charm, thanks! :D
     
    Rxpert83 likes this.
  9. alittle

    alittle Well-Known Member

    Joined:
    Mar 10, 2012
    Messages:
    302
    Likes Received:
    40
    If anybody wants to keep root and update to 4.2.1 then flash paranoid android, the latest version ( 2.99 beta 5) is based off 4.2.1
    I believe they are working out bugs though. I updated through goo and ran into force close hell.
     
  10. costarican

    costarican Well-Known Member

    Joined:
    May 28, 2012
    Messages:
    510
    Likes Received:
    25
    If Im running a stock ROM 4.2 rooted do I have to go back to the regular stock to update?
     
  11. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    Joined:
    Aug 30, 2011
    Messages:
    17,885
    Likes Received:
    13,071
    Nope. Worst case scenario youll have to reroot after the update, but that takes only 2 mins with wugs toolkit
     
  12. costarican

    costarican Well-Known Member

    Joined:
    May 28, 2012
    Messages:
    510
    Likes Received:
    25
    I just checked and there's no update 4.2.1 :(
     
  13. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    Joined:
    Aug 30, 2011
    Messages:
    17,885
    Likes Received:
    13,071
    Give it time.This is not an important update, I wouldn't worry about it too much
     
  14. Modman

    Modman Well-Known Member

    Joined:
    May 31, 2011
    Messages:
    538
    Likes Received:
    37
    Has anyone done it correctly opening ota app hiding root then take ota?
     
  15. costarican

    costarican Well-Known Member

    Joined:
    May 28, 2012
    Messages:
    510
    Likes Received:
    25
    Just got it
     
  16. Groid

    Groid Well-Known Member

    Joined:
    Dec 1, 2009
    Messages:
    358
    Likes Received:
    88
    My N7 is rooted, stock rom, cwm recovery, voodoo ota rootkeeper, supersu. I d/l the update from Droid Life and copied it from my computer to the N7 internal storage. Booted into cwm recovery, chose to install zip from sdcard, chose the d/l'd file from the /0 folder (filename 659e6288b....zip), chose to reboot system, answered 'Yes' to preventing flashing stock recovery, answered 'Yes' to keeping root. All is good. Still have root and cwm recovery.
     
  17. palmtree5

    palmtree5 Sunny Vacation Supporter! Moderator

    Joined:
    May 2, 2012
    Messages:
    4,346
    Likes Received:
    2,799
    Got it this afternoon, it broke root so I tried to reboot to recovery (TWRP) but it was stock recovery. Reflashed TWRP with fastboot and flashed SuperSU, Busybox, and the permanent recovery fix (all from the toolkit). Done and working
     
    Rxpert83 likes this.
  18. Modman

    Modman Well-Known Member

    Joined:
    May 31, 2011
    Messages:
    538
    Likes Received:
    37
    Then do the official ota and what were the results? Retained root yes? Or no? If not then rerooting with root kit is necessary. Maybe an annoyance. So far I've done all otas but trying to decide whether or not to sit this one out.
     
  19. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    Joined:
    Aug 30, 2011
    Messages:
    17,885
    Likes Received:
    13,071
    Why would you sit it out?
     
  20. sleezecheeze

    sleezecheeze Well-Known Member

    Joined:
    Jul 20, 2012
    Messages:
    143
    Likes Received:
    14
    I still haven't got root back since the first update (4.1.1?). Lost root after absently updating without considering loosing root. So I couldn't get it back after the update it was practically stuck at half root.

    The new update is terrible imo, The new lock keypad is less professional than before and the clock is kind of weird.
     
  21. Modman

    Modman Well-Known Member

    Joined:
    May 31, 2011
    Messages:
    538
    Likes Received:
    37
    Even though its doable with rootkit I have better things to do then spend two hours rerooting. How so is 4.2.1 keyboard less professional? Even if I sit it out ill eventually have to face the music.
     
  22. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    Joined:
    Aug 30, 2011
    Messages:
    17,885
    Likes Received:
    13,071
    Did you rerun the toolkit? That's all you have to do

    The only real difference between 4.2 amd 4.2.1 is the December bug patch.

    Rerooting takes less than 5 minutes
     
  23. Modman

    Modman Well-Known Member

    Joined:
    May 31, 2011
    Messages:
    538
    Likes Received:
    37
    Cause the nexus root toolkit wouldn't connect right away
     
  24. ukbigd

    ukbigd Member

    Joined:
    Mar 28, 2011
    Messages:
    5
    Likes Received:
    0
    I am a noobie, But found the biggist mistake I have made is to let it upgrade to 4.2.1 I have now lost root, And I have tried using nexus root toolkit 1.60 and it cannot or will not root, Nexus root toolkit has no 4.2.1 as a choice of model to root and when I try the Android ##any it does nothing, I cannot put a custom recovery on tried cwm and twm neither will work (might be because its not rooted) will wait to see if nexus root toolkit 1.61 comes out soon.
     
  25. Rxpert83

    Rxpert83 Dr. Feelgood Moderator

    Joined:
    Aug 30, 2011
    Messages:
    17,885
    Likes Received:
    13,071
    Any version should work just fine, so I'm not sure what the issue is there. Your sure you are in the nexus 7 selections?

    You can always manually install the recovery and push su files. Nexus devices are ALWAYS rootable.
     

Share This Page

Loading...