4.2.1 update stuck on "rebooting now" on System Update screen


Last Updated:

  1. The_Superhoo

    The_Superhoo Well-Known Member

    Finally stopped kicking this can down the road. The 4.2.1 update wouldnt work for me, presumably because I rooted using the Toolkit back when it had the bad image from Google. I updated the Toolkit today and reflashed using Google's supplied image.

    Now, when I go to settings and check for updates, the normal 4.2.1 update screen comes up and I click "restart and install" it doesnt work. It says "rebooting to install" with a countdown, but never does. It stays on that screen forever if I keep the screen awake. If I let the screen turn off, when I unlock the screen it's back at "reboot and install" button like nothing happened.

    What should I do?

    Advertisement
  2. Atma

    Atma Well-Known Member

    Are you rooted or changed any system files? If so, I don't know what to suggest except use the tookit to reinstall the stock and update before doing anything else. You might also try a factory reset first and see if that helps. I'm not sure why it is hanging like that.
  3. The_Superhoo

    The_Superhoo Well-Known Member

    I'm rooted and unlocked. Did so with the Toolkit originally, but as I said that was back when Google had the bad image for 4.2.0 that wouldnt accept the OTA. (it would begin updating and then give me an error message and crap out)

    I re-flashed the stock image just now (and cleared cache) and now it behaves as I said in the OP. I guess I'll try factory reset
  4. The_Superhoo

    The_Superhoo Well-Known Member

    Factory reset accomplished, it then restarted the tab when I clicked "restart and install" but then I get the "Error!" android.

    Here's what it says in recovery:

    Finding update package...
    Opening update package...
    Verifying update package...
    Installing update...
    Verifying current system...
    Removing unneeded files...
    Patching system files...
    Unpacking new recovery...
    Symlinks and permissions...
    set_perm: some changes failed
    Installation aborted.
  5. The_Superhoo

    The_Superhoo Well-Known Member

    Just wiped and redid the One Touch all-in-one option using the Toolkit.

    Now when I try to install the OTA, it takes me to CWM Recovery where it says:

    E: failed to verfy whole-file signature
    E: signature verification failed

    It asked if i wanted to install from untrusted zip. As it came from google's servers, I said yes. Afterwards it said the same stuff as in my immediately above post except the end was:

    set_perm: some changes failed
    E: Error in /cache/07ac4f5d6c30.signed-mantaray - JOP40D- from- JOP40C.07ac4f5d.zip
    (Status 7)
    Installation aborted.
  6. The_Superhoo

    The_Superhoo Well-Known Member

    Ok now I'm not sure if it worked or not. Restarted after the above, and when i click "check now" for updates. it says I'm up to date. But the Build Number still shows JOP40C not JOP40D (the update)
  7. Atma

    Atma Well-Known Member

    I'm not at home to check mine but I would think it should say JOP40D.

    Have you tried downloading JOP40C again direct from Google and using the toolkit to flash it? Some of the errors your getting sounds like the problem with the buggy build. Read through this thread. Maybe it will help.
  8. The_Superhoo

    The_Superhoo Well-Known Member

    Where did December used to not exist? I can check that and see if it's there.
  9. Atma

    Atma Well-Known Member

    It was C, 4.2. I think all the update to D, 4.2.1, did was add December.
  10. Atma

    Atma Well-Known Member

    Yeah, mine says D. Do you have a custom recovery installed? I was just reading a custom recovery won't install an OTA. Use option 6 in the Nexus 10 toolkit and select stock recovery.
  11. The_Superhoo

    The_Superhoo Well-Known Member

    Yes I have CWM recovery. But tried it before with stock recovery. Weird. It says I'm up to date when I try to check for updates now, even tho it says it's build C. Odd. Will try some more stuff after the weekend
  12. The_Superhoo

    The_Superhoo Well-Known Member

    As of yesterday it started telling me I wasnt up to date (though it said it WAS for a few days after the above stuff I did.) So I need to fix this issue still...

    Will try with stock recovery using tool...


    *EDIT* Flashed stock recovery, but again when i go to check for updates, it says I'm up to date. Even tho I'm not. WTH?

    *EDIT 2* Cleared google services framework and forced a check for update again. Found it. Trying to install.... "Error!" then when I reboot it it goes to "No command." again, where I can input recovery commands and reboot it, but no update. Sigh.

    *EDIT 3* I used the Tool to unroot and still get "Error!" followed by "No command" in recovery as above. Now trying relocking the bootloader as well.... "Error!" again. WTF am I doing wrong?

    *EDIT 4* Ok this is the last thing I can think to try. I'm factory wiping it, ensuring it's both locked and unrooted, and THEN trying to apply update...

    *EDIT 5* Alright, I factory wiped it. Wiped the cache, unrooted and locked it, and STILL get an error. WTF.
  13. The_Superhoo

    The_Superhoo Well-Known Member

    Any other ideas of what to do? Am I doing something wrong?
  14. Atma

    Atma Well-Known Member


    That's the only thing I had left to suggest was relock the bootloader and try it. Did you use the toolkit to reinstall the stock rom and then lock the bootloader or just do a factory reset and lock it? If you installed stock and then relocked I'm out of ideas. It may be time to call Google and see if they can help.
  15. The_Superhoo

    The_Superhoo Well-Known Member

    I unrooted, installed stock using both the download function in the Toolkit AND using the file I got myself from Google, relocked the bootloader, and did factory resets.

    Same error.

    Google has a 4.2.1 image available for Nexus 7, why not for Nexus 10????
  16. Atma

    Atma Well-Known Member


    Beats me. I guess because it was so small and mainly for the December calender.

    Try this and see if it helps.

    Power off then press the power button for seven seconds until your tablet reboots. Then press and hold both the volume up and down keys until you see the words
  17. The_Superhoo

    The_Superhoo Well-Known Member

    I tried safe mode just now. Same error. :-/ Wish I could find the app they mentioned in that link you posted.
  18. Atma

    Atma Well-Known Member


    I see you found the app and it didn't help. I just don't know buddy. If you get time, call Google. Since you aren't the only one having a problem maybe its something on their end.
  19. The_Superhoo

    The_Superhoo Well-Known Member

    Still haven't been able to fix it. Guess I'll call Google. Been too busy lately but will try this week

    Why don't they just release a danged image for it? They did for N7....

Share This Page