4.2 and Amazon App StoreSupport


Last Updated:

  1. regression

    regression Well-Known Member This Topic's Starter

    Joined:
    Nov 10, 2009
    Messages:
    1,017
    Likes Received:
    126
    I received the 4.2 upgrade today. However, I keep having to sign into the Amazon App Store. Even if I am using an app I purchased (free app of the day), it will tell me I need to log in to Amazon first. It seems something in the 4.2 upgrade broke the app's ability to stay signed in.

    Has anyone else seen this?
     

    Advertisement
  2. PortNerd

    PortNerd Active Member

    Joined:
    Nov 13, 2012
    Messages:
    29
    Likes Received:
    0
    I am seeing the same thing.
     
  3. regression

    regression Well-Known Member This Topic's Starter

    Joined:
    Nov 10, 2009
    Messages:
    1,017
    Likes Received:
    126
    I sent an email to Amazon support. Hopefully the issue gets fixed soon.
     
  4. jwseris

    jwseris New Member

    Joined:
    Jun 9, 2010
    Messages:
    4
    Likes Received:
    0
    Same thing happening on my Wife's Galaxy Nexus.
     
  5. tcat007

    tcat007 Well-Known Member

    Joined:
    Jan 31, 2011
    Messages:
    1,722
    Likes Received:
    262
    This is the only thing about 4.2 I don't like and is VERY annoying. It also clicks on "in app purchases" every time before you enter the PW again... check its settings.

    And if you look at your devices on a PC, you'll see you have several Nexus 7's... I had 7 of them! (until I deleted all but one)
     
  6. regression

    regression Well-Known Member This Topic's Starter

    Joined:
    Nov 10, 2009
    Messages:
    1,017
    Likes Received:
    126
    I just got off the phone with Amazon support. They said their developers were alerted to the issue today. It wouldn't hurt for others to call. If a lot of people call hopefully it will bump up the priority of getting it fixed.

    The phone number to Amazon support is: 866-749-7771
     
  7. Bexy

    Bexy Well-Known Member

    Joined:
    Jul 1, 2010
    Messages:
    292
    Likes Received:
    50
    Definitely very annoying. I (and my partner) downgraded back to 4.1.2 because of this. Other stuff we decided we could both live with, even some apps not working but, as we both use apps we got from Amazon and check it daily, having to log in just to use an app we downloaded was super irritating.
     
  8. tcat007

    tcat007 Well-Known Member

    Joined:
    Jan 31, 2011
    Messages:
    1,722
    Likes Received:
    262
    I hear Amazon did this to piss off Google owners, so they'd buy more Kindle Fires :D. Amazon has little incentive to fix this. It definitely is the biggest issue for me with 4.2!
     
  9. sloheim

    sloheim Well-Known Member

    Joined:
    Sep 10, 2010
    Messages:
    133
    Likes Received:
    27
    I'm guessing that isn't even remotely true... but if it is, I have a feeling they'll be losing a lot more non-Kindle business than they'll be gaining via offsetting Kindle sales.
     
  10. mattmchackit

    mattmchackit New Member

    Joined:
    Nov 17, 2012
    Messages:
    1
    Likes Received:
    0
    I had this problem. It is easily solved by re-installing the Amazon Appstore using the apk from Amazon's website after installing the 4.2 update and rebooting. Once the app is re-installed, run it once and enter username and password. Bingo! Everything works again and you won't have to keep re-entering your details. Hope this helps :)
     
  11. regression

    regression Well-Known Member This Topic's Starter

    Joined:
    Nov 10, 2009
    Messages:
    1,017
    Likes Received:
    126
    This didn't work for me. After un-installing, reinstalling and rebooting, I still have the sign in problem. Glad it worked for you.
     
  12. skelms

    skelms Well-Known Member

    Joined:
    Aug 23, 2012
    Messages:
    89
    Likes Received:
    11
    Same for me. I even redownloaded the Amazon app from the website the second time I uninstalled and reinstalled. Still no success. Please post if this gets resolved. I might have to revert to 4.1.2. Very annoying
     
  13. jhsrennie

    jhsrennie Well-Known Member

    Joined:
    Jul 31, 2012
    Messages:
    310
    Likes Received:
    65
    The Amazon app works here, but I did a factory reset before the 4.2 update so the app was installed on a clean system.
     
    Rxpert83 likes this.
  14. chalky378

    chalky378 Active Member

    Joined:
    Feb 5, 2011
    Messages:
    30
    Likes Received:
    2
    I tried un installing and reinstalling it but still get the log out ad well so it's a no go for me and it's a real pain
     
  15. Hoosiermama

    Hoosiermama Well-Known Member

    Joined:
    Nov 24, 2010
    Messages:
    158
    Likes Received:
    21
    I was getting the sign in request, but it stopped a few days ago. Odd that it is behaving differently for different people.
     
  16. Unforgiven

    Unforgiven -.. --- - / -.. .- ... .... Moderator

    Joined:
    Jun 23, 2010
    Messages:
    31,565
    Likes Received:
    28,338
    I have this same problem. There is a temporary solution that I got from a chat with Amazon support.

    Log into Amazon.com in a browser. Mouse over your profile in the top right and at the bottom of the pop up menu choose "Your Android Apps & Devices." On the lext screen on to top left choose "Your Devices" in the Manage box. I had multiple versions of the same device registered (a new one each day since the 4.2 release) for a total of 40+ devices.

    On the right of each device is an actions button. Choose Deregister device on all of your devices, then sign back into Amazon app store and all of your apps will work again.
     
  17. tcat007

    tcat007 Well-Known Member

    Joined:
    Jan 31, 2011
    Messages:
    1,722
    Likes Received:
    262
    That doesn't work (for me). I've deleted all Nexus 7 devices 2 or 3 times (9 once, 5 once, 4 once...), when you log in it adds a new device. I lose the log-in within 30 minutes and then a new device is added. None of the log-ins "stick". :(

     
  18. Unforgiven

    Unforgiven -.. --- - / -.. .- ... .... Moderator

    Joined:
    Jun 23, 2010
    Messages:
    31,565
    Likes Received:
    28,338
    The first time I only deleted what I thought were the extra ones and it only took for a day. I then deleted everything and it seems to be working OK now. I'll let you know if it kicks me out again.
     
  19. tcat007

    tcat007 Well-Known Member

    Joined:
    Jan 31, 2011
    Messages:
    1,722
    Likes Received:
    262
    I read on another forum that rolling back appstore to this apk will temporarily solve the problem (until they fix it). I've gone about 30 minutes so far with wifi on and off, and so far log-in has stuck. I deleted all registered Nexus devices on my PC and deleted the Appstore on my N7 first. Downloaded the apk to Dropbox to my N7 download folder, and installed. Going to diner, if still logged in after, I'll report.
     
    chalky378 likes this.
  20. regression

    regression Well-Known Member This Topic's Starter

    Joined:
    Nov 10, 2009
    Messages:
    1,017
    Likes Received:
    126
    Do you have a link to an apk of a prior version of the Amazon Appstore?
     
  21. tcat007

    tcat007 Well-Known Member

    Joined:
    Jan 31, 2011
    Messages:
    1,722
    Likes Received:
    262
    the word "this" is a link.

    Also still logged in after 1.5 hours!
     
  22. regression

    regression Well-Known Member This Topic's Starter

    Joined:
    Nov 10, 2009
    Messages:
    1,017
    Likes Received:
    126
    Ah, missed it, thanks.
     
  23. Cedrickit

    Cedrickit New Member

    Joined:
    Nov 19, 2012
    Messages:
    1
    Likes Received:
    0
    I called and the they said that they are working on the issue.

    please call them!!! 866-749-7771


     
  24. sparksd

    sparksd Well-Known Member

    Joined:
    Jun 18, 2012
    Messages:
    145
    Likes Received:
    35
    This appears to be a winner - I've been logged on for over 2 hours and it held through a reboot.

    Dave
     
  25. fareal

    fareal Active Member

    Joined:
    Oct 18, 2010
    Messages:
    43
    Likes Received:
    3
    Which forum are they discussing this other version?
     

Share This Page

Loading...