Support 4.3 Upgrade Samsung Security Issue


  1. Goodspike

    Goodspike Well-Known Member

    Are we talking about the message that says you need to update your security policy? If so, why not just update it by pressing the link? I did that on the wife's phone last night.
  2. OstrichSaK

    OstrichSaK Well-Known Member

    For me..

    ..is one example.


  3. It works with my home WiFi, but not the corperate WiFi here at my office, and i spend most of my time here and its basically vital that I use their internet instead of my data.... I just did a FDR and its the same thing..... so I lost everything I had on my phone for NOTHING. Very pissed to say the least...
  4. Goodspike

    Goodspike Well-Known Member

    From a prior post you said the popups are gone, and that it's now just a connection problem. Have you tried deleting your work network connection and creating a new one?
  5. BigRedGonzo

    BigRedGonzo Well-Known Member

    I did that on my phone also, the first 642 times the friggin thing popped up. Every time I connected to a WiFi network, I would get the pop up. Not just one time per network, but every time. In other words, every time I walked in the door at home I would have "Update" the security policy. After the FDR, I haven't had the pop up at all, not one time. I would also get it for every update or install I made from the play store. It was driving me insane.
  6. GrouchoM

    GrouchoM Well-Known Member

    Have you done a soft reset since the FDR? My warning went away on its own after ~18 hours. Five days later, I did a system restart and I got the warnings a few more times.
  7. mcllcu

    mcllcu Member

    I have a similar situation... The message is lightly different: "An application has been forced to stop for an unauthorized attempt to access system in your device" and the WiFi is working.. But everytime I turn on or off the WiFi, I've got a new message...
  8. BigRedGonzo

    BigRedGonzo Well-Known Member

    Yes, I did several soft resets and the problem always came back within minutes of the reset.

    I was getting those messages also. I was also getting messages each and every time I installed/updated any item from the Play Store.
  9. mcllcu

    mcllcu Member

    Nothing to do... Samsung Facebook support kick my ass... Just because mine is not an U.S. device....
  10. OstrichSaK

    OstrichSaK Well-Known Member

    I was sick of getting the pop-up every time I connected to my home WiFi so I finally selected the option other than Cancel on the pop-up (update I think) and it hasn't returned. Not sure if I sent my WiFi security credentials to Samsung or Google or what but I'm not comfortable being forced to do this. I do NOT want to share my SSID & password with other users and I know this is the big push these days from Google.
  11. Goodspike

    Goodspike Well-Known Member

    Have you seen any indication this has anything to do with sending your SSID and password anywhere?

    One way to test for that would be to change both and see if the message starts reappearing. I would be surprised if it does.
  12. Darnell0216

    Darnell0216 Well-Known Member

    Knox is annoying. I tried to restore my old Voicemail data and it now force closes it and my launcher in one swoop while displaying the security warning (Note, I already FDR'd). When it takes deliberate action, it will say what the app is instead of the vague one from the screenshot. I am getting random popups of the vague kind now, possibly Voicemail trying to check in the background. I'm going to eventually clear the restored data to see if it stops.

    It also blocks apps that attempt root access even if they have SU permission. Talk about invasive... I can't modify Settings.db for the HotSpot mod, at least not with SQLite Editor.
  13. OstrichSaK

    OstrichSaK Well-Known Member

    I don't have any indication but at some level it has to save your network as trusted and how does it do this? GPS? Nope, GPS never came on. I've seen some Google products you install talk of sending a SSID & password as a trusted network to the Google data farm and this settings DEFAULTS to yes. To me this is just wrong. It's one thing if it's a public network but I don't need anyone having access to my SSID & password as well as GPS coordinates. I digress. While I have no proof that KNOX is doing this I also have zero confidence that they're not when they're forcing all these other securities onto my device that I didn't request and sure as hell don't want. I know nothing about it or it's track record or history. All I know is I'm being forced to run security provisions I don't want on a device I paid for with my own money on a service I pay for and on a network that I pay for and maintain. I didn't have a reason to root my device for about the first time in the years I've owned Android devices.... until now.
  14. drobs13

    drobs13 New Member

    I had a similar issue today after the update just last night, with my employers WiFi, when I tried to connect it said that the wifi was "unstable" and that it would auto switch to mobile networks. A second later I was back on 4G. To correct this I went into the Settings Menu, then WiFi, then press the menu soft key and press Advanced. Unchecked the box to "Auto network switch". This has fixed the issue and I stay connected to my works wifi now. What remains to be seen is whether or not it will still jump back on 4G if I go out of range of the wifi.

    I know this doesn't sound exactly like the issue you're having, but thought it might be worth a shot.

    Edit: Just tested and confirmed that the phone does still switch back to 4G when out of range of wifi. It also reconnected to wifi once back in range.
    bls and valorian like this.
  15. Darnell0216

    Darnell0216 Well-Known Member

    That was a feature before the update ;). But it's nice to point out for those who may have been unaware.
  16. AeolianReflex

    AeolianReflex Well-Known Member

    This thread is a bit confusing in that I can't tell which poster is having problems because they DIDN'T activate the security policy or if they are having problems because they DID activate the security policy or if they are having the same problems before and after activating it.

    I haven't activated the policy and so far I'm only getting the warning when I connect to my WiFi and no other issues beyond that. It's a minor annoyance at this point. Question is, what problems if any should one expect if the security policy is applied?

    So is everyone just upset about perceived privacy issues or are there hard facts that apps don't run and data won't transmit, etc? Does applying the security policy allow the user to ferret out apps perceived by Knox as nefarious or is do you just get more of the generic messages about a security breach?
  17. Darnell0216

    Darnell0216 Well-Known Member

    The security policy (Knox) is active the minute you install 4.3. There's just an update available that can be downloaded (Version 012). It's not likely to fix any issues with individual apps, but it shouldn't hurt you to download it. At this point it's just another antivirus layer to me.

    Several forums are confirming issues with WiFi (usually work WiFi) not being allowed to connect because of Knox. I haven't had any trouble connecting to my home WiFi, but won't know if my work's system will piss it off until the weekend. It could be something with the type of connection (AES/TKIP/etc) or another glitch for the non-FDR'd. No one has gone into enough detail about that yet.

    And for the record, Google states in the backup notice that WiFi passwords are saved to the cloud as part of your phone's settings and has been doing so for a couple years. You'd have to turn off My Data backup to stop that (Settings -> Accounts -> Backup and reset -> Back up my data). It's brought my saved connections from device to device to device and I haven't a single complaint about it.
    AeolianReflex likes this.
  18. hansangb

    hansangb Well-Known Member

    I did the FDR about 10 days ago. Went the entire time w/o any security notices. But this morning, I got the "security notice" :(
  19. Goodspike

    Goodspike Well-Known Member

    I applied it and have not had any issues.
  20. Goodspike

    Goodspike Well-Known Member

    Correct, and that should have been obvious to anyone owning an S4 that previously owned another Android device and set up the phone with the same gmail account. So it might come as a surprise to someone coming from an Apple, BB, Windows or Palm device, but I would imagine they are in the minority.
  21. Goodspike

    Goodspike Well-Known Member

    I'm afraid this forum is becoming a place where the advice is too frequently given to do an FDR, sort of like how some tech support lines ask you to do meaningless things to your desktop that take a lot of time just in the hope that it might somehow fix your problem (e.g. uninstall and re-install their program).
  22. bls

    bls Well-Known Member

    Thanks for posting this! Like some other users, this feature kept sending me notifications that my home wifi bandwidth was too slow and would switch me to cellular data. Small problem: even my uneven home wifi bandwidth was far better than my nearly nonexistent cell signal!

    But until I read your post, I wasn't clear where the advanced wi-fi settings were; I'm not used to having to hit the Menu button inside the actual settings UI. I hope this fixes the problem.

    Now to sort out whether I really want the security software blocking my apps. Is there any way to get that feature to actually tell you which apps were blocked? Haven't found a way to do that yet.
  23. tim1989

    tim1989 Well-Known Member

    Regrettably I installed this update this morning. I have had constant security update, battery drain (possibly from the security app) and a lot of lagging. If I type a text it will freeze for a couple of seconds, and sometimes continues to say I have an unread text after I opened it.

    Although you cannot uninstall you can disable the app
  24. OstrichSaK

    OstrichSaK Well-Known Member

    How? All I see is options to Force Stop but this doesn't keep it from re-activating. How do we disable to never worry about again?

    I will honestly think twice before buying another Samsung smartphone after this.
  25. tim1989

    tim1989 Well-Known Member

    You go into the application manager, find lookout and there is an option to disable it.

    I thought it had worked, but no the pop ups keep coming! Is anyone experiencing lag at all since the update?

Share This Page