4g scans, tries to connect, and then says disconnected. Fix?Support


Last Updated:

  1. pemw2000

    pemw2000 Member This Topic's Starter

    Joined:
    Mar 9, 2013
    Messages:
    12
    Likes Received:
    0
    I recently rooted my phone (flashed Harmonia), however I've been having this issue since before the root. I've tried all the basic fixes (reboot, pull battery, update prl, update profile) but nothing has been working. From what I have read it could possibly be my MAC address (which I don't know how to gain access to). I would take it in but my warranty is void, and the people at my radioshack are completely useless. Any advice is appreciated. Thanks!!!!
     

    Advertisement
  2. jose224

    jose224 Well-Known Member

    Joined:
    Dec 30, 2012
    Messages:
    141
    Likes Received:
    13
    Try to revert to stock from get virgin mobile to provision it and then report back what happens
     
  3. newevouservm

    newevouservm Well-Known Member

    Joined:
    Feb 9, 2013
    Messages:
    57
    Likes Received:
    2
    Mines been working perfectly for the past few days and now mine isn't connecting.
     
  4. pemw2000

    pemw2000 Member This Topic's Starter

    Joined:
    Mar 9, 2013
    Messages:
    12
    Likes Received:
    0
    Reverted to stock, did a factory reset, nothing changed
     
  5. jose224

    jose224 Well-Known Member

    Joined:
    Dec 30, 2012
    Messages:
    141
    Likes Received:
    13
    Did you calling VM and ask them to provision your service and phone
     
  6. OverByter

    OverByter Resident Slide Rule Guru

    Joined:
    Dec 12, 2010
    Messages:
    4,000
    Likes Received:
    921
    Have you ever had 4G?
    OB
     
  7. magohn

    magohn Well-Known Member

    Joined:
    Dec 15, 2010
    Messages:
    519
    Likes Received:
    42
    I had the exact same thing until recently. For 4 weeks, constant unsuccessful scanning of 4g. I called VM, tried different ROMS, radios, all to no avail. Then last week I picked up my phone and a message stated "Network Update Complete". 4g was back and its been great since.

    The VM CSRs were useless. Had no idea there was a network update pending in my area.
     

Share This Page

Loading...