4g slow speed

Discussion in 'T-Mobile' started by whatsitsname, Aug 3, 2012.

  1. whatsitsname

    whatsitsname Well-Known Member
    53

    Jun 5, 2010
    320
    68
    53
    I have a new Galaxy s3. Most times when it shows 4g I get subpar speeds in the .04 to .2 mbps range. Its about the same speed when my phone is on the edge network. Only a few times have I gotten 5 to 10 mbps range while on the 4g network. I get full signal bars when doing these test.
    I'm on the $30 5gb monthly unlimited data plan which I just activated last night so it can't be throttled already.

    I'm new to t-mobile but isn't the speed suppose to be fast when connected to 4g or am I reading my galaxy s3 wrong?
     

    Advertisement
  2. LoyalServant

    LoyalServant Well-Known Member
    163

    May 24, 2010
    1,050
    267
    163
    Male
    Programmer
    Columbia, SC
    Can you show us what your getting?
    Can you tell us the city and state as well if possible?
     
  3. whatsitsname

    whatsitsname Well-Known Member
    53

    Jun 5, 2010
    320
    68
    53
    Sacramento/ Elk Grove, CA
     

    Attached Files:

  4. LoyalServant

    LoyalServant Well-Known Member
    163

    May 24, 2010
    1,050
    267
    163
    Male
    Programmer
    Columbia, SC
    They look suspect.... the upstream in a lot of those is faster than the downstream.

    Have you tried other servers?
     
  5. whatsitsname

    whatsitsname Well-Known Member
    53

    Jun 5, 2010
    320
    68
    53
    Yes I have tried other servers
     
  6. LoyalServant

    LoyalServant Well-Known Member
    163

    May 24, 2010
    1,050
    267
    163
    Male
    Programmer
    Columbia, SC
    I really am at a loss.
    I have never seen that happen before.

    Hopefully someone else has and know what is going on there.

    Have you tried to talk to support about it?
    I know they don't really like prepaid much but you can try asking the Philippines call center ladies to transfer you to the states.
    They usually will.
     
  7. trife

    trife Well-Known Member
    38

    Dec 14, 2009
    112
    11
    38
    I'm having same issue and thought there was differen't "4g" cause of t-mobiles evasiveness about 4g.

    in wasco 93280 I live outside of town and get about 1mb max. going slightly south towards shafter i'm looking at 20mb.

    is 4g suppose to always be like that? I notice it shifts between hspa 11 or 15 in some cases when looking at status in settings.
     

Share This Page

Loading...