Last Updated:

  1. Scy

    Scy Member

    Hi Forum.

    Yes, it's this old chestnut.

    I realise that this problem is as old as Android itself, but it actually appears to be a bunch of different problems that manifest with the same symptom. I've tried all of the solutions I can find, and none of them seem to work.

    I have an Orange UK branded Desire S that I recently acquired second-hand off eBay. To begin with, everything worked fine, but the phone hadn't been updated in a while so I applied all the OTA updates (3 in total), one after the other. After the first two it was also working fine, but after the third update it stopped connecting to the Orange network.

    When I attempt to connect to the Orange network manually, I get

  2. notebook

    notebook Well-Known Member

    What's the current Software number and Baseband version on your phone?

    Menu > Settings > About phone > Software information
  3. Scy

    Scy Member

    Version 2.3.5, Sense 3.0, software

    Baseband is 20.4801.30.0822U_3822.10.08.04_M
  4. notebook

    notebook Well-Known Member

    All's present and correct there.

    I can only suggest the following to try, if you haven't already.

    Menu > Settings > Wireless & networks > Mobile networks > Network operators > Search networks > Select appropriate network to register the phone. I don't know if this will do anything, but try registering to a non-Orange/T-Mobile network to clear the relevant info on your phone, before registering to Orange.

    The SIM connector/seat could be dirty. Try cleaning it.

    It might be the radio/baseband that's faulty. That could be a hardware or software issue. For the latter (and there's no real way of telling if it is the cause) I'd recommend trying a Gold card first, to see if an earlier HTC European ROM makes a difference. If the former is a possibility, then the only option is a repair, if that's realistic, i.e. it's still under warranty.

    Have you tried calling Orange to see what they say, especially as the phone appears to have been working fine before the update?
  5. Scy

    Scy Member

    Yes, tried the manual network selection, all networks come up with the same error message, 'Your SIM card does not allow a connection to this network'.

    I've tried cleaning the SIM, no luck. I didn't move the SIM between the second and third OTA update, so I doubt it's that.

    I haven't tried contacting Orange yet as I don't know where I stand with the warranty, as I purchased the phone second-hand and I don't have an original proof of purchase. I suppose it's worth contacting them just to see what they say, but I posted here because there may be fixes that Orange would never suggest - like flashing an RUU.

    Speaking of which, do you have a suggestion for which ROM I should flash using the Goldcard method? I can find the instructions for the procedure elsewhere, I just need to make sure I'm not picking a ROM that will brick my phone. This one perhaps?


    Much appreciated.
  6. notebook

    notebook Well-Known Member

    I'd try an early HTC Europe RUU and then the latest one. The early one because your phone worked with the Orange equivalent and the latest because if there was a problem with the installation of the Orange OTA, this will be 'clean', hopefully.



    And the one you mention


    There's also the earlier RUU_Saga_HTC_Europe_1.28.401.1_Radio_20.28b.30.0805U_38.03.02.11_M_release_177977_signed.exe, but if the 1.47 version doesn't work, I don't think this will either - but it might be worth a try when you get the hang of things.

    Here's a good source for RUUs.

    Still worth calling Orange just in case they can do anything on their network, but, yes, they'd never suggest flashing ROMs!
    Scy likes this.
  7. Scy

    Scy Member

    Thanks for your response. I've tried flashing a number of these RUU's, but all fail at the 'updating signature' stage with 'Error [155] Unknown Error'. I've read that this is often because you're using the wrong RUU version for your branded phone, but there are no Orange UK RUUs in the link you provided (thanks for that BTW). So, I found this Orange RUU from another source:


    That didn't work either. Same error. Since then, I've tried installing a custom recovery, followed by a rooted custom ROM (Endymion). Unfortunately, the same problem still exists; 'Your SIM card does not allow a connection to this network'.

    So, I figure I need to try downgrading the radio. If I want to flash a radio from my current HBOOT, I need to gain S-OFF, but Revolutionary won't work with my new HBOOT version. So, it looks like I still need to flash an earlier RUU.

    I've also changed the phone's version number so it's now earlier than the RUU, but still I get the same 'Error [155] Unknown Error' from the RUU.

    Any ideas? Thanks in advance.
  8. Scy

    Scy Member

    I relocked the bootloader and that fixed the error 155 problem. I now have an older original version on the phone, including an older Hboot and an older radio.

    Unfortunately, the same problem still occurs - 'Your SIM card does not allow a connection to this network'. I think I've ruled out just about everything except a hardware issue now. Perhaps an issue with the SIM slot?

    I suspect the phone is out of warranty, so if it is a hardware problem I may be screwed.
  9. notebook

    notebook Well-Known Member

    If you've successfully flashed the ROM/installed a Goldcard, then that effectively rules out a software issue, leaving you with a hardware issue. However, because the fault occured after the update, part of me would cling on to the idea that it is a software issue and could be 'fixed'.

    But it's difficult to know what to try next. It looks like you've already tried making a Goldcard and also tried rooting your phone and installing a custom ROM. I can only suggest doing those again, to make sure everything is installed correctly.

    The only other thing I can think of is to call Orange, if you haven't already done so. Nothing to lose there. And if the phone has become locked, they might be able to unlock it according to your phone's IMEI.

    And there's this link which might add a little bit to what you've tried before re: changing the wireless band, in particular trying the Radio on/off setting.
  10. wolflet

    wolflet New Member

    I had this problem with my new Desire S and eventually discovered that T-mobile had "accidentally" blacklisted the phone before I got it. They undid it and it's fine now.
  11. irjayjay

    irjayjay New Member

    I thought I needed to add this to all the possible forums where this problem is listed.

    I tried the *#*#4636#*#*, removing battery, cleaning contact points, etc. for 4 days straight. Even removing the battery and sim for an hour or so.

    What worked for me I realised was:
    Remove your sim, put it in a different phone and switch that phone on, then remove again and put it back into your android.

    Somehow it seems like the android does not dismount my Simcard whenever I power down my phone, so I still get the error whenever I reset or power down my phone, but I dismount my sim by using another phone.

    I'm hoping someone who knows more about simcards could find these posts and figure out a fix for it permanently.

    Let me know if it worked for you.
  12. Luijo

    Luijo New Member

    How I Fixed Your SIM card does not allow a connection to this network, i have a samsung infuse the phone worked fine for two weeks then I could not make calls, open Internet sites, phone and wifi works perfectly well but does not recognize my SIM Card, i did everything root, unlocked , apgrade ,reset it like stock everything I dont know what i have to do now. i from dominican republic
  13. SirSaavedra

    SirSaavedra New Member

    You can look here. It was the real solution for me. Great work of this guy.

    thewichitacomputerguy dot com

Share This Page