1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

.602 rooted without SBF'g or wiping!


  1. lexluthor

    lexluthor Well-Known Member

    Not sure if anyone noticed this. I linked to it at the bottom of the simple update thread.

    I take no credit for this whatsoever.

    Here's the original discussion as started by user "tadpole" on mydroidworld
    .602 rooted without SBF'g or wiping!

    It worked perfectly for me. Here's the steps I used. So much easier than .sbf'ing and restoring and all of that.

    --
    I was on stock .596, rooted.

    I installed Droid2Bootstrap. Booted into recovery and created a Nandroid. Booted back and unfroze anything I had frozen with Titanium. I did not restore stock Swype. I went to system update on the phone, accepted the updated and chose to install. Phone rebooted and started installing the update. I didn't see that said it completed, but I might have looked away. It definitely just rebooted back to android on it's own, even if it did tell me it completed. As I was rebooting, I did a battery pull. I then put the battery back in and it rebooted into CWM recovery. I installed the superuser .zip file and rebooted again. After a much longer than normal wait, I was back into Android w/version 6.02 and .13p radio. All of my programs and settings fully intact.

    Advertisement
  2. dragonbro

    dragonbro Well-Known Member

    Well, I've tried this 4 times now with no luck :( I can't get the OTA update to install successfully? I'm on rooted .596 stock rom, but for some reason it keeps failing. Oh well, off to SBF I suppose.
  3. ylexot

    ylexot Well-Known Member

    Did you freeze or delete any bloatware? If so, it will fail until you undo what you changed.
  4. dragonbro

    dragonbro Well-Known Member


    Thanks for the idea, but I have not removed or frozen any of the stock apps...nor have I renamed anything.
  5. Wally World

    Wally World Well-Known Member

    Most people can't install the .602 update while on .596 rooted.

    SBF to Froyo, root, bootstrap, two part .602 done deal.
  6. Trooper

    Trooper Well-Known Member

    Yeah but who wants to be on stock? :p
    tom108 likes this.
  7. Wally World

    Wally World Well-Known Member

    Little ol' grannies and soccer moms.
  8. Trooper

    Trooper Well-Known Member

    So you fall into that category eh? ;)
  9. Wally World

    Wally World Well-Known Member

    For a day I did! But I couldn't stand the taste of Ensure. Back to root for me. :D
  10. Trooper

    Trooper Well-Known Member

    Haha!

    I liked the new blur for awhile when it first came out, but then was like meh. Cant go back!
  11. FragDroidX

    FragDroidX Well-Known Member

    Thanks for the post, nice to have options for this type of thing. That being said this seems a bit "Mickey Mouse" for me as we say around these here parts. :)
  12. Wally World

    Wally World Well-Known Member

    Yeah, after finally giving Go Launcher EX a try I am hooked and can't imagine going back to blur launcher.
  13. Pushwall

    Pushwall Well-Known Member

    Just tried this easy method and it took all of 15-20 minutes. I almost missed the system rebooting after the 602 update so I could install the su zip file.The longest part of the entire process was the final reboot but it all worked! Thanks lexluthor for the info! :cool:
  14. Dcodesdlx

    Dcodesdlx New Member

    OP directions worked for me, no issues. Came from stock .596 rooted and deodexed. I did NOT unfreeze any apps or bloatware with TiBU.

    I read Tadpoles instructions on mydroidworld for this which have a different battery pull point and I was a bit confused when to pull the battery. So what I did was take the OTA update and after the update screen finished (little droid guy hopping out of the box) and the phone was rebooting, I pulled the battery when the droid eye came up. This got me to CWR and I installed the su zip and then rebooted. Now rooted with .602 and 13p!
    WishinItWas likes this.
  15. lexluthor

    lexluthor Well-Known Member

    I don't think it's different than where you and I both did the battery pull. I think he just worded it differently.

    He says "take the official 602 update and let it install
    *once it finishes rebooting and you get the install was ok message pull the battery out while droidx is still powered on"

    If you do the official update from within .596, the phone reboots immediately and then installs the update. You pull the battery after the install is done and before it boots back up.

    I don't recall seeing a message saying the install was complete though. It just rebooted right away for me.
  16. KX4SAM

    KX4SAM Well-Known Member

    I had the tow part .596 rooted, accepted the 602 update this morning, now have un-rooted .602

    Two part 602 available?
  17. dirtmouth

    dirtmouth Well-Known Member

    I have deleted some stock apps and blur.. If i factory restore will this method work?
    I am on 2 part gb rooted stock.
  18. mbtoloczko

    mbtoloczko Member

    The OTA update method would error out with the triangle+exclamation point, so I figured out how to install the update.zip from stock recovery, but I got a "Status 7" error during install with a note about the build.prop file not being valid. So after a lot of research, I realized that the build.prop contains some performance settings, in particular, the max events setting that I had changed from 55 to 60 using Android Overclock. I changed that back to 55, rebooted into stock recovery, and bam, the install worked. Only took the better part of two days to figure that one out. ugh. BTW, anyone using Bloat Freezer needs to defrost everything before the update process will work.
  19. scary alien

    scary alien not really so scary Moderator

    Guys,

    I used this method last night (thanks for the head-ups re. this, Lex!) and for the most part, it worked wonderfully.

    I should point-out a few little things that might help others that try this too:

    1. You need to have rooted, stock .596 for this to go smoothly. I had installed a self-modified framework-res.apk that I manually backed-out just prior to trying to get the OTA. Well, it was either the plethora of (somewhat expected FCs) when backing this out or that fact that I had renamed BlurUpdater_VZW.apk to disable OTA, but when I re-activated the OTA capability (by putting BlurUpdater_VZW.apk back to normal and rebooting), I was presented with something unexpected: the check for system updates took me to a screen that said "Motorola Service Account Required" :( :confused: :mad:.

    Turns-out (as far as I know), only a factory reset will fix this predicament. I wasn't too upset at having to do this, since I have TiBu and thought it was high-time that I wiped the slate clean, but I really didn't want to have run into this. I actually think it was the renaming of the BlurUpdater_VZW.apk file that did me in and caused this disconnect. Anyway, the factory reset allowed me to take the OTA just fine.

    2. Just expounding on the sequence of events that I experienced. When I told the OTA to go-ahead and install, I watched the screen intently for any indication that it was finished. Well, I watched the progress bar that you get while the OTA is being installed and I never even saw it fill the progress bar up completely before the reboot started. I (somewhat nervously) pulled the battery when the red Droid eye appeared and was very relieved when ClockworkMod showed-up. I simply flashed the su/superuser .zip package, rebooted, and blammo, everything was cool :cool: ;) :).

    So, at least I didn't have to SBF...which was nice...:)...this whole process would've probably only taken 10 minutes if I hadn't had to factory reset.

    Hope that helps.

    Cheers!
  20. bpbomber

    bpbomber New Member

    Currently on TBH's Deodexed .596
    Is this not considered stock?
  21. scary alien

    scary alien not really so scary Moderator

    Oh, no, deodexed is far from stock...you certainly cannot use this method since the OTA should not work for you (would be cool if it did, but I can't see that it could).

    Cheers!
    bpbomber likes this.
  22. scary alien

    scary alien not really so scary Moderator

    Welcome to the AndroidForums, by the way :).
  23. mortymouse

    mortymouse Well-Known Member

    IMO the thread title is incorrect. My understanding is that if you are on a true STOCK .602 there is no way to root without an sbf. These instructions are for if you are on .596 toot, etc. There is no clear path from a stock .602 to root.

    If I am wrong here, someone please correct me.
    scary alien likes this.
  24. bpbomber

    bpbomber New Member

    lol, thank you and thank you again. You, amongst others here, have helped me countless times over without ever knowing it.

    I've never done an SBF before, I've read a bunch about it... Just not sure it's something I want to jump into just to be able to install an OTA baseband update. If I'm gonna learn to SBF, it should be to try out CM7.1 or something, right?!?! :p
  25. scary alien

    scary alien not really so scary Moderator

    Oh, I see what you mean...well, I think most of the references say "stock, rooted" and I just noticed in my post (thank you for pointing that out, I'll correct it in just a second) that I said "completely stock"... I was trying to reinforce that you can't have anything like the framework-res.apk mods and BlurUpdater_VZW.apk mods that I made.

    So, yes, mortymouse is correct, you must be stock (.596) and rooted for this method.

    Thanks!

    edit: and apologies to bpbomber for the misunderstanding.

Share This Page