8 G microSDHC made smaller after image write

Last Updated:

  1. drdaevans

    drdaevans Member

    I am following verygreen's procedure to add CM7 to my newly purchased 8 G microSDHC SanDIsk card. I've used Win32DiskImager to write generic-sdcard.img to the card. However after that completes successfully the card now says it is only 115 MB in unused space and I cannot copy CM7 to it.

    I've tried re-doing it several times, in a card reader as well as the onboard reader and always get the same result. (I re-formatted the sdhc and it would only format to 115 MB; I had to use 'diskpart' to restore the care to 8 G).

    I'm running Windows 7, 64 bit on an HP Pavilion g7 (Core i5). I also tried this with a second, new 8 G microSDHC and got the same results.

    I'm not sure what else to try. Any suggestions?

  2. colchiro

    colchiro Well-Known Member

    Got a link to the guide you're following?

    You're supposed to end up with a sdcard with 4 partitions on it and you can only see one from Windows, if plugged into the computer.
  3. drdaevans

    drdaevans Member

  4. colchiro

    colchiro Well-Known Member

    You didn't read far enough. :D I checked out the first post, then fast-forwarded to the last when I saw how old it was. I found the answer on the last two pages. Took about one minute.

    When that guide was created, CM7 was small enough to fit, but newer builds are larger now and don't work, unless you use an old version of CM7. (I wouldn't recommend that.) If you check out the page where you DL CM7, you'll see the file sizes on the right.

    Use this guide and links and you'll have a 300 MB partition to copy files, big enough even for CM10 files (much larger than CM7): http://forum.xda-developers.com/showthread.php?p=23153010#post23153010

    Bear in mind that your sdcard will eventually fail, depending on how much you use it. Consider yourself lucky if you get a year's use out of it. It will also be a little bit slower than a rom that replaces the stock B&N rom. My opinion: The NC is too slow and a Nexus 7 would be a LOT faster, have the latest version of Android on it and you'd be a LOT happier. Still, I suspect your Nook is already paid for and it'll be a fun little project (from this point forward). :D

    Please update this thread with your outcome.
  5. drdaevans

    drdaevans Member

    Thanks for that link. I followed the steps, using the larger file, and I got the SD card to be able to load CM-10-20130127 nightly encore.

    The boot of the NC installed CM10 and I was able to followup installing gapps-ds-ERE368. That is when things wnet south. After installing gapps when I tired to restart the NC is get as far as the CyanogenMod spinning logo and no further. Now the NC is at that point and will go no further nor will it turn off or respond in any way. The only thing I can see that will work is for the battery to run down.

    Any ideas on this?

    Update: I was finally able to get it to shut down. I re-booted and am back to the spinning CyanogenMod. I've gone through this process several times. Even removed the SD and booted B&N then powered off and back to CM but still hung at the bootloader.
  6. colchiro

    colchiro Well-Known Member

    Hold down the "n" and power button until it powers off. You'll have to do this without being plugged into the charger or it will restart. Plan "B" would be to unplug your sdcard and power off and let it boot into B&N to charge.

    The gApps version HAS to match the rom version and the stock ones will have the rom version (gb, ics or jb) in the file name. The best thing it to use the one recommended in the install guide. It'll probably be one of the first two here: Goo.im Downloads - Browsing gapps You'll have to find out if you have a 10.0 or 10.1 version rom from where you DL'd it.

    I suspect the easiest thing would be to start over. You're probably pretty good at that by now. :D
    drdaevans likes this.
  7. drdaevans

    drdaevans Member

    Yes, I'm getting better and better at this install :).

    I got both CM and gApps to install. Note that during install of CM I saw that it did not find a copy of gApps. I used the latest build from download.cyanogenmod.com and the last gApps for CM 1.1.x. Install when OK although I'm still not sure that the versions match as I cannot find a version number for CM other than it is 10.

    The problem I'm having is that the android keyboard is not working (flashes an error message that andoid keyboard is closing. So is this maybe a mismatch or something else?

    I would rather use a stable build of CM but the download site only shows CM7 as stable.
  8. colchiro

    colchiro Well-Known Member

    CM10 is too new to be stable. It's going to be some time. :D

    Settings... about should tell you if it's 10.0 or 10.1.

    Try a different keyboard from Play Store, like Hacker's maybe. Settings... input... default. Change the default keyboard there to use the new one, then maybe it won't FC any more.

    I believe CM7.2 would be the last stable, tho a RC is usually pretty good.
    drdaevans likes this.
  9. drdaevans

    drdaevans Member

    I finally got everything to work. I backed off to an earlier gApps and installed it at the same time as I installed CM (which turned out to be 10.1)

    So I've got it working and can learn about Android (this it totally new to me). Once I feel confident I may try what you suggested to not have to run off the SD.

    Thanks for all your help and suggestions.
  10. colchiro

    colchiro Well-Known Member

    Glad you got it working... :D

Share This Page