a few small issues with my new S4Support

Last Updated:

  1. zalex

    zalex Active Member

    so i got this phone three days ago. in the past i've only used motorola phones. never again. this s4 is WORLDS ahead of any of the garbage i've used before, and i cannot believe i'm finally happy with my phone. this is new territory for me.

    a few small issues:

    1. when i first got the phone (i'm on verizon), data connectivity would not work at all. turned out i needed a new SIM card. now i get data just fine...unless i'm on wifi. it seems that i lose 4g/3g/1x entirely while wifi is on. however, it is possible that it is working, but there's not enough room on the notification bar to display the 4g icon.

    screenshot with wifi on: [​IMG]

    screenshot with wifi off: [​IMG]


    2. sms/mms delivery reports do not work. this may be a bug with 4.2.2 though (or so some research has led me to believe).

    3. my last small issue is the daydream feature., which i love. i have a folder of ~2900 funny pics i've collected over the last few years. they're a mix of PNGs and JPEGs with maybe one or two GIFs. i have daydream set to show a frame of everything from this folder. sometimes it works and sometimes it doesn't. when it doesn't work, the screen turns all blue. at first i thought this was a filetype not supported by the phone - especially since it would display a ton of images before the blue came on. but once it shows a blue image daydream stops working entirely. however, if i start using the phone and then let it go back into daydream mode, it fixes itself.

    thoughts on any of these, anyone?


  2. Szadzik

    Szadzik Well-Known Member

    1. Why do you need 3g when you have data from wifi?
    2. Delivery reports can be turned on in Messaging settings, no bugs he.
    3. Try to leave jpegs only in the folder. Or maybe you have a bad file there or it simply chokes at that number of files.
  3. zalex

    zalex Active Member

    thanks for the reply.

    1. it's not whether i need it, it's whether it's there. but to answer your question, let's say i want to send an mms.

    2. they are already turned on.

    3. will do, good suggestion
  4. Sierra255

    Sierra255 Well-Known Member

    #1. Your text messaging will work just fine if you're connected to WiFi.
  5. zalex

    zalex Active Member

    okay, well i mean i haven't found that to be the case, but either way it's not really the point. i don't want to lose my data connection at all, regardless of wifi connectivity, you know? is the general consensus here that i AM losing it (based off of the screenshots)?
  6. Sierra255

    Sierra255 Well-Known Member

    On my last phone (GS2) and my current phone (GS4), it has worked that the 3G/4G icon goes away when you connect to WiFi. I don't think that means you disconnect from your cellular data signal, only that the data transfer service has been handed over to the WiFi radio. When you turn off the WiFi radio (or when you're out of range of one the saved signals), it will hand those duties back over to the data radio. From what I know, your cell signal is still used to send SMS and MMS messages when connected to WiFi. And in my experience, that has been true. When I've had good WiFi access, but in an area with a poor data signal, text messages tend to have a problem being sent. If you're having similar issues, my guess is you're in an area with a poor or busy data signal and you'd have these issues whether you're connected to WiFi or not. That's been my experience any way.

    By the way, if you lose your cell data signal, you'll get a circle with a line through it in place of the bars. Since you have bars, you're connected to your cellular data.
  7. zoxxo

    zoxxo Well-Known Member

    Sierra255 has it right! One of the reasons for WiFi taking over is so that you don't use your data plan, which saves you money on metered data. On my Droid Razr Maxx, I would have the 3g/4g indicator on all the time, but it would turn blue when connected, and it would turn white when I was on WiFi.

    As for the SMS/MMS problem. Have you tried a third party text program such as Handcent or GoSMS to see if the problem is with default application, or the phone/network. If it happens in the third party app, then I would give Verizon a call.

    Finally for daydream: on my Nexus 7, daydream only kicks in when i have the tablet in the dock. I'm not sure if the s4 is supposed to behave the same way, but it could be the reason why you're having trouble...
  8. Coolhands

    Coolhands Active Member

    The 3G/4G icon goes away for me when on wifi but usually comes back when I send an MMS which shows it is active to send a picture.
  9. Szadzik

    Szadzik Well-Known Member

    Then turn off WiFi.

    So what seems to be the problem?
  10. zalex

    zalex Active Member

    assuming this is the answer (which i believe it is not, per zoxxo's post), is that really a solution you'd be content with?

    they don't work. they are turned on but i don't get confirmation for any texts. chomp used to show a green checkmark when the message was delivered and the yellow dots while it was pending. now all i get are yellow dots, even though the texts are going through. yes i've tried other sms apps. yes i'm texting someone whose phone sends delivery reports.


    thanks guys! this is very helpful. my razr behaved the same way now that i'm thinking about it. i guess this is just the equivalent :)
  11. Szadzik

    Szadzik Well-Known Member

    Guys, this is how it is designed to work, there is no glitch here. How do you imagine having 2 data connections at the same time - WiFi and 3G? You think Android can use connection bridging or what?
  12. Sandroidfan

    Sandroidfan Well-Known Member

    This is normal behavior with any android phone. When it's connected to WiFi point, the cell data radio goes into super low power mode to save battery life. But your 2G cell connection for calls/texts is always alive.
  13. zalex

    zalex Active Member

    well this isn't really my area of expertise (hence the support post on an android forum), but i suppose like this

    and this

    good thing you're not being a dick about it, szadzik. thanks for your efforts.

Share This Page