A firmware bug means I can't USB - so how can I root?

Last Updated:

  1. Periphereality

    Periphereality New Member

    This is literally the first time I've ever had to post on a forum for help - I cannot find anyone else who has this problem!

    Basically, my note has a "firmware bug" <-- according to Samsung support (known) where I will get a 'USB device not recognised' problem every time I connect to the PC. Actually, when I plug it into the power cable into the wall-socket MTP comes up. Just to get this out of the way, I know it's not a hardware problem - I've been on support for ages, and they insist I RMA for a "firmware reflash" well, no. They said I have to take it to a Samsung outlet, and.. do they even exist?! (from the UK)

    Anyway, if we could focus on the solution here: I need to root my phone in order to reflash my phone and therefore solve all the problems. I have Rom manager (pro) installed, and Odin on my phone - but no root, since I can't USB and therefore can't ZergRush etc and so forth. You see my problem here.

    Basically the tl;dr is I need to root via APK OR reflash via SD without any need to connect to my PC via USB (since it work work). Obviously as I'm not rooted I don't have CWM Recovery.

    So, you see my problem... I can't figure out how to sort it. One idea I had was to "update" the firmware via the stock recovery manager via SD.. Kernel version is currently

    Android ver 2.3.6

    If anyone can help I'd be in your .. srs Wookie style. Sorry for the essay!

    (I'm getting a message saying I can't post links.. but I haven't.. so I need to start deleting stuff :/)

  2. ZeroOne

    ZeroOne Guest

    you have to root using a computer to exploit your phone sorry. maybe bluetooth
    ADB could work somehow? but i have not tried anything like that? or some FTP file sharing i do not think its possible though.
  3. Periphereality

    Periphereality New Member

    Thanks. I read of an apk that could root through an exploit but I don't think it has been updated even for he s2 yet.. If I can't root, then any help reflashing or updating would be great help too. I will research this adp. I thanks for the reply.
  4. Blue1k

    Blue1k Well-Known Member

    Just out of curiosity have you done a factory reset?
    I'm not sure of the options in a stock recovery but if there is an option to fix permissions and format /system I would do that.

    Also, if you go to settings>applications>development.
    Check USB debugging.

    Can you mount the phone as a USB drive when connected and the prompt comes up in the task bar?
  5. Periphereality

    Periphereality New Member

    Hi. Yeah a factory reset was my first port of call. I checked debugging and development mode and fiddled with all those options, too. I also tried reinstalling the firmware via SD in default recovery (from a file I found on Samsungroms) but it only seems to allow updates this way, not full installs.

    The factory reset doesn't actually touch the firmware, it just resets all the user-data and configuration settings, so the bug still remains. There doesn't seem to be any way to wipe the system as you said.

    As for mounting, the PC isn't interfacing with the phone at all. The PC recognises something is connected, but even with the required drivers (on 3 of my PC's, and with a windows reinstall) and 4 different cables, the USB device is not recognised (code43, I think) Samsung recognised this as a known bug. I can't mount in download mode, recovery, usb mass storage or anything. ODIN does not recognise at all. Nothing does.

    I really need to figure out some-way of either flashing, updating or rooting.

    Thanks for your help though, so far no luck.

    Just for your use, here is a list of stock recovery options:
    -apply update from external storage (tried)
    -wipe data / factory reset (tried)
    -wipe cache (tried)
    -apply update from cache
    -test redbend fota[FS]

    Email from Samsung:
    "Thank you for contacting Samsung.

    Regarding your case, kindly note that the issue reported with the phone indicates that the phone would need a software reset, or re-flashing of the software, in order to have it operating normally again.

    Please note that what has happened is caused by a minor software confliction."

    Please, kindle note how useless the email is :/ right?
  6. Blue1k

    Blue1k Well-Known Member

    A couple things. Rooting is not necessary if you want to wipe the phone. Odin can achieve this. But in your case the issue is NOT software related. That, and even if it was you NEED usb support to use odin or achieve root. I can explain:

    I did a little research.....

    1. Code 43 is not a Samsung error but a Windows error relating to a driver not functioning. People at Samsung telling you it is a bug is bullsh*t
    From a windows technician: "because one of the drivers controlling the device notified the operating system that the device failed in some manner. This can be because of corruption in one of the loaded drivers and the driver cache just needs to be flushed"

    2. The MTP initializing error is due to either a faulty USB connector OR dirt/debris in the charging port. My guess is since you are able to charge your phone but have the MTP initialization error, you have an obstructed port.

    I would look at your port with a magnifying lens and bright light and try to clean it.

    Use compressed air and not any liquid or q-tip.

    If this does not fix it then you indeed have a faulty USB port. This is not a software issue. I don't care what those guys at Samsung tell you. Insist for a new device if my suggestion does not work.
  7. Periphereality

    Periphereality New Member

    Wow thanks for your hard-work, I'm going to have a close look at this port and give it a very good clean.

    When I plug the phone into my dock, I get no MTP. When I plug it into my PC I get MTP connected. It charges, and the MTP seems to know when to activate. (when I plug it into the wall socket it's via an Amazon kindle charger and cable so that might explain why it gets confused there). Still, again, no matter which cable or PC I use there's no connectivity.

    Interestingly, I tried connecting via kies for wifi, and it's just stuck on 'Loading' in the top left. Tried loads of times, left it for two hours. It technically connects, since it has the phone model - but it's just stuck on 'Loading'.

    It really seems as though the phone is at fault here, but that's just inductive conjecture.

    http://i.imgur.com/HAgLX.png you can see here when it's plugged in I get MTP connected, but nothing on my PC (or other PC's, or with other cables)

    If I had rooted this I could have avoided all this -_- No USB as of yet, still though.

    UPDATE: I have just tried to connect to kies via WIFI, and it's stuck on 'Loading' (I dismounted SD card too.) So kies isn't even talking to the phone via Kies for WIFI.

Share This Page