A fix for Motorola Triumph's Slow GPS (by updating GPS library)


  1. jetlawn

    jetlawn New Member

    I register an account to let you know that long GPS lock time is a software issue and not a hardware issue:D. It can be fixed by updating the Triumph's GPS library.

    Follow These Steps:
    1. Root your phone (use gingerbreak.apk) and install clockwork recovery (http://androidforums.com/triumph-al...orola-triumph-root-guide-upd-7-30-2011-a.html).

    2. BACKUP (I am not responsible if something happens to your phone).

    3. Go to this XDA thread ([6.Aug.2011][Dev] GPS Libraries v2.0 with AGPS support for HD2 Gingerbread - xda-developers).

    4. Download GPS_Libraries_v2.0_RPC_for_HD2_Gingerbread_update. zip (Thanks tytung for developing this fix)

    5. Put the zip file on your sd card and flash it through ClockModRecovery. Restart after flashing.

    6. Turn on GPS fix application. You should see improvement in accuracy and lock time. (For me, I can get a lock in less than 10 seconds)

    Please let me know in the thread if it works for you.

    EDIT: It seems like turning on wifi increase GPS lock time but not by much. If GPS lock is still slow for you, try to disable WIFI.

    Thanks :cool:

    Advertisement
    zubero, rubejb, Neptik and 5 others like this.
  2. novak921

    novak921 Well-Known Member

    I am going to give this fix another try step by step and see if I missed something because I tried this the other day and nothing, my GPS still will not lock and Gps Fix shows I have about 5 or more satellites connected.

    Hopefully 2nd time is a charm and there are some really good YouTube videos on how to install Clockwork mod on your Triumph on YouTube for anyone who is hesitant.

    EDIT: I did the 2nd install and on the first attempt with Gpslock, it had 6 or more sats connected and was hanging but I got a location after about a minute and stayed locked on so I will update again later today as I am heading to Chicago and that will be the real test.

    Hope at least!

    ~Novak
  3. nrg3x

    nrg3x New Member

    Thanks for posting this fix. I tried it this morning and my GPS seemed to lock in faster. Usually it would take a couple of minutes to lock on but today it took less then a minute! I will do more testing today and keep you posted! Again thanks for posting this!
  4. stef7

    stef7 Well-Known Member

    I am suspicious of people reporting better lock/fix times using some modification.

    When I have performed a fix and that is cached, yes, subsequent fix attempts are fast and that isn't because of rooting or updating of a library.
  5. striker325

    striker325 Well-Known Member

    I didn't see any change in gps location results. I will try to redownload the agps data.
  6. zeeebs

    zeeebs Member

    This has worked like a charm for me...I now get GPS locks within 10 or so seconds at most...before it was a couple minutes. Good work team
  7. eatsaimin

    eatsaimin Well-Known Member

    Which .zip did u flash?
  8. APag96

    APag96 Member

    Crazy-awesome results! Went from a GPS lock in 3 minutes to about 5 seconds! This is after flashing the v2.1 ZIP.
  9. borjis

    borjis Well-Known Member

    do i have to have gingerbread o/s?

    will it work on stock Froyo?

    EDIT: looks like it will work on froyo..anyone try the gps 2.1 version on stock triumph?
    looks a bit newer.
  10. exProphecy

    exProphecy Well-Known Member

    ? Am I doing something wrong? I flashed the .zip but I don't get any GPS app showing up in my app drawer..

    EDIT: OHHH we have to download a gps fix app?
  11. JarGnex

    JarGnex Well-Known Member

    Gps wouldnt even lock prior to this mod :D thanks a lot. Oh im on the latest cm7 reloaded :)

    Edit: I don't know what happened but after going to maps again the GPS wouldn't lock anymore. :/:(
  12. b_randon14

    b_randon14 Well-Known Member Developer

    You guys do realize that flashing this zip on our phone does nothing right. The updater-script inside the zip tries to mount our system partition as a mtd partition which does not mount the system partition at all and then it tries to copy the files to an unmounted system which means basically the files never make it on the phone!

    I will try to get a zip that will actually copy the files over posted soon after I test it to make sure it won't break nothing!
    BBears and JarGnex like this.
  13. APag96

    APag96 Member

    I know for sure that my results (posted above) are not placebo. My GPS literally locked in under 10 seconds. That has NEVER happened. I was even in my basement. Are you sure that flashing this has absolutely no effect?
  14. agentc13

    agentc13 Daleks Über Alles VIP Member

    Yep. b_randon is correct.
  15. b_randon14

    b_randon14 Well-Known Member Developer

    Now perhaps mounting the system partition first then flashing it would work.

    I dud it and got the files over on my phone. Mine was already locking fast before and I can't tell much of a difference after but to some it may help more. But yeah just mount system first. Then check by seeing if it added some GPS.bravo.so and GPS.Leo.so in the /system/lib/hw/ folder.
    nannycrick and wokeupdead like this.
  16. ziggy46

    ziggy46 Well-Known Member Developer

    i like using these mount commands for our phone... they are alot simpler than messing with MTD and EMMC crap lol ;)

    Code:
    run_program("/sbin/busybox", "mount", "/system");
    
    run_program("/sbin/busybox", "umount", "/system");
    JarGnex likes this.
  17. tcross8361

    tcross8361 Well-Known Member

    Sounds promising. I think I tried this method before and it didn't really work. So, let me ask a couple questions.

    After doing this mod, does it still work after cold start (turning phone off and changing locations then turning phone back on)? On the XDA thread there are different versions of the file to download, should I always keep the most recent RPC version (currently 2.1)?

    I will try this again today. I'm going out of town, so that'l be a good test.
  18. b_randon14

    b_randon14 Well-Known Member Developer

    Yeah I got the 2.1 rock on my phone at the moment.
  19. DisguntledUser

    DisguntledUser New Member

    I have used this youtube tutorial below on how to install and use CWMod. Installed the RPC version 2.1 suggested in this forum with CWMod and no dice. I also mounted the system and cache. Phone GPS still can't lock on to my position, any other suggestions?

    EDIT: This forum will not allow me to use links in my first post so please go to youtube and put 1H0KMnVy26Y in the search.
  20. DisguntledUser

    DisguntledUser New Member

    Is there a way to just access your phone and overwrite the existing GPS files with the ones provided in the 2.1 zip file by copying and pasting? Just seem like it would be 10 times easier to do it that way...
  21. tcross8361

    tcross8361 Well-Known Member

    Yup, do this 1st and it works like a charm. I first tried it with out mounting the other day and didn't see any differance. I read your comment and found in my version of CWR (blue letter version) that there was an option to mount to the system (mounts and storage>Mount/system). Well I mounted to system then installed the zip and rebooted the phone twice to make sure it was a cold start. It locked within 10 seconds from my yard.

    Now let me tell you it was hit or miss before. My yard usually took about 5 minutes to cold lock. Most other places a couple minutes. After doing this mod, in my yard took 10 seconds to lock and on a cloudy rainy night. Thats awesome.

    So as b_random said you have to mount to the system 1st to make the mod stick.
  22. wonshikee

    wonshikee Well-Known Member

    I can confirm this did nothing for me.

    Mounted /system, flashed zip. Ran GPS test, 15s later it saw its second sat... so yeah, no help for me. Running CM7.

    I'm inside my room, I have 3 other phones and they all lock pretty fast (10-30s) so yes - it's the MT sucking.
  23. gradymcd

    gradymcd Member

    how do u install it
  24. retromind

    retromind Well-Known Member

    This worked like a charm on CM7. I took the plunge and flashed CM9, Do I Need to flash this again? or Is GPS not stable on this rom?
  25. I mounted /system and installed the zip but I do not find the files GPS.bravo.so and GPS.Leo.so. When I try to lock on my GPS signal it won't lock at all.
Loading...

Share This Page