A series of issues wtih Sprint Hero


Last Updated:

  1. fayester

    fayester Well-Known Member This Topic's Starter

    Joined:
    Feb 6, 2010
    Messages:
    69
    Likes Received:
    24
    I did a search on Google and this forum trying to find an answer to a series of problems I am having with my Hero and was unsuccessful. Please help or point me to the direction to find help if you can.

    1. After the phone wakes up and I try to access the internet I cget "No data connection found. Usually I would have to wait 1-5 minutes before the phone restores the connection. If that doesn't work, I toggle Mobile Connection off, then on and then attempt to use the internet. If that doesn't work I power down my phone wait a few minutes then restart. This morning it took the phone 15 minutes to establish a connection on its own after waking up. I tried to used the toggle to turn the Mobile connection on an off but the application was unresponsive to my taps and the screen seemed to freeze.

    2. I reported this a few months ago: While my phone is resting and I get a call the lock screen will flash on and off. Nothing appears on the caller ID and I have no idea who is calling unless I actually "slide to answer". By then the caller has hung up. Restarting the phone does not automatically stop the problem and it is very sporadic.

    3. Sprint Navigation has never worked on my phone. Sometimes it freezes during startup, can never find a GPS satellite or gets stuck trying to create the route. I have the latest version of the app from Sprint.

    I bought my phone during the last week of December. It has the stock ROM and latest firmware build. Only applications that I have added

    Toggle Headset
    OpenSudoku
    Solitare
    Pandora
    AndroidZip
    ColorNote
    Battery Widget
    Mobile, WiFi, Bluetooth and GPS toggles
    Brightness toggle
    Handcent
    Dolphin

    Thanks to anyone that can help!
     

    Advertisement
  2. peterc10

    peterc10 Well-Known Member

    Joined:
    Jan 10, 2010
    Messages:
    711
    Likes Received:
    80
    Suggest this would be best in the dedicated Sprint forum?
     
  3. caliboy99

    caliboy99 Well-Known Member

    Joined:
    Mar 31, 2010
    Messages:
    74
    Likes Received:
    8
    well if your problems started after you installed any of those problems i would suggest uninstalling all of them then install one by one to see if you can narrow it down to one app that is causing your problems. Since its well over any exchange policy id maybe try restoring phone to factory settings. I know Nokia devices you can reformat the phone so it reinstalls factory settings but not sure about android phones though. Good luck
     
  4. dan330

    dan330 Well-Known Member

    Joined:
    Jan 22, 2010
    Messages:
    11,598
    Likes Received:
    3,221
    hi
    You still have warranty
    So use it

    Or

    You can call support and get them to show you how todo full rest
    Put it back to factory and try from fresh
     

Share This Page

Loading...