A Step by Step Guide to getting Amazon Appstore, & Google Play on a Curtis Klu LT7033


  1. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    What are you talking about dude? You've been awesome! :)
    scary alien likes this.
  2. cabiggs152

    cabiggs152 Member

  3. Birdie13

    Birdie13 New Member

    Followed instructions listed and worked great on two Curtis Klu LT7033 tablets. I used a Windows XP SP3 laptop for connection with an Intel i5 CPU and the drivers listed worked. There are several ways to get to the device to change the drivers the only thing I see was different I think it listed to select the AMD or the i386 folder depending on your processor. It would not let me select the specific folder I had to select the root folder that was created when it unzipped, that folder name was "ADB Driver RK29". From there it found the driver and installed without a problem.
    Very clear instructions and much appreciated, THANKS.
    SuperNoober and scary alien like this.
  4. mavrikmeercat

    mavrikmeercat Well-Known Member

    Man... just like that bro? I dont think anyone here is ungreatfull and if someone has been rude then blow it off cuz that is not what this community is about at all.
    Don't let some troll hinder your desire to help others and dont let your mistakes hinder that either. Thats how we learn unfortunately..
    El Presidente and scary alien like this.
  5. cabiggs152

    cabiggs152 Member

    okay im still having problems im rooted with su on the tablet but now google play store fc's everytime i open it idk what im doing wrong... if anybody knows what the problem could be plz let me know!!!!!!!!!!!


    jkjk im stupid and didnt read all the directions haha ignore this post haha
  6. rdwalter

    rdwalter New Member

    Thanks for all the help. Google Store and Amazon Market easily insalled on my LT7033E (also comes rooted). One tip - in ES File Explorer, to select and copy the Google Play apk, click and hold. Otherwise if you just short click you will install it.
    SuperNoober likes this.
  7. SuperNoober

    SuperNoober Well-Known Member

    You can also use the (multi) select button with just one file. This is what I originally meant, but it was not clear enough the way I wrote it the first time. I've made a number of edits based on the replies everyone's made and I feel the guide is getting to the point of being really good, perhaps even to the point of good enough as is. (I hope so because I'd like to start playing with the tablet more than writing about it.)

    The ADB drivers have been proven on XP, Win 7, and even Win 8, that means they are the most up to date currently available, and should be inclusive from win 2000 to win 8. The RK29 root toolkit has proven effective for both the LT7033, and the LT7052. Both of these files are ready to populate the All Things Root Sticky.

    To all of you guys who did the original work in making this guide happen, and to all of you who helped refine this guide by providing your comments I say...

    THANKS A GOOGLE!!!
  8. SuperNoober

    SuperNoober Well-Known Member

    :goodnight:
  9. SuperNoober

    SuperNoober Well-Known Member

    We are Curtis
    We play joke
    We sell you tablet
    Already broke!
    :party::party:
    :party::party:
    :party::party:
    :party::party:

    This thread has been, and still is, dedicated to helping everyone who purchased a Curtis International Klu LT7033 get Amazon Appstore, and Google Play up and running on their device. For a discussion concerning why I no longer consider Curtis International to be a legitimate enterprise see the new thread...


    Dumping on the American Market?

  10. cabiggs152

    cabiggs152 Member

    I Followed this guide to a tee and successfully rooted my tablet downloaded Google play store and i haven't put it down yet!!! Thank you so much supernoober and all who helped, y'all made this tablet more than just an over sized paper weight. I cant thank you enough.
    SuperNoober likes this.
  11. gardenfan

    gardenfan New Member

    So very glad to have found this post! Now my son's tablet has become much more useful! Thank you Thank you!
    scary alien likes this.
  12. frostydog

    frostydog Member

    Guy's this is fantastic, noobs like myself really appreciate it.

    I am now having a problem though...

    I only took the steps for the Amazon Store, that was enough to get a few games on the tablet for my toddler son. For a couple days everything was working fine. I downloaded a few apps, my son was happy, life was good.

    Today, when I was trying to download another game for him, the process got hung up on the download step.

    It goes through the purchase step just fine, but once I click "download", the download bar will show forever with no progress. I tried everything I could think of...different apps, uninstalled and reinstalled the Amazon Store app. Still the same.

    Any ideas??

    thanks much
  13. mavrikmeercat

    mavrikmeercat Well-Known Member

    Close amazon appstore. Go to settings--> apps--> amazon appstore--> and clear cache and wipe data. Open appstore again and sign in again. (Repeat until it works) you should be able to download again. Do this anytime this happens..
    DEC173000g likes this.
  14. frostydog

    frostydog Member

    Thanks Mavrik, I have tried this, many times. I've gone so far to completely uninstall and re-install the appstore. Still no luck.

    You mention "repeat until it works"...between restarting the tablet and doing the clear data steps, I'm sure I've done it at least 5 times now. Are you suggesting it could take 10+ times till it works?

    I should also note the only thing "new" I did with the tablet, since I last downloaded an app successfully, was to put a couple movies on an SD Card to watch on the tablet. I can't imagine how this would be related, but other than that little addition the tablets entire life was playing apps from the Amazon appstore. I did take the SD Card out of the tablet, thinking that may have had some affect on all this....but no luck.

    thanks again for the help
    MLF
  15. SuperNoober

    SuperNoober Well-Known Member

    frostydog:

    The more specific you can be about what you are trying to do the more likely one of us will be to answer your question. For instance, what app were you trying to download? I'd like to try to download the same app to see if the same happens on my unit.

    I don't have an answer for you, but things I would be curious about would be if anything actually did download to the /sdcard/ folder.

    Other than that I'm glad to see Maverikmeercat is still out there, where did the rest of you guys go?
    mavrikmeercat likes this.
  16. mavrikmeercat

    mavrikmeercat Well-Known Member

    Also try clearing the dalvik cache(not the same thing as cache) which would normally be done in a recovery but we aren't there yet. So you can do it manually like so:

    Open es file explorer
    Go up to root ( / )
    Open data
    Open dalvik
    select all files in dalvik folder
    Select delete
    Now right from there, press the power button and choose shutdown (don't back out of anything)
    Now power back up. It will take a few min to boot because it will rewrite all needed files to the dalvik.
    Try your app again and see if that worked

    Usually the dalvik gets cluttered when you add/remove a lot of apps and is a good idea to clear it once a week on low end devices because the ram gets all cluttered with unused junk. Also apps that have been removed sometimes stay in dalvik and clearing and rebooting will rewrite only installed/relevant files during boot.
    DEC173000g likes this.
  17. frostydog

    frostydog Member

    Thanks SuperNoober,

    I was trying to download an app for my son called "Stack 'N Puzzles", its a pay app.

    The only thing I can see on my sd card are the movies I copied over from my laptop, doesn't appear anything got downloaded to the card.

    Thanks Mavrik,

    I never downloaded es file explorer (I know, my bad). Is there any way to do what you describe using the default apps available on the 7022?

    I really appreciate all the suggestions guys!
    thanks again
    MLF
  18. SuperNoober

    SuperNoober Well-Known Member

    Which model do you have?

    Oh hell just load up play store. It is not hard to do, just take long, slow, deep breaths, you'll be ok. I promise. If I can do it anyone can. Except the manufacturer that is.
    With how screwed up Amazon appstore acts, I wouldn't doubt they did something to screw that up too.

    Anyway, its past my bedtime so good luck.
  19. mavrikmeercat

    mavrikmeercat Well-Known Member

    Yeah honestly I stop using amazon because it is such a pain. google play is the way to go. I really don't have any need for amazon. I just put it in my ROM because so many of you were looking to use it but it has given me lots of trouble as well
  20. frostydog

    frostydog Member

    Thanks guys...that will be my path.

    Is there anywhere else I can get es file explorer, since I can't get from Amazon? Seems to be a pretty important component for the google play install.

    thanks
    MLF
  21. SuperNoober

    SuperNoober Well-Known Member

    I wouldn't assume that because Amazon froze on Stack and Puzzles that it will freeze on ES File Explorer, however if that is the case, you can use SlideME which comes preloaded on the LT7033. Slide ME has a payment option that allows you to link to your already existing Amazon account. Be sure to post your result regardless of outcome so everyone will have an idea of what works, and what doesn't.
  22. mavrikmeercat

    mavrikmeercat Well-Known Member

    here you go

    mod edit: see link in next post, please :)
  23. scary alien

    scary alien not really so scary Moderator

    mavrikmeercat and SuperNoober like this.
  24. mavrikmeercat

    mavrikmeercat Well-Known Member

    Thanks alien.. Sorry if I violated something
  25. scary alien

    scary alien not really so scary Moderator

    No problem, mavrikmeercat :).

    It's just best to only post links to official sources or if you are the author/owner of the software.

    Thanks!
Loading...

Share This Page