A2DP bitrate on S3 and lousy sound quality!!!General

Last Updated:

  1. sorka

    sorka Well-Known Member

    So I may have just found my first real deal breaker. Other issues that looked like they might be deal breakers have had work arounds.

    So I'm listening to music for the first time with my new S3 using my Sony BT-50 A2DP stereo headphones. On my DX, the sound quality is fantastic. Truly CD quality with all of my 320 kbs rips of cds. I don't like compression so I've always ripped my CDs at lossless even though they take more space.

    So now I'm listening to my S3 with the same headphones and hear the distinct worble compression artififacts on the upper end that you typically get if you're listening to a low bitrate mp3. After doing some reading, it appears the S3 may have set the bitrate low on A2DP which I didn't even know was possible.

    Someone please help. I have to figure this out or the phones will have to go back. I listen to music through these headphones 5 to 6 hours a day...mostly classical and the SQ is killing me.

  2. sorka

    sorka Well-Known Member

    Really? Nobody is bothered by the BT streaming quality on the S3? I've done some poking around. I guess the S3, and the S2 are using SBC for mpeg which re-encodes the stream. The mpeg section is turned off in audio.conf but turning it on and SBC off prevents the headphones from connecting, so I'm guessing that samsungs stack or their version of liba2dp.so doesn't support it.

    It's a shame, because if it did, it would send the mp3 stream directly to my headphones and the first and only decode would occur there not only drastically improving sound quality but also reducing power usage on the phone.

    I really don't get this.
  3. I'm surprised you are that concerned with sound quality, yet are using a Bluetooth setup.

    I know A2DP is supposed to be the fix, but I'm not convinced.

    I have a set of UE TripleFi 10's and a portable headphone amp that I use for mobile listening, but, unfortunately, I haven't had the opportunity with my S3, yet. I'll give that a listen when I get home.

    I listen through a pair of $30 Skullcandy headphones via a Jabra Clipper at work (kind of have to) and it sounds okay. That said, I'm listening to TuneIn and have ultra low expectations for the setup as a whole anyways.
  4. sorka

    sorka Well-Known Member

    A2DP with the right setup can sound very very good. I rip all my CDs at 320 kbps and with mpeg direct mode through A2DP, the mp3 file is streamed directly to the headphones and the headphone dacs do the first and only decode, so it's as good as a wire but your at the mercy of the dacs in the phones and the quality of the drivers.

    I use Sony BT-50 headphones. They are exceptional for their price. They don't replace good quality reference headphones which I have considerable $ invested in. Let's put it this way, I still listen to CDs with wired reference when I'm stationary and I pick the headphone based on the type of music and the mood I'm in.

    The BT setup is for working outside and in active environments where cords would be an issue.

    So what I have a problem with is when the SQ through this setup isn't as good as it can be.

    I think the fix that was reported is simply that the bitpool was increased so it doesn't suck as bad as it did before, but mpeg direct still doesn't work and that's what I'm having issues with. I demoed the issue to 10 coworkers, and only one, the guy with the custom molded plugs, could tell what I was talking about.

    Interestingly, a sign wave test signal by itself was actually pretty clean up to 17KHz. My hearing starts to leave at 17.5. In my twenties, I could easily hear up to 20.5 but now I'm in my 40s and it's just not there any more. Still, my wife can only hear up to 12.
  5. Crafty

    Crafty Well-Known Member

    using A2DP in the car, sounds good enough to me.
  6. craighwk

    craighwk Well-Known Member

    Agreed. My car has both bluetooth and an AUX connection and I honestly feel that the Bluetooth sounds better. It could be unique to my car, but even with my old Rezound and Gnex, the Bluetooth sounded better.

    Maybe my AUX port sucks. :)
  7. nafanny29

    nafanny29 Member

    I use a Jabra BT3030 bluetooth headset with my klipsch headphones and the audio is nothing short of stunning.
  8. If you say so.

    Let's put it this way, I'm probably not the guy to boast about your equipment to.

    Good luck in getting the BT sound you want, though. If your apparently golden ear is that upset, I'd suggest either figuring out a way to make wired work, finding a different phone with the hard/firmware you want, or heading over to the root section to see if you can make this work.
  9. sorka

    sorka Well-Known Member

    CM 9 or 10 is probably my only viable solution at this point, but I really don't like to go that far off stock.

    But the first thing is to root and play with audio.conf.
  10. sorka

    sorka Well-Known Member

    I turned my droid x back on and did some testing to confirm that my ears aren't just playing tricks.

    This thread:

    Increase bluetooth A2DP quality (SBC -> MP3) - xda-developers

    Shows the "enhanced stereo" bluetooth setting. I remember setting this almost immediately upon getting the phone. From the description, it's clear that what it means is that if set, it will pass the mp3 stream directly if the receiving device supports it, which all of my a2dp headphones do. The plus is that it uses less power. I could listen to music on my DX all day long and it hardly touched the battery any more than standby alone.

    With the S3, it's drained after 3 hours of solid music. Presumably it's because the cpu has to work to transcode to SBC.

    If anyone would be kind enough to set MPEG12Sources=1 as in the exmaple in this thread and report back, I'd really appreciate it. If you set SBCSources to zero, I don't think the headphones will connect because the SBC profile is mandatory, but MPEG12Sources being set should allow the phone to stream direct mp3 to supported headphones. It very well might not work if the liba2dp.so prevents it.
  11. sorka

    sorka Well-Known Member

    On the bright side, for kicks, I paired yet another set of headphones I have, Sennheiser mm-100. Amazingly the problem doesn't exist with these headphones. It didn't take long to find out why. These headphone are the only ones i have that support apt-X, which is a lossless codec. It's exploding right now on high end bluetooth devices. The S3 is also one of the first phones to sport this new codec. As a result, they sound spectacular. They're not my favorite headphones, but it proves that there can at least be an alternative.

    My Sony BT50s don't support this codec and my old droid x didn't either, so the ironic thing is that the BT50s sound worse on this phone than the X, but the MM100s sound worse on the X than the S3.

    When I root, I'll still set Mpeg12Sources=1 to see if it will send the mp3 file directly to the headset like it does on the X. The apt-x codec, though is much more flexible because it's lossless but can transcode any audio format to the equivalent of 44.1KHz PCM once it's decompressed.
  12. R. Kamidees

    R. Kamidees Member

    I can't tell you how glad I am to find I'm not the only one experiencing this. I've been scouring the Android boards for hours looking for some fix. I've found a few threads on XDA about the S2 having the same issue but no permanent fix other than flashing a new ROM (which I intend to do as soon as CM9, CM10, or MIUI come available).

    I have the VZW S3 and am experiencing the fuzzy sound when I connect it to my Sony dash unit. I've rooted it an set the SBC value to "0" but it won't connect to the A2DP (audio) mode on my deck.

    So now my values in the /system/etc/bluetooth/audio.conf file are set to:
    Code (Text):
    1. [A2DP]
    2. SBCSources=1
    3. MPEG12Sources=1
    And I feel like there is an improvement in the sound quality. It just did a quick 1 min, 3 track test and it may just be my ears, but I feel like there is less compression sound. Can anyone confirm that changing the MPEG12Sources value improves the A2DP output quality?
  13. sorka

    sorka Well-Known Member

    I haven't yet rooted myself. I was sort of waiting to see if the bootloader is cracked and if an exploit might appear that would allow rooting without writing the system image.

    But yes, your settings are correct as far as I know. You can't set SBC to 0 because SBC is required by all devices and your reciever/headphones won't accept the handshake if the sending device doesn't report that it supports SBC even if it decides to use something else like direct mpeg.

    In my case, since I'm listening with headphones, I'd be able to tell instantly if the problem was resolved. If setting MPEG12Sources to 1 or 2(you might try that too) results in any change at all, it will be because the handshake resolved on sending mp3 directly without transcoding to SBC. This would only be the case if your receiving device supports direct stream of mpeg. If it doesn't, then your only hope is increasing the bitpool to 53 in liba2dp.so which will get a transcoded rate of 328 kbps or so.

    I'm happy that apt-x works as long as I can find headphones that will be acceptable. I'm going to give the Sennheiser MM 500-x a try.
  14. socalwrx

    socalwrx New Member

    Id like to chime in on this as Im a big a2dp user. specifically, I pair my galaxy to my sony car stereo that Ive loved using for the past several years. I did notice something intersting:

    Ive mostly been streaming through spotify which I believe is 320kbps and sounds amazing in my car (sony BT unit, components, and sub)

    however, only a couple times have I listened to music with the stock player and I did notice a loss in quality.

    So is everyone whos noticing a loss in quality using the stock player? have you tried different apps or maybe even a third party music player such as poweramp (which by the way has a great equalizer). That in itself could help with some quality issues.

    I guess what Im getting at is, could this be somehow tied to the stock music player?
  15. sorka

    sorka Well-Known Member

    Yes, I've tried multiple third party apps and players and it makes no difference. I am using Creative Labs wp-350 headphones with aptX and the there is no loss with those as the S3 handshakes up to aptX and streams lossless to the headphones.

    Also, several people have reported that the issue is fixed in the about to be released firmware update.

Share This Page