accelerometer problemSupport


Last Updated:

  1. samuelmaskell

    samuelmaskell Well-Known Member This Topic's Starter

    Joined:
    May 11, 2009
    Messages:
    293
    Likes Received:
    3
    Hi,
    I just got my magic on friday and now the accelerometer is not work
    at all
    it just completely stopped
    and now matter what I do it won't work
    I have tried everything
    I even did a factory restore
    which deleted everything I had on the phone
    and then that didn't even help..
    I tried calling rogers but I was on hold for an hour and then I just gave up
    seriously not impressed
    I almost knew I wouldn't be impressed with rogers but I thought I would at least be fine as far as the actual phone is concerned
    what the heck?
    so any ideas?
    I don't see any accelerometer setting anywhere
    except for the one that lets you shut off auto-rotate
    any input would be greatly appreciated

    thanks,
    Sam
     

    Advertisement
  2. devolio

    devolio Well-Known Member

    Joined:
    Oct 30, 2008
    Messages:
    339
    Likes Received:
    37
    Hardware problem? These things happen
     
  3. justjimjpc

    justjimjpc Premium Member VIP Member

    Joined:
    Nov 3, 2008
    Messages:
    10,543
    Likes Received:
    210
    Safe mode reboot This procedure can clear a large number of problems and should be tried before a Hard Reset.

    1.) Turn phone off ... remove battery .. WAIT for at least two minutes.
    2.) Power On Phone while Holding MENU key ... Until ALL actions finish from Powering on phone ...
    ....... At the bottom left corner of the display in transparent text will be the words "Safe Mode"

    Now do ANOTHER Factory RESET ...

    3.) Power off phone again ... battery out ... wait two minutes
    4.) do a normal power on ...
    __________________

    This may help ... maybe not .... Let us know ... Good Luck ..
     
  4. samuelmaskell

    samuelmaskell Well-Known Member This Topic's Starter

    Joined:
    May 11, 2009
    Messages:
    293
    Likes Received:
    3
    oh okay, cool
    I'll definitely try that
    thanks for your help =]
     
  5. samuelmaskell

    samuelmaskell Well-Known Member This Topic's Starter

    Joined:
    May 11, 2009
    Messages:
    293
    Likes Received:
    3
    well nothing worked..
    but I went to rogers and they gave me a new phone without any hassle whatsoever
    it was awesome
    totally stoked
    I thought I was going to have a huge problem
     
  6. sushiguru

    sushiguru New Member

    Joined:
    Sep 25, 2009
    Messages:
    2
    Likes Received:
    0
    Just to say that I had the same problem (accelerometer stopped working) and a factory reset did the job for me (HTC Magic - How do I perform a factory reset?) and it's now working again.

    I think the problem was installing a game that used the accelerometer, but was designed for the G1. Don't know why this would be the case, but clearly an installed app crashed the OS.
     
  7. KlaymenDK

    KlaymenDK Well-Known Member

    Joined:
    May 29, 2009
    Messages:
    1,217
    Likes Received:
    130
    :cool: Awesome. I wish I could say the same. My Galaxy has the same problem (2 months old), and I've emailed the service center twice in a week and I haven't heard back from them. :mad::(
     
  8. linuxluver

    linuxluver Member

    Joined:
    Sep 30, 2009
    Messages:
    7
    Likes Received:
    0
    My accelerometer seems to have been disabled somehow. I'll follow the advice here and see if I can get it going again. It was fine a couple of days ago....but it slowly dawned on me nothing was rotating today. I've installed about 130 apps....so no idea which one has done it.

    Probably a factory reset required......or the hardware is broken. I haven't been harsh with it. No drops or bangs.
     
  9. linuxluver

    linuxluver Member

    Joined:
    Sep 30, 2009
    Messages:
    7
    Likes Received:
    0
    Backed up all the files on the sdcard. Then did a factory reset. Once done, the accelerometer was working fine again. The screen rotates just fine. Must have been an app I installed in the last few days. I installed so many (nice problem to have).....that I can't recall whch one messed it up and an uninstall probably would not have fixed it anyway.

    But I'll be testing the rotation after each app install as I rebuild the collection.
     
  10. justjimjpc

    justjimjpc Premium Member VIP Member

    Joined:
    Nov 3, 2008
    Messages:
    10,543
    Likes Received:
    210
    I had a wierd case of no accelo. as well... I did factory reset no help ...
    This went on for a week or more then it just started working again ... no explanation ...

    so give it some time ... maybe hung ... leaving battery out of the phone for hours might effect it too ??? good luck :cool:
     

Share This Page

Loading...