Acer Liquid E failed updateSupport


  1. DashRipRock

    DashRipRock Member

    Hello,

    My phone is/was running 2.2. It's and Acer Liguid E. Only a month old. I use Windows 7.

    I tried to update the phone using an acer.ca update. (311 issues)The phone stopped halfway through the update. Yellow Triangle appeared. Tried the few options to reset, clear cache. Tried loading the two folders needed on a new SD Card and still fails.

    The phone will not start up. It is stuck at the screen with the green guys. When the phone is plugged in the computer sees the phone loads the drivers but the SDCard is never mounted.

    Can the phone be fixed or is toast? I can send it to FIDO to be fixed but if I can do myself that would be best. Not sure what FIDO would charge.

    Phone isn't that old but I didn't buy it from FIDO so no warranty from them. Acer Canada told me I can't send it to them because they don't fix phones. They say it's under warranty because I registered the phone online with them. But they didn't offer up a place to take it other than FIDO.

    Thanks
    Dash

    Advertisement
    :
  2. thor124

    thor124 Well-Known Member

    Hi Dash,

    Put the files on the SD card, UNPLUG THE PHONE FROM THE COMPUTER, turn it off, start it up with the indicated key combo, and see if that works. Updates installed from a SD card do not require a connection to the computer and that may be the source of your issue.

    My two cents.

    thor124
  3. DashRipRock

    DashRipRock Member

    I have tried every key combo, battery in/out I could find in this Forum. Nothing works. I am trying to avoid sending it to FIDO for repair. But it's looking like I might have to. Not sure how much I am willing to spend to get it working.
  4. DashRipRock

    DashRipRock Member

    Fixed it today! Kind of forgot about it this summer. I tried to get Fido to help in July but they were no help. Acer can suck it because they were no help also. I decided to take another crack at it this weekend. Finally got the phone to except a new bin. Using the Acer download tool. Tried a few bins till got one that worked.
Loading...

Share This Page